summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-26 19:02:44 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:07:04 +0000
commite380b48602db316c7d12d328192eadc52e5be861 (patch)
tree78d1c6d7742c79216b01fb0b739adea44c85dc51 /meta
parentf9f549d06fd787f93c9c0af607683d0521fcd827 (diff)
downloadopenembedded-core-e380b48602db316c7d12d328192eadc52e5be861.tar.gz
classes/autotools_stage.bbclass: Add autotools_stage class to simplify recipes using standard autotools
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/autotools_stage.bbclass5
-rw-r--r--meta/packages/atk/atk.inc6
-rw-r--r--meta/packages/avahi/avahi.inc2
-rw-r--r--meta/packages/avahi/avahi_0.6.23.bb4
-rw-r--r--meta/packages/beecrypt/beecrypt_3.1.0.bb6
-rw-r--r--meta/packages/cairo/cairo.inc2
-rw-r--r--meta/packages/claws-mail/claws-mail.inc6
-rw-r--r--meta/packages/clutter/aaina.inc7
-rw-r--r--meta/packages/clutter/clutter-box2d.inc6
-rw-r--r--meta/packages/clutter/clutter-cairo.inc6
-rw-r--r--meta/packages/clutter/clutter-gst.inc6
-rw-r--r--meta/packages/clutter/clutter-gtk.inc6
-rw-r--r--meta/packages/clutter/clutter-helix.inc6
-rw-r--r--meta/packages/clutter/clutter.inc6
-rw-r--r--meta/packages/clutter/table.inc6
-rw-r--r--meta/packages/clutter/tidy.inc6
-rw-r--r--meta/packages/connman/connman_git.bb6
-rw-r--r--meta/packages/drm/libdrm_2.4.0.bb6
-rw-r--r--meta/packages/drm/libdrm_git.bb6
-rw-r--r--meta/packages/eds/eds-dbus_2.20.0.bb6
-rw-r--r--meta/packages/eds/eds-dbus_svn.bb6
-rw-r--r--meta/packages/file/file_4.18.bb6
-rw-r--r--meta/packages/galago/libgalago_0.5.2.bb6
-rw-r--r--meta/packages/gmp/gmp.inc6
-rw-r--r--meta/packages/gnome/gnome-keyring_2.20.bb6
-rw-r--r--meta/packages/gsm/gsmd.inc6
-rw-r--r--meta/packages/gstreamer/gst-plugins.inc6
-rw-r--r--meta/packages/gstreamer/gstreamer_0.10.20.bb6
-rw-r--r--meta/packages/gupnp/gssdp_0.6.2.bb6
-rw-r--r--meta/packages/gupnp/gupnp_0.12.2.bb7
-rw-r--r--meta/packages/gypsy/gypsy.inc2
-rw-r--r--meta/packages/gypsy/gypsy_0.6.bb2
-rw-r--r--meta/packages/icu/icu-3.6.inc2
-rw-r--r--meta/packages/icu/icu_3.6.bb4
-rw-r--r--meta/packages/iso-codes/iso-codes_3.3.bb7
-rw-r--r--meta/packages/libetpan/libetpan_0.54.bb6
-rw-r--r--meta/packages/libexif/libexif_0.6.16.bb6
-rw-r--r--meta/packages/libgcrypt/libgcrypt.inc6
-rw-r--r--meta/packages/libgdbus/libgdbus_git.bb6
-rw-r--r--meta/packages/wbxml/wbxml2_0.9.2.bb6
-rw-r--r--meta/packages/webkit/webkit-gtk_svn.bb6
-rw-r--r--meta/packages/wv/wv_1.2.0.bb6
-rw-r--r--meta/packages/xcb/libpthread-stubs_0.1.bb6
-rw-r--r--meta/packages/xcb/libxcb.inc6
-rw-r--r--meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb6
-rw-r--r--meta/packages/xorg-app/xorg-app-common.inc6
-rw-r--r--meta/packages/xorg-driver/xf86-driver-common.inc6
-rw-r--r--meta/packages/xorg-lib/xorg-lib-common.inc6
-rw-r--r--meta/packages/xorg-proto/xorg-proto-common.inc6
-rw-r--r--meta/packages/xorg-util/xorg-util-common.inc6
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-common.inc6
51 files changed, 53 insertions, 231 deletions
diff --git a/meta/classes/autotools_stage.bbclass b/meta/classes/autotools_stage.bbclass
new file mode 100644
index 0000000000..010117c250
--- /dev/null
+++ b/meta/classes/autotools_stage.bbclass
@@ -0,0 +1,5 @@
+inherit autotools
+
+do_stage () {
+ autotools_stage_all
+} \ No newline at end of file
diff --git a/meta/packages/atk/atk.inc b/meta/packages/atk/atk.inc
index 5f81cdf67e..9256dfbac8 100644
--- a/meta/packages/atk/atk.inc
+++ b/meta/packages/atk/atk.inc
@@ -5,10 +5,6 @@ LICENSE = "LGPL"
DEPENDS = "glib-2.0 gtk-doc-native"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
EXTRA_OECONF = "--disable-glibtest"
-
-do_stage () {
- autotools_stage_all
-}
diff --git a/meta/packages/avahi/avahi.inc b/meta/packages/avahi/avahi.inc
index 419b787b5f..8bc9f1b610 100644
--- a/meta/packages/avahi/avahi.inc
+++ b/meta/packages/avahi/avahi.inc
@@ -13,7 +13,7 @@ SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \
file://99avahi-autoipd \
file://initscript.patch;patch=1"
-inherit autotools pkgconfig update-rc.d
+inherit autotools_stage pkgconfig update-rc.d
EXTRA_OECONF = "--with-distro=debian \
--with-avahi-priv-access-group=adm \
diff --git a/meta/packages/avahi/avahi_0.6.23.bb b/meta/packages/avahi/avahi_0.6.23.bb
index 642b6b916c..87876ac6f2 100644
--- a/meta/packages/avahi/avahi_0.6.23.bb
+++ b/meta/packages/avahi/avahi_0.6.23.bb
@@ -6,7 +6,3 @@ PR = "r8"
FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
${sysconfdir}/avahi/avahi-autoipd.action \
${sysconfdir}/dhcp3/*/avahi-autoipd"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/beecrypt/beecrypt_3.1.0.bb b/meta/packages/beecrypt/beecrypt_3.1.0.bb
index 947ca56689..78ff5cad29 100644
--- a/meta/packages/beecrypt/beecrypt_3.1.0.bb
+++ b/meta/packages/beecrypt/beecrypt_3.1.0.bb
@@ -7,11 +7,7 @@ HOMEPAGE="http://sourceforge.net/projects/beecrypt"
SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
file://x64fix.patch;patch=1"
-inherit autotools
+inherit autotools_stage
acpaths=""
EXTRA_OECONF="--with-arch=${TARGET_ARCH} --enable-shared --enable-static"
-
-do_stage () {
- autotools_stage_all
-}
diff --git a/meta/packages/cairo/cairo.inc b/meta/packages/cairo/cairo.inc
index 015e649e64..5618233063 100644
--- a/meta/packages/cairo/cairo.inc
+++ b/meta/packages/cairo/cairo.inc
@@ -8,7 +8,7 @@ LICENSE = "MPL LGPL"
require cairo-fpu.inc
EXTRA_OECONF += "${@get_cairo_fpu_setting(bb, d)}"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
do_stage () {
autotools_stage_all
diff --git a/meta/packages/claws-mail/claws-mail.inc b/meta/packages/claws-mail/claws-mail.inc
index be184f9022..fcd4a1dd7f 100644
--- a/meta/packages/claws-mail/claws-mail.inc
+++ b/meta/packages/claws-mail/claws-mail.inc
@@ -39,7 +39,7 @@ EXTRA_OECONF = "--disable-aspell-test \
CFLAGS += "-D_GNU_SOURCE"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
do_install_append() {
install -d ${D}${datadir}/applications
@@ -48,10 +48,6 @@ do_install_append() {
install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
}
-do_stage () {
- autotools_stage_all
-}
-
#python populate_packages_prepend () {
# abiword_libdir = bb.data.expand('${libdir}/claws-mail/plugins', d)
#
diff --git a/meta/packages/clutter/aaina.inc b/meta/packages/clutter/aaina.inc
index 1baccc730c..29a0e0c0d6 100644
--- a/meta/packages/clutter/aaina.inc
+++ b/meta/packages/clutter/aaina.inc
@@ -4,9 +4,4 @@ LICENSE = "GPL"
DEPENDS = "clutter-0.6 libxml2 gtk+ neon"
-inherit autotools pkgconfig
-
-do_stage () {
- autotools_stage_all
-}
-
+inherit autotools_stage pkgconfig
diff --git a/meta/packages/clutter/clutter-box2d.inc b/meta/packages/clutter/clutter-box2d.inc
index c5cd3283e2..7e279a2a04 100644
--- a/meta/packages/clutter/clutter-box2d.inc
+++ b/meta/packages/clutter/clutter-box2d.inc
@@ -7,11 +7,7 @@ DEPENDS = "clutter-0.8"
# The main clutter lib is machine specific so we need to be too
PACKAGE_ARCH = "${MACHINE_ARCH}"
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
do_install_append () {
install -d ${D}${bindir}
diff --git a/meta/packages/clutter/clutter-cairo.inc b/meta/packages/clutter/clutter-cairo.inc
index 3a94c35ad6..2e6e3e5ee0 100644
--- a/meta/packages/clutter/clutter-cairo.inc
+++ b/meta/packages/clutter/clutter-cairo.inc
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-cairo"
PACKAGES =+ "${PN}-examples"
FILES_${PN}-examples = "${bindir}/flowers ${bindir}/clock"
-inherit autotools pkgconfig
-
-do_stage () {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
diff --git a/meta/packages/clutter/clutter-gst.inc b/meta/packages/clutter/clutter-gst.inc
index ad921bd0c0..c3a659767c 100644
--- a/meta/packages/clutter/clutter-gst.inc
+++ b/meta/packages/clutter/clutter-gst.inc
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-gst"
PACKAGES =+ "${PN}-examples"
FILES_${PN}-examples = "${bindir}/video-player ${bindir}/video-sink ${bindir}/audio"
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
diff --git a/meta/packages/clutter/clutter-gtk.inc b/meta/packages/clutter/clutter-gtk.inc
index 0545571b44..bbecee548c 100644
--- a/meta/packages/clutter/clutter-gtk.inc
+++ b/meta/packages/clutter/clutter-gtk.inc
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-gtk"
PACKAGES =+ "${PN}-examples"
FILES_${PN}-examples = "${bindir}/gtk-clutter-test ${bindir}/gtk-clutter-events ${bindir}/gtk-clutter-multistage"
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
diff --git a/meta/packages/clutter/clutter-helix.inc b/meta/packages/clutter/clutter-helix.inc
index 6e0612ad3a..7b17185612 100644
--- a/meta/packages/clutter/clutter-helix.inc
+++ b/meta/packages/clutter/clutter-helix.inc
@@ -9,9 +9,5 @@ FILESPATH = "${FILE_DIRNAME}/clutter-helix"
PACKAGES =+ "${PN}-examples"
FILES_${PN}-examples = "${bindir}/video-player ${bindir}/audio-player"
-inherit autotools pkgconfig gtk-doc
-
-do_stage () {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig gtk-doc
diff --git a/meta/packages/clutter/clutter.inc b/meta/packages/clutter/clutter.inc
index 1caa1c74e9..7e9f99269e 100644
--- a/meta/packages/clutter/clutter.inc
+++ b/meta/packages/clutter/clutter.inc
@@ -45,7 +45,7 @@ PACKAGE_ARCH_menlow = "${MACHINE_ARCH}"
FILESPATH = "${FILE_DIRNAME}/clutter"
-inherit autotools pkgconfig gtk-doc
+inherit autotools_stage pkgconfig gtk-doc
PACKAGES =+ "clutter-examples"
FILES_clutter-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
@@ -58,7 +58,3 @@ do_configure_prepend() {
sed -i s:doc/reference/Makefile::g ${S}/configure.ac
sed -i s:doc::g ${S}/Makefile.am
}
-
-do_stage () {
- autotools_stage_all
-}
diff --git a/meta/packages/clutter/table.inc b/meta/packages/clutter/table.inc
index b07b39dc1e..6a5b32ccda 100644
--- a/meta/packages/clutter/table.inc
+++ b/meta/packages/clutter/table.inc
@@ -4,14 +4,10 @@ LICENSE = "LGPL"
DEPENDS = "clutter-gst-0.6 gnome-vfs"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
do_install() {
install -d ${D}${bindir}
install -m 0755 ${S}/table ${D}${bindir}/table
}
-#do_stage () {
-# autotools_stage_all
-#}
-
diff --git a/meta/packages/clutter/tidy.inc b/meta/packages/clutter/tidy.inc
index d1f11976cd..14ec4ca9a8 100644
--- a/meta/packages/clutter/tidy.inc
+++ b/meta/packages/clutter/tidy.inc
@@ -8,7 +8,7 @@ BASE_CONF = "--disable-gtk-doc"
DEPENDS = "${STDDEPENDS}"
EXTRA_OECONF = "${BASE_CONF}"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
PACKAGES =+ "tidy-examples"
FILES_tidy-examples = "${bindir}/test-*"
@@ -18,7 +18,3 @@ do_configure_prepend() {
sed -i s:docs/reference/Makefile::g ${S}/configure.ac
sed -i s:docs::g ${S}/Makefile.am
}
-
-do_stage () {
- autotools_stage_all
-}
diff --git a/meta/packages/connman/connman_git.bb b/meta/packages/connman/connman_git.bb
index e8ad21ef98..5175f45522 100644
--- a/meta/packages/connman/connman_git.bb
+++ b/meta/packages/connman/connman_git.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://moblin.org/repos/projects/connman.git;protocol=http \
INITSCRIPT_NAME = "connman"
INITSCRIPT_PARAMS = "defaults 22"
-inherit autotools pkgconfig update-rc.d
+inherit autotools_stage pkgconfig update-rc.d
do_install_append() {
install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
@@ -42,7 +42,3 @@ python populate_packages_prepend() {
plugin_name = bb.data.expand('${PN}-plugin-%s', d)
do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/drm/libdrm_2.4.0.bb b/meta/packages/drm/libdrm_2.4.0.bb
index d5e716014f..29b3c4cbf8 100644
--- a/meta/packages/drm/libdrm_2.4.0.bb
+++ b/meta/packages/drm/libdrm_2.4.0.bb
@@ -4,8 +4,4 @@ SRC_URI = "http://dri.freedesktop.org/libdrm/libdrm-${PV}.tar.bz2"
PROVIDES = "drm"
DEPENDS = "libpthread-stubs"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
diff --git a/meta/packages/drm/libdrm_git.bb b/meta/packages/drm/libdrm_git.bb
index 27d913c8d7..4765894b37 100644
--- a/meta/packages/drm/libdrm_git.bb
+++ b/meta/packages/drm/libdrm_git.bb
@@ -12,8 +12,4 @@ PV = "2.4.0+git${SRCREV}"
LEAD_SONAME = "libdrm.so"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
diff --git a/meta/packages/eds/eds-dbus_2.20.0.bb b/meta/packages/eds/eds-dbus_2.20.0.bb
index 424194fd19..76694ce5a6 100644
--- a/meta/packages/eds/eds-dbus_2.20.0.bb
+++ b/meta/packages/eds/eds-dbus_2.20.0.bb
@@ -11,7 +11,7 @@ SRC_URI = "http://ftp.gnome.org/pub/GNOME/mobile/2.23/2.23.92/sources/evolution-
S = "${WORKDIR}/evolution-data-server-dbus-${PV}"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
# -ldb needs this on some platforms
LDFLAGS += "-lpthread"
@@ -20,10 +20,6 @@ do_configure_append () {
cp ${WORKDIR}/iconv-detect.h ${S}
}
-do_stage () {
- autotools_stage_all
-}
-
EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
--with-soup --with-libdb=${STAGING_DIR_HOST}${layout_prefix} \
--disable-smime --disable-nss --disable-nntp --disable-gtk-doc"
diff --git a/meta/packages/eds/eds-dbus_svn.bb b/meta/packages/eds/eds-dbus_svn.bb
index 81d9e83cfb..83b875bd43 100644
--- a/meta/packages/eds/eds-dbus_svn.bb
+++ b/meta/packages/eds/eds-dbus_svn.bb
@@ -13,7 +13,7 @@ SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
S = "${WORKDIR}/trunk"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
# -ldb needs this on some platforms
LDFLAGS += "-lpthread"
@@ -22,10 +22,6 @@ do_configure_append () {
cp ${WORKDIR}/iconv-detect.h ${S}
}
-do_stage () {
- autotools_stage_all
-}
-
EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
--with-soup --with-libdb=${STAGING_DIR_HOST}${layout_prefix} \
--disable-smime --disable-nss --disable-nntp --disable-gtk-doc"
diff --git a/meta/packages/file/file_4.18.bb b/meta/packages/file/file_4.18.bb
index a98c68009e..c26228a364 100644
--- a/meta/packages/file/file_4.18.bb
+++ b/meta/packages/file/file_4.18.bb
@@ -9,14 +9,10 @@ SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
file://filesystems"
S = "${WORKDIR}/file-${PV}"
-inherit autotools
+inherit autotools_stage
do_configure_prepend() {
sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
cp ${WORKDIR}/dump ${S}/magic/Magdir/
cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/galago/libgalago_0.5.2.bb b/meta/packages/galago/libgalago_0.5.2.bb
index 167f044f62..d4dd3aaba3 100644
--- a/meta/packages/galago/libgalago_0.5.2.bb
+++ b/meta/packages/galago/libgalago_0.5.2.bb
@@ -7,10 +7,6 @@ SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz
file://pkgconfig.patch;patch=1 "
PR = "r1"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
EXTRA_OECONF = "--disable-tests --disable-check"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/gmp/gmp.inc b/meta/packages/gmp/gmp.inc
index 71ea128bc5..2f99c2f1fd 100644
--- a/meta/packages/gmp/gmp.inc
+++ b/meta/packages/gmp/gmp.inc
@@ -7,12 +7,8 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/gmp/gmp-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
file://amd64.patch;patch=1"
-inherit autotools
+inherit autotools_stage
ARM_INSTRUCTION_SET = "arm"
acpaths = ""
-
-do_stage () {
- autotools_stage_all
-}
diff --git a/meta/packages/gnome/gnome-keyring_2.20.bb b/meta/packages/gnome/gnome-keyring_2.20.bb
index c18d9f19f4..fb0f641a42 100644
--- a/meta/packages/gnome/gnome-keyring_2.20.bb
+++ b/meta/packages/gnome/gnome-keyring_2.20.bb
@@ -3,7 +3,7 @@ SECTION = "x11/gnome"
PR = "r1"
-inherit autotools gnome pkgconfig
+inherit autotools_stage gnome pkgconfig
DEPENDS = "gtk+ libgcrypt"
@@ -17,7 +17,3 @@ do_install_append () {
}
FILES_${PN} += "${datadir}/dbus-1/services"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/gsm/gsmd.inc b/meta/packages/gsm/gsmd.inc
index 5e59bd660c..6039d6133d 100644
--- a/meta/packages/gsm/gsmd.inc
+++ b/meta/packages/gsm/gsmd.inc
@@ -13,7 +13,7 @@ SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
file://default"
S = "${WORKDIR}/gsm"
-inherit autotools pkgconfig update-rc.d
+inherit autotools_stage pkgconfig update-rc.d
# handle update-rc.d RDEPENDS manually, we don't need it on
# anything but gsmd
RDEPENDS_append = ""
@@ -21,10 +21,6 @@ RDEPENDS_append = ""
INITSCRIPT_NAME = "gsmd"
INITSCRIPT_PARAMS = "defaults 35"
-do_stage() {
- autotools_stage_all
-}
-
do_install_append() {
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/gsmd ${D}/${sysconfdir}/init.d/
diff --git a/meta/packages/gstreamer/gst-plugins.inc b/meta/packages/gstreamer/gst-plugins.inc
index 85775391ea..94cb9310d7 100644
--- a/meta/packages/gstreamer/gst-plugins.inc
+++ b/meta/packages/gstreamer/gst-plugins.inc
@@ -3,7 +3,7 @@ SECTION = "multimedia"
PRIORITY = "optional"
DEPENDS = "gstreamer"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2"
@@ -27,8 +27,4 @@ python populate_packages_prepend () {
do_split_packages(d, gst_libdir, 'libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)', extra_depends=bb.data.expand('${PN}-dev',d))
}
-do_stage() {
- autotools_stage_all
-}
-
ALLOW_EMPTY = "1"
diff --git a/meta/packages/gstreamer/gstreamer_0.10.20.bb b/meta/packages/gstreamer/gstreamer_0.10.20.bb
index 32f6523b2a..512df0b4bd 100644
--- a/meta/packages/gstreamer/gstreamer_0.10.20.bb
+++ b/meta/packages/gstreamer/gstreamer_0.10.20.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://www.gstreamer.net/"
DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native"
PR = "r1"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
file://gst-inspect-check-error.patch;patch=1 \
@@ -26,10 +26,6 @@ do_configure_prepend() {
PARALLEL_MAKE = ""
-do_stage() {
- autotools_stage_all
-}
-
FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
FILES_${PN}-dbg += " ${libdir}/gstreamer-0.10/.debug/"
diff --git a/meta/packages/gupnp/gssdp_0.6.2.bb b/meta/packages/gupnp/gssdp_0.6.2.bb
index 034d2f5fe3..09e12e2c63 100644
--- a/meta/packages/gupnp/gssdp_0.6.2.bb
+++ b/meta/packages/gupnp/gssdp_0.6.2.bb
@@ -3,12 +3,8 @@ DEPENDS = "glib-2.0 libsoup-2.4 libglade"
SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
PACKAGES =+ "gssdp-tools"
FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/gupnp/gupnp_0.12.2.bb b/meta/packages/gupnp/gupnp_0.12.2.bb
index e1a0206d90..2b615f0602 100644
--- a/meta/packages/gupnp/gupnp_0.12.2.bb
+++ b/meta/packages/gupnp/gupnp_0.12.2.bb
@@ -3,12 +3,7 @@ DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2"
SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
-
+inherit autotools_stage pkgconfig
FILES_${PN} = "${libdir}/*.so.*"
FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
diff --git a/meta/packages/gypsy/gypsy.inc b/meta/packages/gypsy/gypsy.inc
index 456d9fb6a5..82978029c8 100644
--- a/meta/packages/gypsy/gypsy.inc
+++ b/meta/packages/gypsy/gypsy.inc
@@ -3,7 +3,7 @@ LICENSE = "GPL"
SECTION = "x11"
DEPENDS = "glib-2.0 dbus bluez-libs dbus-glib"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
EXTRA_OECONF += "--with-distro=debian"
diff --git a/meta/packages/gypsy/gypsy_0.6.bb b/meta/packages/gypsy/gypsy_0.6.bb
index 68a07ffcd7..4301e8275d 100644
--- a/meta/packages/gypsy/gypsy_0.6.bb
+++ b/meta/packages/gypsy/gypsy_0.6.bb
@@ -5,6 +5,6 @@ DEPENDS = "glib-2.0 dbus bluez-libs dbus-glib libxslt"
SRC_URI = "http://gypsy.freedesktop.org/gypsy-releases/gypsy-${PV}.tar.gz"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
FILES_${PN} += "/usr/share/dbus-1/services/"
diff --git a/meta/packages/icu/icu-3.6.inc b/meta/packages/icu/icu-3.6.inc
index 04fc8420ab..1c7eda21e2 100644
--- a/meta/packages/icu/icu-3.6.inc
+++ b/meta/packages/icu/icu-3.6.inc
@@ -7,7 +7,7 @@ S = "${WORKDIR}/icu/source"
PARALLEL_MAKE = ""
-inherit autotools pkgconfig binconfig
+inherit autotools_stage pkgconfig binconfig
do_configure() {
libtoolize --force
diff --git a/meta/packages/icu/icu_3.6.bb b/meta/packages/icu/icu_3.6.bb
index 5760ddb2bc..5b341470ff 100644
--- a/meta/packages/icu/icu_3.6.bb
+++ b/meta/packages/icu/icu_3.6.bb
@@ -34,8 +34,4 @@ FILES_libiculx = "${libdir}/libiculx.so.*"
FILES_libicutu = "${libdir}/libicutu.so.*"
FILES_libicuio = "${libdir}/libicuio.so.*"
-do_stage() {
- autotools_stage_all
-}
-
diff --git a/meta/packages/iso-codes/iso-codes_3.3.bb b/meta/packages/iso-codes/iso-codes_3.3.bb
index 98425111d5..50ea791926 100644
--- a/meta/packages/iso-codes/iso-codes_3.3.bb
+++ b/meta/packages/iso-codes/iso-codes_3.3.bb
@@ -7,13 +7,8 @@ PACKAGE_ARCH = "all"
SRC_URI = "ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/iso-codes-${PV}.tar.gz"
-inherit autotools
+inherit autotools_stage
FILES_${PN}-dev="${datadir}/pkgconfig/iso-codes.pc"
FILES_${PN}="${datadir}/xml/iso-codes/ \
${datadir}/iso-codes/"
-
-do_stage() {
- autotools_stage_all
-}
-
diff --git a/meta/packages/libetpan/libetpan_0.54.bb b/meta/packages/libetpan/libetpan_0.54.bb
index 7ad0f54f2c..6a20560c07 100644
--- a/meta/packages/libetpan/libetpan_0.54.bb
+++ b/meta/packages/libetpan/libetpan_0.54.bb
@@ -9,15 +9,11 @@ PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
file://cxx-is-here.patch;patch=1"
-inherit autotools pkgconfig gettext binconfig
+inherit autotools_stage pkgconfig gettext binconfig
EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
PARALLEL_MAKE = ""
-do_stage() {
- autotools_stage_all
-}
-
FILES_${PN} = "${libdir}/lib*.so.*"
FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"
diff --git a/meta/packages/libexif/libexif_0.6.16.bb b/meta/packages/libexif/libexif_0.6.16.bb
index 2f896352db..0be23df60b 100644
--- a/meta/packages/libexif/libexif_0.6.16.bb
+++ b/meta/packages/libexif/libexif_0.6.16.bb
@@ -5,14 +5,10 @@ LICENSE = "LGPL"
SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
-inherit autotools
+inherit autotools_stage
do_configure_append() {
sed -i s:doc\ binary:binary:g Makefile
}
AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/libgcrypt/libgcrypt.inc b/meta/packages/libgcrypt/libgcrypt.inc
index 5fe2b49121..ccbb4b7066 100644
--- a/meta/packages/libgcrypt/libgcrypt.inc
+++ b/meta/packages/libgcrypt/libgcrypt.inc
@@ -7,16 +7,12 @@ DEPENDS = "libgpg-error"
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
file://add-pkgconfig-support.patch;patch=1"
-inherit autotools binconfig pkgconfig
+inherit autotools_stage binconfig pkgconfig
EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
ARM_INSTRUCTION_SET = "arm"
-do_stage() {
- autotools_stage_all
-}
-
# move libgcrypt-config into -dev package
FILES_${PN} = "${libdir}/lib*.so.*"
FILES_${PN}-dev += "${bindir} ${libdir}/pkgconfig/*.pc"
diff --git a/meta/packages/libgdbus/libgdbus_git.bb b/meta/packages/libgdbus/libgdbus_git.bb
index 30cffe3997..d29afa546c 100644
--- a/meta/packages/libgdbus/libgdbus_git.bb
+++ b/meta/packages/libgdbus/libgdbus_git.bb
@@ -7,8 +7,4 @@ S = "${WORKDIR}/git"
SRC_URI = "git://moblin.org/repos/projects/libgdbus.git;protocol=http"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
diff --git a/meta/packages/wbxml/wbxml2_0.9.2.bb b/meta/packages/wbxml/wbxml2_0.9.2.bb
index 85b533044d..14c3f6acc3 100644
--- a/meta/packages/wbxml/wbxml2_0.9.2.bb
+++ b/meta/packages/wbxml/wbxml2_0.9.2.bb
@@ -6,17 +6,13 @@ DEPENDS = "libxml2 sed-native expat"
SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
file://no-doc-install.patch;patch=1"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
do_configure_append() {
sed -i s:-I/usr/include::g Makefile
sed -i s:-I/usr/include::g */Makefile
}
-do_stage() {
- autotools_stage_all
-}
-
PACKAGES += "${PN}-tools"
FILES_${PN}-tools = "${bindir}"
diff --git a/meta/packages/webkit/webkit-gtk_svn.bb b/meta/packages/webkit/webkit-gtk_svn.bb
index 3dd7f13029..a5765e84b1 100644
--- a/meta/packages/webkit/webkit-gtk_svn.bb
+++ b/meta/packages/webkit/webkit-gtk_svn.bb
@@ -23,7 +23,7 @@ SRC_URI = "\
S = "${WORKDIR}/"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
EXTRA_OECONF = "\
--enable-debug=no \
@@ -48,10 +48,6 @@ do_compile_prepend() {
cd ${S}
}
-do_stage() {
- autotools_stage_all
-}
-
PACKAGES =+ "${PN}launcher-dbg ${PN}launcher libjavascriptcore"
FILES_${PN}launcher = "${bindir}/GtkLauncher"
FILES_${PN}launcher-dbg = "${bindir}/.debug/GtkLauncher"
diff --git a/meta/packages/wv/wv_1.2.0.bb b/meta/packages/wv/wv_1.2.0.bb
index 7f06f587c4..6fdb0fe8c6 100644
--- a/meta/packages/wv/wv_1.2.0.bb
+++ b/meta/packages/wv/wv_1.2.0.bb
@@ -7,12 +7,8 @@ PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/wvware/wv-${PV}.tar.gz \
file://pkgconfig.patch;patch=1"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
S = "${WORKDIR}/${PN}-${PV}"
EXTRA_OECONF = ""
-
-do_stage () {
- autotools_stage_all
-}
diff --git a/meta/packages/xcb/libpthread-stubs_0.1.bb b/meta/packages/xcb/libpthread-stubs_0.1.bb
index 211170a902..826bff7678 100644
--- a/meta/packages/xcb/libpthread-stubs_0.1.bb
+++ b/meta/packages/xcb/libpthread-stubs_0.1.bb
@@ -11,11 +11,7 @@ PARALLEL_MAKE = ""
SRC_URI = "http://xcb.freedesktop.org/dist/libpthread-stubs-${PV}.tar.bz2"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${DEBPV})"
diff --git a/meta/packages/xcb/libxcb.inc b/meta/packages/xcb/libxcb.inc
index bdce8a2e6b..ee46f598c0 100644
--- a/meta/packages/xcb/libxcb.inc
+++ b/meta/packages/xcb/libxcb.inc
@@ -40,7 +40,7 @@ FILES_libxcb-xtest = "${libdir}/libxcb-xtest.so.*"
FILES_libxcb-xv = "${libdir}/libxcb-xv.so.*"
FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
# XCBPROTO_XCBINCLUDEDIR is setup based on `pkg-config --variable=xcbincludedir xcb-proto`
# but the xcbincludedir variable doesn't point into the staging area, so it needs some
@@ -49,7 +49,3 @@ do_configure_prepend () {
sed -i "s|XCBPROTO_XCBINCLUDEDIR=|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/|" \
${S}/configure.ac
}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb b/meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb
index cb448be243..19a08d7a31 100644
--- a/meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb
+++ b/meta/packages/xkeyboard-config/xkeyboard-config_1.3.bb
@@ -6,11 +6,7 @@ PR = "r2"
SRC_URI = "http://xlibs.freedesktop.org/xkbdesc/xkeyboard-config-${PV}.tar.bz2"
-inherit autotools
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage
do_install_append () {
install -d ${D}/usr/share/X11/xkb/compiled
diff --git a/meta/packages/xorg-app/xorg-app-common.inc b/meta/packages/xorg-app/xorg-app-common.inc
index cd7f654be2..2dc659a0fa 100644
--- a/meta/packages/xorg-app/xorg-app-common.inc
+++ b/meta/packages/xorg-app/xorg-app-common.inc
@@ -10,10 +10,6 @@ SRC_URI = "${XORG_MIRROR}/individual/app/${XORG_PN}-${PV}.tar.bz2"
S = "${WORKDIR}/${XORG_PN}-${PV}"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
FILES_${PN} += " /usr/lib/X11/${XORG_PN}"
diff --git a/meta/packages/xorg-driver/xf86-driver-common.inc b/meta/packages/xorg-driver/xf86-driver-common.inc
index 308d06e0b1..3cb8cd021e 100644
--- a/meta/packages/xorg-driver/xf86-driver-common.inc
+++ b/meta/packages/xorg-driver/xf86-driver-common.inc
@@ -16,11 +16,7 @@ S = "${WORKDIR}/${XORG_PN}-${PV}"
FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
# AC_CHECK_FILE doesn't work when cross compiling, so we create a replacement
# macro that simply assumes the test succeeds.
diff --git a/meta/packages/xorg-lib/xorg-lib-common.inc b/meta/packages/xorg-lib/xorg-lib-common.inc
index eae0e92a8d..66b453f67f 100644
--- a/meta/packages/xorg-lib/xorg-lib-common.inc
+++ b/meta/packages/xorg-lib/xorg-lib-common.inc
@@ -9,10 +9,6 @@ SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.bz2"
S = "${WORKDIR}/${XORG_PN}-${PV}"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
EXTRA_OECONF = "--enable-malloc0returnsnull"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/xorg-proto/xorg-proto-common.inc b/meta/packages/xorg-proto/xorg-proto-common.inc
index c7188a766a..e70afd02bf 100644
--- a/meta/packages/xorg-proto/xorg-proto-common.inc
+++ b/meta/packages/xorg-proto/xorg-proto-common.inc
@@ -9,12 +9,8 @@ SRC_URI = "${XORG_MIRROR}/individual/proto/${XORG_PN}-${PV}.tar.bz2"
S = "${WORKDIR}/${XORG_PN}-${PV}"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${DEBPV})"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta/packages/xorg-util/xorg-util-common.inc b/meta/packages/xorg-util/xorg-util-common.inc
index 56aae30725..e8a9d01d15 100644
--- a/meta/packages/xorg-util/xorg-util-common.inc
+++ b/meta/packages/xorg-util/xorg-util-common.inc
@@ -8,8 +8,4 @@ SRC_URI = "${XORG_MIRROR}/individual/util/${XORG_PN}-${PV}.tar.gz"
S = "${WORKDIR}/${XORG_PN}-${PV}"
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
+inherit autotools_stage pkgconfig
diff --git a/meta/packages/xorg-xserver/xserver-xf86-common.inc b/meta/packages/xorg-xserver/xserver-xf86-common.inc
index d31e97a0e2..5a10ecf994 100644
--- a/meta/packages/xorg-xserver/xserver-xf86-common.inc
+++ b/meta/packages/xorg-xserver/xserver-xf86-common.inc
@@ -16,7 +16,7 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
S = "${WORKDIR}/${XORG_PN}-${PV}"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
PACKAGES =+ "${PN}-utils"
@@ -33,10 +33,6 @@ CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
SRC_URI += "file://macro_tweak.patch;patch=1"
-do_stage() {
- autotools_stage_all
-}
-
do_install_append () {
install -d ${D}/${sysconfdir}/X11
install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/