summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/dpkg/dpkg.inc19
-rw-r--r--meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb2
2 files changed, 9 insertions, 12 deletions
diff --git a/meta/recipes-devtools/dpkg/dpkg.inc b/meta/recipes-devtools/dpkg/dpkg.inc
index aa5f90e8b3..8c2511dc43 100644
--- a/meta/recipes-devtools/dpkg/dpkg.inc
+++ b/meta/recipes-devtools/dpkg/dpkg.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Package maintenance system for Debian."
LICENSE = "GPL"
SECTION = "base"
-INC_PR = "r4"
+INC_PR = "r5"
SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.bz2 \
file://ignore_extra_fields.patch"
@@ -20,17 +20,14 @@ inherit autotools gettext perlnative
DPKG_INIT_POSITION = "98"
-pkg_postinst_dpkg () {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
- install -d $D/${sysconfdir}/rcS.d
+do_install_prepend () {
+ install -d ${D}/${sysconfdir}/rcS.d
# this happens at S98 where our good 'ole packages script used to run
- echo -e "#!/bin/sh
- dpkg --configure -a
- rm -f /${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
-" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
- chmod 0755 $D/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
-fi
+ printf "#!/bin/sh
+dpkg --configure -a
+rm -f ${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
+" > ${D}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
+ chmod 0755 ${D}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
}
do_configure () {
diff --git a/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb b/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
index 91535d38e3..99197c0b7f 100644
--- a/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
+++ b/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
@@ -20,6 +20,6 @@ EXTRA_OECONF = "--without-static-progs \
BBCLASSEXTEND = "native"
-do_install_append_virtclass-native () {
+do_install_append () {
rm ${D}${bindir}/update-alternatives
}