summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbsetup_0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsb/lsbsetup_0.9.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbsetup_0.9.bb21
1 files changed, 3 insertions, 18 deletions
diff --git a/meta/recipes-extended/lsb/lsbsetup_0.9.bb b/meta/recipes-extended/lsb/lsbsetup_0.9.bb
index f5b40acb8b..ce49fc641c 100644
--- a/meta/recipes-extended/lsb/lsbsetup_0.9.bb
+++ b/meta/recipes-extended/lsb/lsbsetup_0.9.bb
@@ -9,24 +9,9 @@ LIC_FILES_CHKSUM = "file://LSB_Setup.sh;md5=c7360d77e08a7f4f2fa66acf28012e7e"
SRC_URI = "file://LSB_Setup.sh"
-LSBFILE=${POKYBASE}/meta/recipes-extended/lsbsetup/lsb/LSB_Setup.sh
-
S=${WORKDIR}
-do_unpack(){
- cp ${LSBFILE} ${WORKDIR}
-}
-
-
-do_patch(){
- :
-}
-
-do_configure(){
- :
-}
-
-do_install(){
- mkdir -p ${D}/usr/bin
- cp ${LSBFILE} ${D}/usr/bin
+do_install() {
+ # Only install file if it has a contents
+ install -m 0644 ${S}/LSB_Setup.sh ${D}/usr/bin
}