summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch')
-rw-r--r--meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch b/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch
new file mode 100644
index 0000000000..d96b038999
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-1.0/install-examples.patch
@@ -0,0 +1,28 @@
+Install the examples to $libdir/clutter/.
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+Upstream-Status: Inappropriate
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index 4b9b449..232cd19 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -31,7 +31,7 @@ LDADD = \
+ AM_CFLAGS = $(CLUTTER_CFLAGS) $(GDK_PIXBUF_CFLAGS) $(MAINTAINER_CFLAGS)
+
+ AM_CPPFLAGS = \
+- -DTESTS_DATADIR=\""$(abs_top_srcdir)/tests/data"\" \
++ -DTESTS_DATADIR=\""$(exampledir)"\" \
+ -DG_DISABLE_SINGLE_INCLUDES \
+ -DGLIB_DISABLE_DEPRECATION_WARNINGS \
+ -I$(top_srcdir) \
+@@ -39,6 +39,8 @@ AM_CPPFLAGS = \
+ -I$(top_srcdir)/clutter \
+ -I$(top_builddir)/clutter
+
+-noinst_PROGRAMS = $(all_examples)
++exampledir = $(pkglibdir)/examples
++example_PROGRAMS = $(all_examples)
++example_DATA = $(top_srcdir)/tests/data/redhand.png
+
+ -include $(top_srcdir)/build/autotools/Makefile.am.gitignore