summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/xorg-lib')
-rw-r--r--meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb24
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb.inc64
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch13
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.9.3.bb12
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_git.bb12
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util-image_0.3.9.bb11
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util-keysyms_0.3.9.bb10
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util-renderutil_0.3.8.bb13
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util-wm_0.3.9.bb11
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util.inc23
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util_0.3.9.bb8
11 files changed, 201 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb b/meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb
new file mode 100644
index 0000000000..ad046d19c8
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Library that provides weak aliases for pthread functions"
+DESCRIPTION = "This library provides weak aliases for pthread functions \
+not provided in libc or otherwise available by default."
+HOMEPAGE = "http://xcb.freedesktop.org"
+BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=XCB"
+SECTION = "x11/libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6edc1fea03d959f0c2d743fe5ca746ad"
+
+PARALLEL_MAKE = ""
+#DEPENDS = "xcb-proto xproto libxau libxslt-native"
+# DEPENDS += "xsltproc-native gperf-native"
+
+SRC_URI = "http://xcb.freedesktop.org/dist/libpthread-stubs-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "e8fa31b42e13f87e8f5a7a2b731db7ee"
+SRC_URI[sha256sum] = "35b6d54e3cc6f3ba28061da81af64b9a92b7b757319098172488a660e3d87299"
+
+inherit autotools pkgconfig
+
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-graphics/xorg-lib/libxcb.inc b/meta/recipes-graphics/xorg-lib/libxcb.inc
new file mode 100644
index 0000000000..91df1be8c5
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb.inc
@@ -0,0 +1,64 @@
+SUMMARY = "XCB: The X protocol C binding library"
+DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
+for Xlib featuring a small footprint, latency hiding, direct access to \
+the protocol, improved threading support, and extensibility."
+HOMEPAGE = "http://xcb.freedesktop.org"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SECTION = "x11/libs"
+LICENSE = "MIT-X"
+
+PARALLEL_MAKE = ""
+DEPENDS = "xcb-proto xproto libxau libxslt-native xcb-proto-native libpthread-stubs"
+# DEPENDS += "xsltproc-native gperf-native"
+
+SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2"
+# file://xcbincludedir.patch"
+
+PACKAGES =+ "libxcb-composite libxcb-damage libxcb-dpms libxcb-glx \
+ libxcb-randr libxcb-record libxcb-render libxcb-res \
+ libxcb-screensaver libxcb-shape libxcb-shm libxcb-sync \
+ libxcb-xevie libxcb-xf86dri libxcb-xfixes libxcb-xlib \
+ libxcb-xprint libxcb-xtest libxcb-xv libxcb-xvmc \
+ libxcb-dri2 libxcb-dri3 libxcb-present"
+
+FILES_${PN} = "${libdir}/libxcb.so.*"
+#FILES_${PN}-dev = "${libdir}/libxcb.* ${libdir}/pkgconfig/*.pc ${includedir}/xcb/*.h"
+FILES_libxcb-dri2 = "${libdir}/libxcb-dri2.so.*"
+FILES_libxcb-dri3 = "${libdir}/libxcb-dri3.so.*"
+FILES_libxcb-composite = "${libdir}/libxcb-composite.so.*"
+FILES_libxcb-damage = "${libdir}/libxcb-damage.so.*"
+FILES_libxcb-dpms = "${libdir}/libxcb-dpms.so.*"
+FILES_libxcb-glx = "${libdir}/libxcb-glx.so.*"
+FILES_libxcb-randr = "${libdir}/libxcb-randr.so.*"
+FILES_libxcb-record = "${libdir}/libxcb-record.so.*"
+FILES_libxcb-render = "${libdir}/libxcb-render.so.*"
+FILES_libxcb-res = "${libdir}/libxcb-res.so.*"
+FILES_libxcb-screensaver = "${libdir}/libxcb-screensaver.so.*"
+FILES_libxcb-shape = "${libdir}/libxcb-shape.so.*"
+FILES_libxcb-shm = "${libdir}/libxcb-shm.so.*"
+FILES_libxcb-sync = "${libdir}/libxcb-sync.so.*"
+FILES_libxcb-xevie = "${libdir}/libxcb-xevie.so.*"
+FILES_libxcb-xf86dri = "${libdir}/libxcb-xf86dri.so.*"
+FILES_libxcb-xfixes = "${libdir}/libxcb-xfixes.so.*"
+FILES_libxcb-xinerama = "${libdir}/libxcb-xinerama.so.*"
+FILES_libxcb-xlib = "${libdir}/libxcb-xlib.so.*"
+FILES_libxcb-xprint = "${libdir}/libxcb-xprint.so.*"
+FILES_libxcb-xtest = "${libdir}/libxcb-xtest.so.*"
+FILES_libxcb-xv = "${libdir}/libxcb-xv.so.*"
+FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
+FILES_libxcb-present = "${libdir}/libxcb-present.so.*"
+
+inherit autotools pkgconfig pythonnative
+
+# XCBPROTO_XCBINCLUDEDIR is set based on `pkg-config --variable=xcbincludedir xcb-proto`
+# but the xcbincludedir variable doesn't point into the staging area, so it needs some
+# tweaking here:
+do_configure_prepend () {
+ sed -i "s|XCBPROTO_XCBINCLUDEDIR=\`|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/\`|" \
+ ${S}/configure.ac
+ sed -i "s|XCBPROTO_XCBPYTHONDIR=\`|XCBPROTO_XCBPYTHONDIR=${STAGING_DIR_HOST}/\`|" \
+ ${S}/configure.ac
+}
diff --git a/meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch b/meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch
new file mode 100644
index 0000000000..d858a63b72
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb/xcbincludedir.patch
@@ -0,0 +1,13 @@
+Upstream-Status: Inappropriate [configuration]
+
+--- libxcb-1.0.orig/configure.ac 2006-11-23 15:33:01.000000000 +0000
++++ libxcb-1.0/configure.ac 2008-09-10 20:29:12.000000000 +0100
+@@ -50,7 +50,7 @@
+
+ # Find the xcb-proto protocol descriptions
+ AC_MSG_CHECKING(XCBPROTO_XCBINCLUDEDIR)
+-XCBPROTO_XCBINCLUDEDIR=`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
++XCBPROTO_XCBINCLUDEDIR=$PKG_CONFIG_SYSROOT_DIR/`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
+ AC_SUBST(XCBPROTO_XCBINCLUDEDIR)
+
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.9.3.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.9.3.bb
new file mode 100644
index 0000000000..7374f10a4e
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.9.3.bb
@@ -0,0 +1,12 @@
+include libxcb.inc
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
+
+
+DEPENDS += "libxdmcp"
+
+PACKAGES =+ "libxcb-xinerama"
+
+SRC_URI[md5sum] = "1ca999ca94f760d917ef2d8466a88742"
+SRC_URI[sha256sum] = "aad09d223fcb5bd345ce4d1737f178a557b6f2e201128e1ee3c83af46028018b"
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_git.bb b/meta/recipes-graphics/xorg-lib/libxcb_git.bb
new file mode 100644
index 0000000000..1482b7af5b
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_git.bb
@@ -0,0 +1,12 @@
+DEFAULT_PREFERENCE = "-1"
+
+include libxcb.inc
+
+SRCREV = "625ed596cae6dd8175aeb6cb6f26784928042f22"
+PV = "1.1.90.1+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "git://anongit.freedesktop.org/git/xcb/libxcb"
+S = "${WORKDIR}/git"
+
+PACKAGES =+ "libxcb-xinerama"
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util-image_0.3.9.bb b/meta/recipes-graphics/xorg-lib/xcb-util-image_0.3.9.bb
new file mode 100644
index 0000000000..1d36893f93
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xcb-util-image_0.3.9.bb
@@ -0,0 +1,11 @@
+require xcb-util.inc
+
+DEPENDS += "xcb-util"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://image/xcb_image.c;endline=24;md5=eafdf965cfb89955fdedf75054223fb4 \
+ file://image/xcb_image.h;beginline=4;endline=27;md5=48cd25ae55e7de525fe1e1a3a7672e1c"
+
+SRC_URI[md5sum] = "fabb80b36490b00fc91289e2c7f66770"
+SRC_URI[sha256sum] = "d35a3c0eaae171f5081ec127fb9cec174b716ce5d78196a87f2785376da021df"
+
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util-keysyms_0.3.9.bb b/meta/recipes-graphics/xorg-lib/xcb-util-keysyms_0.3.9.bb
new file mode 100644
index 0000000000..39ead34e92
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xcb-util-keysyms_0.3.9.bb
@@ -0,0 +1,10 @@
+require xcb-util.inc
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://keysyms/keysyms.c;endline=30;md5=2f8de023ed823bb92f0b47900574ea9e \
+ "
+
+SRC_URI[md5sum] = "64e4aad2d48cd4a92e2da13b9f35bfd2"
+SRC_URI[sha256sum] = "7be1acf053bd68a1910fc861b2cbcbad7637b5618590dd5484d43a96f7995c6e"
+
+
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util-renderutil_0.3.8.bb b/meta/recipes-graphics/xorg-lib/xcb-util-renderutil_0.3.8.bb
new file mode 100644
index 0000000000..93b34e8402
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xcb-util-renderutil_0.3.8.bb
@@ -0,0 +1,13 @@
+require xcb-util.inc
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://renderutil/glyph.c;endline=24;md5=c517c483b8d726234ec94f9169236661 \
+ file://renderutil/util.c;endline=20;md5=6e0bfc44fb13298c0f4694eb70dc80d4 \
+ file://renderutil/xcb_renderutil.h;md5=c8732d30d204d3b55e956489f635cefb \
+ "
+
+SRC_URI[md5sum] = "b346ff598ee093c141f836fbc0f8f721"
+SRC_URI[sha256sum] = "9789a5c55728fa7bae374d9fdf1c61095869bdc68561911760879095644c7452"
+
+
+
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util-wm_0.3.9.bb b/meta/recipes-graphics/xorg-lib/xcb-util-wm_0.3.9.bb
new file mode 100644
index 0000000000..944e0d88b1
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xcb-util-wm_0.3.9.bb
@@ -0,0 +1,11 @@
+require xcb-util.inc
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://ewmh/ewmh.c;endline=27;md5=63fd80552d7dc886f4eb267610d5bb9d \
+ file://ewmh/xcb_ewmh.h;beginline=4;endline=30;md5=73b589f90ef90b4a43998955daad5cd8 \
+ file://icccm/icccm.c;endline=28;md5=e2b3240a0c197e8977adde2a5cf18d50 \
+ file://icccm/xcb_icccm.h;beginline=4;endline=31;md5=393772b7b07b9868d479d538238c1d8a \
+ "
+
+SRC_URI[md5sum] = "c612aae7ffe2e70fe743efab9c5548e9"
+SRC_URI[sha256sum] = "038f9bdb917b1f6d98a164f57dfb32212a102d771ab6f03de49fef3786746030"
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util.inc b/meta/recipes-graphics/xorg-lib/xcb-util.inc
new file mode 100644
index 0000000000..7dad545c33
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xcb-util.inc
@@ -0,0 +1,23 @@
+SUMMARY = "XCB: The X protocol C binding utilities"
+DESCRIPTION = "The xcb-util module provides a number of libraries which \
+sit on top of libxcb, the core X protocol library, and some of the \
+extension libraries. These experimental libraries provide convenience \
+functions and interfaces which make the raw X protocol more usable. Some \
+of the libraries also provide client-side code which is not strictly \
+part of the X protocol but which have traditionally been provided by \
+Xlib."
+HOMEPAGE = "http://xcb.freedesktop.org/XcbUtil/"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
+
+LICENSE = "MIT"
+
+SECTION = "x11/libs"
+
+DEPENDS = "libxcb"
+DEPENDS += "gperf-native"
+
+PARALLEL_MAKE = ""
+
+SRC_URI = "http://xcb.freedesktop.org/dist/${BPN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util_0.3.9.bb b/meta/recipes-graphics/xorg-lib/xcb-util_0.3.9.bb
new file mode 100644
index 0000000000..c5d8858115
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xcb-util_0.3.9.bb
@@ -0,0 +1,8 @@
+require xcb-util.inc
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://src/xcb_aux.c;endline=30;md5=ae305b9c2a38f9ba27060191046a6460 \
+ file://src/xcb_event.h;endline=27;md5=627be355aee59e1b8ade80d5bd90fad9"
+
+SRC_URI[md5sum] = "01dcc7a16d5020530552712710646ea2"
+SRC_URI[sha256sum] = "c611259c0ab20fd76f79f48f4684843c18ea9c967eba78a45e8b3636315c18c4"