aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-06-15 15:51:31 +0200
committerLeon Woestenberg <leon@sidebranch.com>2009-06-15 15:51:31 +0200
commit573fd638e702d2d4f5b7f621839fb47f74251364 (patch)
treed235ca2524e979784b7ce59300fc0026a7d5b90e
parente007568f88392e204f8739eed67c6ba126958700 (diff)
downloadopenembedded-573fd638e702d2d4f5b7f621839fb47f74251364.tar.gz
u-boot: Added 2009.06. Machine mpc8315e-rdb uses it now.
Newest u-boot release 2009.06. Also, as the mpc8315e-rdb boards come with a buggy u-boot (possible invalid access due to missing guard, when speculatively executing libz code), its u-boot version is now set to 2009.06 which contains the fix. Same applies to mpc8313e-rdb, to be upgraded later. Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-rw-r--r--conf/checksums.ini4
-rw-r--r--conf/machine/mpc8315e-rdb.conf2
-rw-r--r--recipes/u-boot/u-boot_2009.06.bb16
3 files changed, 21 insertions, 1 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index b813805a59..0a42c6b3f9 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -23526,6 +23526,10 @@ sha256=0c0afa2816482e087987f71958b656ff0c122032f5e3897a8d17daca5bc14115
md5=285e2184d2efef50e0fe43b71d2a7b11
sha256=a2889bee9c45575b284564dbc27cf3dc6cb9833d4ff643976a1b3dba2d763f86
+[ftp://ftp.denx.de/pub/u-boot/u-boot-2009.06.tar.bz2]
+md5=dfbe65c1e31bb7de5f5b03d50de192b5
+sha256=b0037cf21b67779ef5a0c585b32e46bde3b78df889484c78bb4318c9b448f560
+
[http://linux.omap.com/pub/bootloader/2430sdp/source/u-boot-SEP1106.tar.gz]
md5=49c07dec9e1be69fd01d46f47ec03731
sha256=a090786113b02647413ebc15888af269f2e6d50f73cbb94b0619cc1702911dae
diff --git a/conf/machine/mpc8315e-rdb.conf b/conf/machine/mpc8315e-rdb.conf
index 40f289f55c..d7e733bd66 100644
--- a/conf/machine/mpc8315e-rdb.conf
+++ b/conf/machine/mpc8315e-rdb.conf
@@ -13,7 +13,7 @@ MACHINE_FEATURES = "kernel26 usbhost pci ext2 uboot"
KERNEL_IMAGETYPE = "uImage"
-PREFERRED_VERSION_u-boot ?= "1.3.2"
+PREFERRED_VERSION_u-boot ?= "2009.06"
UBOOT_MACHINE = "MPC8315ERDB_config"
UBOOT_ENTRYPOINT = "0"
UBOOT_LOADADDRESS = "0"
diff --git a/recipes/u-boot/u-boot_2009.06.bb b/recipes/u-boot/u-boot_2009.06.bb
new file mode 100644
index 0000000000..3ea182a15f
--- /dev/null
+++ b/recipes/u-boot/u-boot_2009.06.bb
@@ -0,0 +1,16 @@
+PR = "r0"
+require u-boot.inc
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mpc8315e-rdb = "1"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
+
+TARGET_LDFLAGS = ""
+
+inherit base
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+}