aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-04-28 18:56:54 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-05-20 23:15:14 -0300
commit57c5f8879e63e9d1e53552edf258f56a9ce1a2b2 (patch)
treedc7b1964c3a644d4f89aed838f1b357b31be2e1c
parented4f8aa703d1f93178837c3c52f82b916a7160ac (diff)
downloadopenembedded-57c5f8879e63e9d1e53552edf258f56a9ce1a2b2.tar.gz
system-config-printer: add to provide python-cupshelpers to hal-cups-utils
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/system-config-printer/system-config-printer_1.1.7.bb22
2 files changed, 26 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 7fe35667d0..96a2272f88 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -22378,6 +22378,10 @@ sha256=26c05ef7666881eb1d60291a4293e67d75dbf048ca8a30f6b9eb3dc86ad1b6b0
md5=d7b8f27b83ff080ff824177d65a7dae0
sha256=0a63da1c99b6a9b6a93b6fd0a9391c7d8216f658d2bea0ba81999e261c6b6649
+[http://cyberelk.net/tim/data/system-config-printer/1.1/system-config-printer-1.1.7.tar.bz2]
+md5=a77bde5adc5ee8822b0764ff786ccc09
+sha256=fdd50cb114151c66b8180c0ce90ba0e99f77a69770ac21598a87be935eec2224
+
[ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/sysvinit-2.86.tar.gz]
md5=7d5d61c026122ab791ac04c8a84db967
sha256=035f98fae17d9cff002993c564ccc83dc4ed136127172caeff872b6abdb679d8
diff --git a/recipes/system-config-printer/system-config-printer_1.1.7.bb b/recipes/system-config-printer/system-config-printer_1.1.7.bb
new file mode 100644
index 0000000000..5a6d6320ac
--- /dev/null
+++ b/recipes/system-config-printer/system-config-printer_1.1.7.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "cups Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "cups"
+RDEPENDS_python-cupshelpers += "python-pprint python-netclient python-misc"
+PR = "r2"
+
+SRC_URI = "http://cyberelk.net/tim/data/${PN}/1.1/${PN}-${PV}.tar.bz2"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ # disable xmlto usage since we won't use manpages
+ sed -i 's,xmlto,echo xmlto,g' ${S}/Makefile*
+}
+
+PACKAGES += "python-cupshelpers"
+
+FILES_${PN} = "" # we're not going to support it for now
+FILES_python-cupshelpers = "${libdir}"