aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Brabec <sbrabec@suse.cz>2010-07-24 15:39:52 +0200
committerStanislav Brabec <sbrabec@suse.cz>2010-07-24 15:39:52 +0200
commitefc1b721a617a3a895bc4c1ff17d02258e5458e2 (patch)
treeb871f4f00784e13d64ef9065792b7b683b13f342
parentbf242510ce91aef3472a1ac4521410a867ea0964 (diff)
downloadopenembedded-efc1b721a617a3a895bc4c1ff17d02258e5458e2.tar.gz
udev: Fix possible multiple mounting of /dev, increment PR.
* http://lists.linuxtogo.org/pipermail/openembedded-devel/2010-July/021663.html Signed-off-by: Stanislav Brabec <utx@penguin.cz> Acked-by: Andrea Adami <andrea.adami@gmail.com>
-rw-r--r--recipes/udev/udev-124/init2
-rw-r--r--recipes/udev/udev-141/init2
-rw-r--r--recipes/udev/udev-151/init2
-rw-r--r--recipes/udev/udev-154/init2
-rw-r--r--recipes/udev/udev.inc2
-rw-r--r--recipes/udev/udev_124.bb2
-rw-r--r--recipes/udev/udev_141.bb2
-rw-r--r--recipes/udev/udev_151.bb2
-rw-r--r--recipes/udev/udev_154.bb2
9 files changed, 9 insertions, 9 deletions
diff --git a/recipes/udev/udev-124/init b/recipes/udev/udev-124/init
index efe44708ca..1009381b3d 100644
--- a/recipes/udev/udev-124/init
+++ b/recipes/udev/udev-124/init
@@ -29,7 +29,7 @@ export ACTION=add
echo -n "Starting udev"
# mount the tmpfs on /dev, if not already done
-LANG=C awk "\$2 == \"/dev\" && \$4 == \"tmpfs\" { exit 1 }" /proc/mounts && {
+LANG=C awk "\$2 == \"/dev\" && \$3 == \"tmpfs\" { exit 1 }" /proc/mounts && {
mount -n -o mode=0755 -t tmpfs none "/dev"
mkdir -m 0755 /dev/pts
mkdir -m 0755 /dev/shm
diff --git a/recipes/udev/udev-141/init b/recipes/udev/udev-141/init
index 66705e6767..efd9c23a0e 100644
--- a/recipes/udev/udev-141/init
+++ b/recipes/udev/udev-141/init
@@ -29,7 +29,7 @@ export ACTION=add
echo "Starting udev"
# mount the tmpfs on /dev, if not already done
-LANG=C awk "\$2 == \"/dev\" && \$4 == \"tmpfs\" { exit 1 }" /proc/mounts && {
+LANG=C awk "\$2 == \"/dev\" && \$3 == \"tmpfs\" { exit 1 }" /proc/mounts && {
mount -n -o mode=0755 -t tmpfs none "/dev"
mkdir -m 0755 /dev/pts
mkdir -m 1777 /dev/shm
diff --git a/recipes/udev/udev-151/init b/recipes/udev/udev-151/init
index f4dc5de2f5..fea2ca66ee 100644
--- a/recipes/udev/udev-151/init
+++ b/recipes/udev/udev-151/init
@@ -29,7 +29,7 @@ export ACTION=add
echo "Starting udev"
# mount the tmpfs on /dev, if not already done
-LANG=C awk "\$2 == \"/dev\" && \$4 == \"tmpfs\" { exit 1 }" /proc/mounts && {
+LANG=C awk "\$2 == \"/dev\" && \$3 == \"tmpfs\" { exit 1 }" /proc/mounts && {
mount -n -o mode=0755 -t tmpfs none "/dev"
mkdir -m 0755 /dev/pts
mkdir -m 1777 /dev/shm
diff --git a/recipes/udev/udev-154/init b/recipes/udev/udev-154/init
index f4dc5de2f5..fea2ca66ee 100644
--- a/recipes/udev/udev-154/init
+++ b/recipes/udev/udev-154/init
@@ -29,7 +29,7 @@ export ACTION=add
echo "Starting udev"
# mount the tmpfs on /dev, if not already done
-LANG=C awk "\$2 == \"/dev\" && \$4 == \"tmpfs\" { exit 1 }" /proc/mounts && {
+LANG=C awk "\$2 == \"/dev\" && \$3 == \"tmpfs\" { exit 1 }" /proc/mounts && {
mount -n -o mode=0755 -t tmpfs none "/dev"
mkdir -m 0755 /dev/pts
mkdir -m 1777 /dev/shm
diff --git a/recipes/udev/udev.inc b/recipes/udev/udev.inc
index f4f1c4008d..2edc10b0bd 100644
--- a/recipes/udev/udev.inc
+++ b/recipes/udev/udev.inc
@@ -14,7 +14,7 @@ SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://init \
file://udev-compat-wrapper-patch"
-INC_PR = "r27"
+INC_PR = "r28"
inherit update-rc.d autotools pkgconfig
diff --git a/recipes/udev/udev_124.bb b/recipes/udev/udev_124.bb
index 30b049976d..d0d54206dc 100644
--- a/recipes/udev/udev_124.bb
+++ b/recipes/udev/udev_124.bb
@@ -5,7 +5,7 @@ RPROVIDES_${PN} = "hotplug"
require udev.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
LD = "${CC}"
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index 3ef9f7d660..798590c3b7 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE = "-1"
require udev.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += "file://mount.blacklist \
file://run.rules \
diff --git a/recipes/udev/udev_151.bb b/recipes/udev/udev_151.bb
index ce97a7b675..eb0d6a9f38 100644
--- a/recipes/udev/udev_151.bb
+++ b/recipes/udev/udev_151.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r12"
+PR = "r13"
# Untested
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/udev/udev_154.bb b/recipes/udev/udev_154.bb
index 60322151f3..3cf6358819 100644
--- a/recipes/udev/udev_154.bb
+++ b/recipes/udev/udev_154.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r0"
+PR = "r1"
# Untested
DEFAULT_PREFERENCE = "-1"