aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bind
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-12-03 11:51:48 +1030
committerKhem Raj <raj.khem@gmail.com>2010-12-03 12:24:13 -0800
commite967f4332e999be44734e659f32a1b500ab60ca1 (patch)
treebd499d16cf88eb5d67f472b8444965128206fce4 /recipes/bind
parent42b898e30b3ae731de6902ff8e72919ac12cbf75 (diff)
downloadopenembedded-e967f4332e999be44734e659f32a1b500ab60ca1.tar.gz
bind: Fix for DISTRO=micro: s|/usr/bin|${bindir}|
This is a conservative change to fix micro. Bind needs more attention as the latest in tree version is from 2008 and several vulnerabilities have been found and fixed since then. If you are doing anything except using bind as a resolver, please don't use these recipes. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/bind')
-rw-r--r--recipes/bind/bind_9.3.1.bb2
-rw-r--r--recipes/bind/bind_9.3.4-P1.bb2
-rw-r--r--recipes/bind/bind_9.3.5-P1.bb2
-rw-r--r--recipes/bind/bind_9.3.6.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/recipes/bind/bind_9.3.1.bb b/recipes/bind/bind_9.3.1.bb
index 33b1de28e3..268253e95f 100644
--- a/recipes/bind/bind_9.3.1.bb
+++ b/recipes/bind/bind_9.3.1.bb
@@ -17,7 +17,7 @@ INITSCRIPT_PARAMS = "defaults"
do_install_append() {
- rm "${D}/usr/bin/nslookup"
+ rm "${D}${bindir}/nslookup"
install -d "${D}/etc/bind"
install -d "${D}/etc/init.d"
install -m 644 ${S}/conf/* "${D}/etc/bind"
diff --git a/recipes/bind/bind_9.3.4-P1.bb b/recipes/bind/bind_9.3.4-P1.bb
index 45bf608fb3..70c261e9f7 100644
--- a/recipes/bind/bind_9.3.4-P1.bb
+++ b/recipes/bind/bind_9.3.4-P1.bb
@@ -19,7 +19,7 @@ INITSCRIPT_NAME = "bind"
INITSCRIPT_PARAMS = "defaults"
do_install_append() {
- rm "${D}/usr/bin/nslookup"
+ rm "${D}${bindir}/nslookup"
install -d "${D}/etc/bind"
install -d "${D}/etc/init.d"
install -m 644 ${S}/conf/* "${D}/etc/bind"
diff --git a/recipes/bind/bind_9.3.5-P1.bb b/recipes/bind/bind_9.3.5-P1.bb
index d105dfc859..bb9826184d 100644
--- a/recipes/bind/bind_9.3.5-P1.bb
+++ b/recipes/bind/bind_9.3.5-P1.bb
@@ -19,7 +19,7 @@ INITSCRIPT_NAME = "bind"
INITSCRIPT_PARAMS = "defaults"
do_install_append() {
- rm "${D}/usr/bin/nslookup"
+ rm "${D}${bindir}/nslookup"
install -d "${D}/etc/bind"
install -d "${D}/etc/init.d"
install -m 644 ${S}/conf/* "${D}/etc/bind"
diff --git a/recipes/bind/bind_9.3.6.bb b/recipes/bind/bind_9.3.6.bb
index 1412a68573..b10d6e84ed 100644
--- a/recipes/bind/bind_9.3.6.bb
+++ b/recipes/bind/bind_9.3.6.bb
@@ -24,7 +24,7 @@ FILES_${PN}-utils = "${bindir}/host ${bindir}/dig ${bindir}/nslookup"
FILES_${PN}-dev += "${bindir}/isc-config.h"
do_install_append() {
- rm "${D}/usr/bin/nslookup"
+ rm "${D}${bindir}/nslookup"
install -d "${D}/etc/bind"
install -d "${D}/etc/init.d"
install -m 644 ${S}/conf/* "${D}/etc/bind"