aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/boost
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/boost
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/boost')
-rw-r--r--recipes/boost/boost_1.33.1.bb8
-rw-r--r--recipes/boost/boost_1.34.1.bb4
-rw-r--r--recipes/boost/boost_1.36.0.bb14
-rw-r--r--recipes/boost/boost_1.37.0.bb8
-rw-r--r--recipes/boost/boost_1.40.0.bb2
-rw-r--r--recipes/boost/boost_1.41.0.bb2
6 files changed, 19 insertions, 19 deletions
diff --git a/recipes/boost/boost_1.33.1.bb b/recipes/boost/boost_1.33.1.bb
index 3366238980..d712cf7c2c 100644
--- a/recipes/boost/boost_1.33.1.bb
+++ b/recipes/boost/boost_1.33.1.bb
@@ -3,10 +3,10 @@ PR = "${INC_PR}.1"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
- file://linux-uclibc.patch;apply=yes \
- file://atomic_count_gcc_atomicity.patch;apply=yes \
- file://gcc43.patch;apply=yes \
- file://gcc41.patch;apply=yes \
+ file://linux-uclibc.patch \
+ file://atomic_count_gcc_atomicity.patch \
+ file://gcc43.patch \
+ file://gcc41.patch \
"
diff --git a/recipes/boost/boost_1.34.1.bb b/recipes/boost/boost_1.34.1.bb
index 8a95df1ae3..35089b226e 100644
--- a/recipes/boost/boost_1.34.1.bb
+++ b/recipes/boost/boost_1.34.1.bb
@@ -13,8 +13,8 @@ PR = "6"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
- file://linux-uclibc.patch;apply=yes \
- file://${PV}-gcc43.patch;apply=yes \
+ file://linux-uclibc.patch \
+ file://${PV}-gcc43.patch \
"
S = "${WORKDIR}/${BOOST_P}"
diff --git a/recipes/boost/boost_1.36.0.bb b/recipes/boost/boost_1.36.0.bb
index 1b8e8e4d42..d5e7b0ff6e 100644
--- a/recipes/boost/boost_1.36.0.bb
+++ b/recipes/boost/boost_1.36.0.bb
@@ -3,13 +3,13 @@ include boost-36.inc
PR = "${INC_PR}.1"
SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
- file://arm-intrinsics.patch;apply=yes \
- file://01-no-serialization-test.patch;apply=yes \
- file://02-atomic-count-pthreads-on-arm.patch;apply=yes \
- file://03-exception-clone-destructor-fix.patch;apply=yes \
- file://gcc-44.diff;apply=yes \
- file://uclibc.patch;apply=yes \
- file://sscanf.patch;apply=yes \
+ file://arm-intrinsics.patch \
+ file://01-no-serialization-test.patch \
+ file://02-atomic-count-pthreads-on-arm.patch \
+ file://03-exception-clone-destructor-fix.patch \
+ file://gcc-44.diff \
+ file://uclibc.patch \
+ file://sscanf.patch \
"
BJAM_OPTS = '${BJAM_TOOLS} \
diff --git a/recipes/boost/boost_1.37.0.bb b/recipes/boost/boost_1.37.0.bb
index cb350c1bac..6daa475bfb 100644
--- a/recipes/boost/boost_1.37.0.bb
+++ b/recipes/boost/boost_1.37.0.bb
@@ -3,10 +3,10 @@ include boost-36.inc
PR = "${INC_PR}.1"
SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2;name=boost1370tarbz2 \
- file://arm-intrinsics.patch;apply=yes \
- file://02-atomic-count-pthreads-on-arm.patch;apply=yes \
- file://uclibc.patch;apply=yes \
- file://sscanf.patch;apply=yes \
+ file://arm-intrinsics.patch \
+ file://02-atomic-count-pthreads-on-arm.patch \
+ file://uclibc.patch \
+ file://sscanf.patch \
"
SRC_URI[boost1370tarbz2.md5sum] = "8d9f990bfb7e83769fa5f1d6f065bc92"
diff --git a/recipes/boost/boost_1.40.0.bb b/recipes/boost/boost_1.40.0.bb
index 92b5f10b75..194de8e37d 100644
--- a/recipes/boost/boost_1.40.0.bb
+++ b/recipes/boost/boost_1.40.0.bb
@@ -3,7 +3,7 @@ require boost-14x.inc
PR = "${INC_PR}.1"
SRC_URI = "http://sodium.resophonic.com/boost-cmake/1.40.0.cmake2/boost-1.40.0.cmake2.tar.gz \
- file://uclibc.patch;apply=yes \
+ file://uclibc.patch \
"
S = "${WORKDIR}/boost-1.40.0.cmake2"
diff --git a/recipes/boost/boost_1.41.0.bb b/recipes/boost/boost_1.41.0.bb
index 716b515c97..7a31629ca3 100644
--- a/recipes/boost/boost_1.41.0.bb
+++ b/recipes/boost/boost_1.41.0.bb
@@ -3,7 +3,7 @@ require boost-14x.inc
PR = "${INC_PR}.1"
SRC_URI = "http://sodium.resophonic.com/boost-cmake/1.41.0.cmake0/boost-1.41.0.cmake0.tar.gz;name=tarball \
- file://1.41.0_uclibc.patch;apply=yes \
+ file://1.41.0_uclibc.patch \
"
S = "${WORKDIR}/boost-1.41.0.cmake0"