aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bug-logrotate
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@buglabs.net>2010-11-11 15:00:36 +0100
committerStefan Schmidt <stefan@buglabs.net>2010-12-16 15:03:09 +0100
commit7570e05a2518b206f3e5808a3fae6ace6b064851 (patch)
treef8a77f260f111acbb651c3a54a750f4a394df9f6 /recipes/bug-logrotate
parent75306a9922d17a3b8fe0c49e37252d0d793f3edc (diff)
downloadopenembedded-7570e05a2518b206f3e5808a3fae6ace6b064851.tar.gz
bug-logrotate: Add logrotate config file for bug
Diffstat (limited to 'recipes/bug-logrotate')
-rw-r--r--recipes/bug-logrotate/bug-logrotate_0.1.bb13
-rw-r--r--recipes/bug-logrotate/files/bug-rules44
2 files changed, 57 insertions, 0 deletions
diff --git a/recipes/bug-logrotate/bug-logrotate_0.1.bb b/recipes/bug-logrotate/bug-logrotate_0.1.bb
new file mode 100644
index 0000000000..f9e77af556
--- /dev/null
+++ b/recipes/bug-logrotate/bug-logrotate_0.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Logrotate rules for BUG"
+RDEPENDS_${PN} = "logrotate"
+
+SRC_URI = "file://bug-rules"
+
+S = "${WORKDIR}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_install() {
+ install -d ${D}/etc/logrotate.d
+ install -m 0644 bug-rules ${D}/etc/logrotate.d/
+}
diff --git a/recipes/bug-logrotate/files/bug-rules b/recipes/bug-logrotate/files/bug-rules
new file mode 100644
index 0000000000..e8ae5afa1f
--- /dev/null
+++ b/recipes/bug-logrotate/files/bug-rules
@@ -0,0 +1,44 @@
+/var/log/felix.log
+{
+ rotate 7
+ daily
+ size 1M
+ missingok
+ notifempty
+ compress
+ postrotate
+ /etc/init.d/felix restart
+ endscript
+}
+
+/var/log/kern.log
+/var/log/debug
+/var/log/syslog
+{
+ rotate 7
+ daily
+ size 1M
+ missingok
+ notifempty
+ compress
+ postrotate
+ /etc/init.d/syslog-ng restart
+ endscript
+}
+
+/var/log/daemon.log
+/var/log/auth.log
+/var/log/user.log
+/var/log/cron.log
+/var/log/messages
+{
+ rotate 4
+ weekly
+ missingok
+ notifempty
+ compress
+ sharedscripts
+ postrotate
+ /etc/init.d/cron restart
+ endscript
+}