aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cdparanoia
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-12-05 21:52:36 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-12-05 21:53:28 +0100
commit769eb46d611450bd55264ab295830916fceaf279 (patch)
treea695fb2d2f44e1845685a23d526d6c4fb842f71b /recipes/cdparanoia
parent87a8f6bcb94dd4fa5fa714c42784e11af8f8ae03 (diff)
downloadopenembedded-769eb46d611450bd55264ab295830916fceaf279.tar.gz
cdparanoia_svn.bb: updated SVN version; fixed LICENSE, added pkgconfig stuff
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cdparanoia')
-rw-r--r--recipes/cdparanoia/cdparanoia_svn.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes/cdparanoia/cdparanoia_svn.bb b/recipes/cdparanoia/cdparanoia_svn.bb
index 5610450e7d..bdbad601d7 100644
--- a/recipes/cdparanoia/cdparanoia_svn.bb
+++ b/recipes/cdparanoia/cdparanoia_svn.bb
@@ -2,11 +2,11 @@
# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
# Released under the MIT license (see packages/COPYING)
-PR = "r3"
-LICENSE = "GPL"
+PR = "r0"
+LICENSE = "GPLv2"
PV = "10.2+svnr${SRCPV}"
-SRCREV = "16684"
+SRCREV = "17714"
SRC_URI = "svn://svn.xiph.org/trunk;module=cdparanoia;proto=http \
file://fixes10.patch \
@@ -19,7 +19,7 @@ S = "${WORKDIR}/cdparanoia"
PARALLEL_MAKE = ""
-inherit autotools
+inherit autotools pkgconfig
PACKAGES += "libcdparanoia libcdparanoia-dev libcdparanoia-static"
@@ -36,5 +36,7 @@ FILES_libcdparanoia-static = "${libdir}/*.a"
do_install() {
oe_runmake BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man/" \
- INCLUDEDIR="${D}/usr/include/" LIBDIR="${D}/usr/lib" install
+ INCLUDEDIR="${D}/usr/include/" LIBDIR="${D}/usr/lib" \
+ PKGCONFIGDIR="${D}/usr/lib/pkgconfig" \
+ install
}