aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/clutter/clutter.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/clutter/clutter.inc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/clutter/clutter.inc')
-rw-r--r--recipes/clutter/clutter.inc64
1 files changed, 64 insertions, 0 deletions
diff --git a/recipes/clutter/clutter.inc b/recipes/clutter/clutter.inc
new file mode 100644
index 0000000000..e900c43209
--- /dev/null
+++ b/recipes/clutter/clutter.inc
@@ -0,0 +1,64 @@
+DESCRIPTION = "Clutter graphics library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|beagleboard|overo|omap3evm)"
+
+STDDEPENDS = "virtual/libx11 gtk-doc-native pango glib-2.0 libxfixes gtk+"
+BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}"
+
+DEPENDS = "${STDDEPENDS} mesa"
+EXTRA_OECONF = "${BASE_CONF} --with-flavour=glx"
+
+DEPENDS_zylonite = "${STDDEPENDS} libgles-zylonite tslib"
+EXTRA_OECONF_zylonite = "${BASE_CONF} --with-flavour=eglnative"
+PACKAGE_ARCH_zylonite = "${MACHINE_ARCH}"
+LDFLAGS_append_zylonite = " -lnws -lstdc++ "
+
+DEPENDS_mx31litekit = "${STDDEPENDS} libgles-mx31 tslib"
+EXTRA_OECONF_mx31litekit = "${BASE_CONF} --with-flavour=eglnative"
+PACKAGE_ARCH_mx31litekit = "${MACHINE_ARCH}"
+LDFLAGS_append_mx31litekit = " -lpvrNULLWSEGL -lstdc++ "
+
+DEPENDS_omap-3430ldp = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_omap-3430ldp = "${BASE_CONF} --with-flavour=eglx"
+PACKAGE_ARCH_omap-3430ldp = "${MACHINE_ARCH}"
+
+DEPENDS_omap-3430sdp = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_omap-3430sdp = "${BASE_CONF} --with-flavour=eglx"
+PACKAGE_ARCH_omap-3430sdp = "${MACHINE_ARCH}"
+
+DEPENDS_beagleboard = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_beagleboard = "${BASE_CONF} --with-flavour=eglx --with-gles=2.0"
+PACKAGE_ARCH_beagleboard = "${MACHINE_ARCH}"
+
+DEPENDS_omap3evm = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_omap3evm = "${BASE_CONF} --with-flavour=eglx --with-gles=2.0"
+PACKAGE_ARCH_omap3evm = "${MACHINE_ARCH}"
+
+DEPENDS_overo = "${STDDEPENDS} libgles-omap3 tslib"
+EXTRA_OECONF_overo = "${BASE_CONF} --with-flavour=eglx --with-gles=2.0"
+PACKAGE_ARCH_overo = "${MACHINE_ARCH}"
+
+DEPENDS_mx31ads = "${STDDEPENDS} libgles-mx31 tslib"
+EXTRA_OECONF_mx31ads = "${BASE_CONF} --with-flavour=eglnative"
+PACKAGE_ARCH_mx31ads = "${MACHINE_ARCH}"
+LDFLAGS_append_mx31ads = " -lpvrNULLWSEGL -lstdc++ "
+
+inherit autotools pkgconfig gtk-doc
+
+PACKAGES =+ "clutter-examples"
+FILES_clutter-examples = "${bindir}/test-* ${pkgdatadir}/redhand.png"
+
+#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require clutter-fpu.inc
+
+#Fix up some weirdness in the docs
+do_configure_prepend() {
+ sed -i s:doc/reference/Makefile::g ${S}/configure.ac
+ sed -i s:doc::g ${S}/Makefile.am
+}
+
+do_stage () {
+ autotools_stage_all
+}