aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/connman
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-07 17:54:33 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-07 17:55:12 +0100
commit20e56bce4f4c951365b53e8c44d464a17f2ce79f (patch)
tree2b9c8edd26e8342b4c6b22e035b233136a8b3e44 /recipes/connman
parentef45af9139fe61af484f950477b97b57de16e4b5 (diff)
downloadopenembedded-20e56bce4f4c951365b53e8c44d464a17f2ce79f.tar.gz
connman: use libnl2
Diffstat (limited to 'recipes/connman')
-rw-r--r--recipes/connman/connman.inc2
-rw-r--r--recipes/connman/connman_0.46.bb6
-rw-r--r--recipes/connman/files/link-against-libnl2.patch13
3 files changed, 17 insertions, 4 deletions
diff --git a/recipes/connman/connman.inc b/recipes/connman/connman.inc
index 5b2f0cc409..9ea04e3e8d 100644
--- a/recipes/connman/connman.inc
+++ b/recipes/connman/connman.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
SECTION = "libs/network"
LICENSE = "GPL"
# we need to define the depends here, the dynamic stuff is too late
-DEPENDS = "libnl wpa-supplicant dbus glib-2.0 ppp busybox dhclient resolvconf bluez4"
+DEPENDS = "libnl2 wpa-supplicant dbus glib-2.0 ppp busybox dhclient resolvconf bluez4"
EXTRA_OECONF += "\
ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
diff --git a/recipes/connman/connman_0.46.bb b/recipes/connman/connman_0.46.bb
index 814187ded6..9fcd7a780f 100644
--- a/recipes/connman/connman_0.46.bb
+++ b/recipes/connman/connman_0.46.bb
@@ -1,6 +1,5 @@
require connman.inc
-
-PR = "r3"
+PR = "r5"
EXTRA_OECONF += "\
--disable-gtk-doc \
@@ -15,6 +14,7 @@ EXTRA_OECONF += "\
--enable-dhclient \
--enable-resolvconf \
--enable-dnsproxy \
+ --enable-tools \
--disable-novatel \
--disable-huawei \
--disable-hso \
@@ -32,7 +32,7 @@ EXTRA_OECONF += "\
SRC_URI = "\
http://www.kernel.org/pub/linux/network/connman/connman-${PV}.tar.gz \
+ file://link-against-libnl2.patch;patch=1 \
file://no_system_user_perms.patch;patch=1 \
file://connman \
"
-
diff --git a/recipes/connman/files/link-against-libnl2.patch b/recipes/connman/files/link-against-libnl2.patch
new file mode 100644
index 0000000000..5be1618209
--- /dev/null
+++ b/recipes/connman/files/link-against-libnl2.patch
@@ -0,0 +1,13 @@
+Index: connman-0.46/configure.ac
+===================================================================
+--- connman-0.46.orig/configure.ac
++++ connman-0.46/configure.ac
+@@ -326,7 +326,7 @@
+ AC_ARG_ENABLE(tools, AC_HELP_STRING([--enable-tools],
+ [enable testing tools]), [enable_tools=${enableval}])
+ if (test "${enable_tools}" = "yes"); then
+- PKG_CHECK_MODULES(NETLINK, libnl-1, dummy=yes,
++ PKG_CHECK_MODULES(NETLINK, libnl-2.0, dummy=yes,
+ AC_MSG_ERROR(Netlink library is required))
+ AC_SUBST(NETLINK_CFLAGS)
+ AC_SUBST(NETLINK_LIBS)