aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cups
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-02-19 01:43:20 +0000
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2011-02-19 13:57:59 +0100
commit781b459ec2159389b86f1bec7e583860154d0230 (patch)
tree925ab9603996f5b1da1ea2e9faf1a30f51250a92 /recipes/cups
parent84b2080965ce8512156d9068548c7f7b2331395a (diff)
downloadopenembedded-781b459ec2159389b86f1bec7e583860154d0230.tar.gz
cups: merge cups14.inc into cups 1.4.4 recipe
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/cups')
-rw-r--r--recipes/cups/cups14.inc83
-rw-r--r--recipes/cups/cups_1.4.4.bb96
2 files changed, 85 insertions, 94 deletions
diff --git a/recipes/cups/cups14.inc b/recipes/cups/cups14.inc
deleted file mode 100644
index 0828187c1a..0000000000
--- a/recipes/cups/cups14.inc
+++ /dev/null
@@ -1,83 +0,0 @@
-DESCRIPTION = "An Internet printing system for Unix."
-SECTION = "console/utils"
-LICENSE = "GPL LGPL"
-DEPENDS = "gnutls libpng jpeg dbus dbus-glib zlib fakeroot-native"
-PROVIDES = "cups14"
-
-SRC_URI = "ftp://ftp.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2"
-
-LEAD_SONAME = "libcupsdriver.so"
-
-inherit autotools binconfig
-
-EXTRA_OECONF = " \
- --enable-gnutls \
- --enable-dbus \
- --enable-browsing \
- --disable-openssl \
- --disable-tiff \
- --without-php \
- --without-perl \
- --without-python \
- --without-java \
- "
-
-
-do_configure() {
- gnu-configize
- libtoolize --force
- DSOFLAGS="${LDFLAGS}" oe_runconf
-}
-
-do_compile () {
- sed -i s:STRIP:NOSTRIP: Makedefs
- sed -i s:serial:: backend/Makefile
-
- echo "all:" > man/Makefile
- echo "libs:" >> man/Makefile
- echo "install:" >> man/Makefile
- echo "install-data:" >> man/Makefile
- echo "install-exec:" >> man/Makefile
- echo "install-headers:" >> man/Makefile
- echo "install-libs:" >> man/Makefile
-
- oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
- "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
- "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
- "LIBZ=-lz -L${STAGING_LIBDIR}" \
- "-I."
-}
-
-fakeroot do_install () {
- oe_runmake "DSTROOT=${D}" install
-
- # This directory gets installed with perms 511, which makes packaging fail
- chmod 0711 "${D}/${localstatedir}/run/cups/certs"
-}
-
-python do_package_append() {
- # Change permissions back the way they were, they probably had a reason...
- workdir = bb.data.getVar('WORKDIR', d, 1)
- os.system('chmod 0511 %s/install/cups/var/run/cups/certs' % workdir)
-}
-
-PACKAGES =+ "${PN}-lib ${PN}-libimage"
-
-FILES_${PN}-lib = "${libdir}/libcups.so.*"
-
-FILES_${PN}-libimage = "${libdir}/libcupsimage.so.*"
-
-FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
- ${libdir}/cups/cgi-bin/.debug \
- ${libdir}/cups/filter/.debug \
- ${libdir}/cups/monitor/.debug \
- ${libdir}/cups/notifier/.debug \
- ${libdir}/cups/daemon/.debug \
- "
-#package the html for the webgui inside the main packages (~1MB uncompressed)
-
-FILES_${PN} += "${datadir}/doc/cups/images \
- ${datadir}/doc/cups/*html \
- ${datadir}/doc/cups/*.css \
- ${datadir}/icons/ \
- "
diff --git a/recipes/cups/cups_1.4.4.bb b/recipes/cups/cups_1.4.4.bb
index bf23cc5231..709edf1482 100644
--- a/recipes/cups/cups_1.4.4.bb
+++ b/recipes/cups/cups_1.4.4.bb
@@ -1,17 +1,91 @@
-require cups14.inc
-
-SRC_URI += " \
- file://use_echo_only_in_init.patch \
- file://skip_tools.patch \
- file://configure.patch \
- "
+#package the html for the webgui inside the main packages (~1MB uncompressed)
+DESCRIPTION = "An Internet printing system for Unix."
+SECTION = "console/utils"
+LICENSE = "GPL LGPL"
+DEPENDS = "gnutls libpng jpeg dbus dbus-glib zlib fakeroot-native"
+DEPENDS += "virtual/libusb0"
+PROVIDES = "cups14"
+PR = "r3"
+SRC_URI = "ftp://ftp.easysw.com/pub/cups/${PV}/cups-${PV}-source.tar.bz2 \
+ file://use_echo_only_in_init.patch \
+ file://skip_tools.patch \
+ file://configure.patch \
+ "
SRC_URI[md5sum] = "8776403ad60fea9e85eab9c04d88560d"
SRC_URI[sha256sum] = "d25ffa35add3abeeec0eba60be2cffc89425b649c64ef3a73dfc724683a59aa3"
-PR = "r2"
-
DEFAULT_PREFERENCE = "-1"
-DEPENDS += "virtual/libusb0"
-EXTRA_OECONF += " --disable-gssapi --disable-largefile --enable-debug --disable-relro --enable-libusb"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--enable-gnutls \
+ --enable-dbus \
+ --enable-browsing \
+ --disable-openssl \
+ --disable-tiff \
+ --without-php \
+ --without-perl \
+ --without-python \
+ --without-java \
+ --disable-gssapi \
+ --disable-largefile \
+ --enable-debug \
+ --disable-relro \
+ --enable-libusb \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ DSOFLAGS="${LDFLAGS}" oe_runconf
+}
+do_compile () {
+ sed -i s:STRIP:NOSTRIP: Makedefs
+ sed -i s:serial:: backend/Makefile
+ echo "all:" > man/Makefile
+ echo "libs:" >> man/Makefile
+ echo "install:" >> man/Makefile
+ echo "install-data:" >> man/Makefile
+ echo "install-exec:" >> man/Makefile
+ echo "install-headers:" >> man/Makefile
+ echo "install-libs:" >> man/Makefile
+ oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
+ "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
+ "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
+ "LIBZ=-lz -L${STAGING_LIBDIR}" \
+ "-I."
+}
+
+PACKAGES =+ "${PN}-lib ${PN}-libimage"
+
+FILES_${PN}-lib = "${libdir}/libcups.so.*"
+FILES_${PN}-libimage = "${libdir}/libcupsimage.so.*"
+FILES_${PN}-dbg += "${libdir}/cups/backend/.debug \
+ ${libdir}/cups/cgi-bin/.debug \
+ ${libdir}/cups/filter/.debug \
+ ${libdir}/cups/monitor/.debug \
+ ${libdir}/cups/notifier/.debug \
+ ${libdir}/cups/daemon/.debug \
+ "
+FILES_${PN} += "${datadir}/doc/cups/images \
+ ${datadir}/doc/cups/*html \
+ ${datadir}/doc/cups/*.css \
+ ${datadir}/icons/ \
+ "
+
CONFFILES_${PN} += "${sysconfdir}/cups/cupsd.conf"
+
+LEAD_SONAME = "libcupsdriver.so"
+
+fakeroot do_install () {
+ oe_runmake "DSTROOT=${D}" install
+ # This directory gets installed with perms 511, which makes packaging fail
+ chmod 0711 "${D}/${localstatedir}/run/cups/certs"
+}
+
+python do_package_append() {
+ # Change permissions back the way they were, they probably had a reason...
+ workdir = bb.data.getVar('WORKDIR', d, 1)
+ os.system('chmod 0511 %s/install/cups/var/run/cups/certs' % workdir)
+}