aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dzen2
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-11-15 21:07:12 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-15 20:19:25 +0100
commit95a71d22c858715179161121cb81c3c99daa909a (patch)
tree041215db3c58fe1d721a7a6747a100e1bf74aa35 /recipes/dzen2
parent50d3e0bc5dddf87f05984a6e1b7beb672e7edee6 (diff)
downloadopenembedded-95a71d22c858715179161121cb81c3c99daa909a.tar.gz
dzen2: Modify dzen-extras, update Makefile and recipe.
Modularized the battery applet by moving the charge calculation in an external script and adding per-platform functions. Made the process a bit more efficient by adding a small program written in C, dzen-battery, which calculates a battery percentage given two standard files in /sys/class/power_supply and by moving processes outside the main loop when they only need to run once. Modified Makefile for dzen-battery.c Bumped PR on dzen2-svn Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/dzen2')
-rw-r--r--recipes/dzen2/dzen2_svn.bb2
-rw-r--r--recipes/dzen2/files/Makefile8
-rw-r--r--recipes/dzen2/files/dzen-extras.tar.gzbin5082 -> 5491 bytes
3 files changed, 8 insertions, 2 deletions
diff --git a/recipes/dzen2/dzen2_svn.bb b/recipes/dzen2/dzen2_svn.bb
index 893a5778b2..fa1072483b 100644
--- a/recipes/dzen2/dzen2_svn.bb
+++ b/recipes/dzen2/dzen2_svn.bb
@@ -5,7 +5,7 @@ RDEPENDS = "ttf-dejavu-sans xrandr"
SRCREV = "271"
PV = "0.8.5+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "svn://dzen.googlecode.com/svn/;module=trunk;proto=http \
file://dzen-extras.tar.gz \
diff --git a/recipes/dzen2/files/Makefile b/recipes/dzen2/files/Makefile
index 4e3525a176..4bafbcbd80 100644
--- a/recipes/dzen2/files/Makefile
+++ b/recipes/dzen2/files/Makefile
@@ -6,7 +6,7 @@ include config.mk
SRC = draw.c main.c util.c action.c
OBJ = ${SRC:.c=.o}
-all: options dzen2
+all: options dzen2 dzen-battery
options:
@echo dzen2 build options:
@@ -24,6 +24,10 @@ dzen2: ${OBJ}
@echo CC -o $@
@${CC} -o $@ ${OBJ} ${LDFLAGS} ${LIBS}
+dzen-battery: dzen-battery.c
+ @${CC} -c ${CFLAGS} dzen-battery.c
+ @${CC} -o dzen-battery dzen-battery.o ${LDFLAGS}
+
clean:
@echo cleaning
@rm -f dzen2 ${OBJ} dzen2-${VERSION}.tar.gz
@@ -43,6 +47,8 @@ install: all
@chmod 755 ${DESTDIR}${PREFIX}/bin/dzen2
@cp -f dzen-launcher ${DESTDIR}${PREFIX}/bin
@chmod 755 ${DESTDIR}${PREFIX}/bin/dzen-launcher
+ @cp -f dzen-battery ${DESTDIR}${PREFIX}/bin
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/dzen-battery
@echo installing scripts to ${DESTDIR}${PREFIX}/share/dzen
@mkdir -p ${DESTDIR}${PREFIX}/share/dzen/scripts
@cp -f scripts/* ${DESTDIR}${PREFIX}/share/dzen/scripts
diff --git a/recipes/dzen2/files/dzen-extras.tar.gz b/recipes/dzen2/files/dzen-extras.tar.gz
index d57171404a..7a10757722 100644
--- a/recipes/dzen2/files/dzen-extras.tar.gz
+++ b/recipes/dzen2/files/dzen-extras.tar.gz
Binary files differ