aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ecj
diff options
context:
space:
mode:
authorHenning <h.heinold@tarent.de>2011-03-27 13:41:28 +0200
committerStefan Schmidt <stefan@buglabs.net>2011-05-09 09:01:41 +0200
commite6b88ca55bc7c2cc6a54d2fa7befb223128e975d (patch)
treeed6a9e041084434805ba7ae87d2ca33a9d048dc6 /recipes/ecj
parent3cf29cfac4a64afbc67a3a1de7aecab64ffad9d3 (diff)
downloadopenembedded-e6b88ca55bc7c2cc6a54d2fa7befb223128e975d.tar.gz
ecj-bootstrap: try 5 times to compile the classes
* that is an easy fix to workaround the aborts and segfaults of cacao and jamvm * bump PR Signed-off-by: Stefan Schmidt <stefan@buglabs.net>
Diffstat (limited to 'recipes/ecj')
-rw-r--r--recipes/ecj/ecj-bootstrap-native.bb2
-rwxr-xr-xrecipes/ecj/files/ecj.in14
2 files changed, 14 insertions, 2 deletions
diff --git a/recipes/ecj/ecj-bootstrap-native.bb b/recipes/ecj/ecj-bootstrap-native.bb
index bdb9797d92..a11ba74baf 100644
--- a/recipes/ecj/ecj-bootstrap-native.bb
+++ b/recipes/ecj/ecj-bootstrap-native.bb
@@ -17,7 +17,7 @@ SRC_URI = "file://ecj.in"
S = "${WORKDIR}"
-PR = "r3"
+PR = "r4"
JAR = "ecj-bootstrap.jar"
diff --git a/recipes/ecj/files/ecj.in b/recipes/ecj/files/ecj.in
index 2cff2593d5..0fd4a65cdc 100755
--- a/recipes/ecj/files/ecj.in
+++ b/recipes/ecj/files/ecj.in
@@ -1 +1,13 @@
-${RUNTIME} -Xmx1024m -cp ${ECJ_JAR} org.eclipse.jdt.internal.compiler.batch.Main ${1+"$@"}
+ARGS=${1+"$@"}
+COUNT=5
+END=0
+
+while test "${COUNT}" -gt "${END}"
+do
+ ${RUNTIME} -Xmx1024m -cp ${ECJ_JAR} org.eclipse.jdt.internal.compiler.batch.Main ${ARGS}
+ if test "${?}" -eq "${END}"
+ then
+ break
+ fi
+ COUNT=$(($COUNT-1))
+done