aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enblend
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-09-22 10:59:34 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-22 19:44:32 +0200
commit7bb9447c7008233367e5b7a9ce1c087e115d7919 (patch)
treeed75b67cd3a3311b637bfd793d2a1b6a25986ac1 /recipes/enblend
parentd2d7afd76a9dd27d11136f6aa9831aa9a90b41c2 (diff)
downloadopenembedded-7bb9447c7008233367e5b7a9ce1c087e115d7919.tar.gz
plotutils: add 2.6
Diffstat (limited to 'recipes/enblend')
-rw-r--r--recipes/enblend/plotutils/01_configure_ac.patch28
-rw-r--r--recipes/enblend/plotutils_2.6.bb23
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/enblend/plotutils/01_configure_ac.patch b/recipes/enblend/plotutils/01_configure_ac.patch
new file mode 100644
index 0000000000..e432d135a8
--- /dev/null
+++ b/recipes/enblend/plotutils/01_configure_ac.patch
@@ -0,0 +1,28 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 01_configure_ac.dpatch by Floris Bruynooghe <floris.bruynooghe@gmail.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Enable AM_MAINTAINER_MODE to stop make from rebuilding configure in
+## DP: case of timestamp skew (as created by dpkg-source).
+
+@DPATCH@
+diff -urNad plotutils-2.5~/configure.ac plotutils-2.5/configure.ac
+--- plotutils-2.5~/configure.ac 2009-05-03 14:28:26.000000000 +0000
++++ plotutils-2.5/configure.ac 2009-05-03 14:33:24.000000000 +0000
+@@ -8,6 +8,8 @@
+ AM_INIT_AUTOMAKE([plotutils],[2.5])
+ AM_CONFIG_HEADER(config.h:config.hin)
+
++AM_MAINTAINER_MODE
++
+ # The following will be defined in config.h, if appropriate.
+
+ # Miscellaneous.
+@@ -64,6 +66,7 @@
+ # Note: this can apparently alter CFLAGS, on a few platforms, e.g., on
+ # SCO OpenServer 5 (i.e. *-*-sco3.2v5*), "-belf" is added.
+ AC_PROG_LIBTOOL
++AC_PROG_CXX
+
+ # Determine extension (e.g. ".exe") on executables, if any.
+ AC_EXEEXT
diff --git a/recipes/enblend/plotutils_2.6.bb b/recipes/enblend/plotutils_2.6.bb
new file mode 100644
index 0000000000..90a32b0e56
--- /dev/null
+++ b/recipes/enblend/plotutils_2.6.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "The GNU plotutils package contains software for both programmers and technical users. Its centerpiece is libplot, a powerful C/C++ function library for exporting 2-D vector graphics in many file formats, both vector and raster. It can also do vector graphics animations."
+
+LICENSE = "GPLv2+"
+
+SRC_URI = "http://ftp.gnu.org/gnu/plotutils/plotutils-${PV}.tar.gz \
+ file://01_configure_ac.patch"
+SRC_URI[md5sum] = "c08a424bd2438c80a786a7f4b5bb6a40"
+SRC_URI[sha256sum] = "4f4222820f97ca08c7ea707e4c53e5a3556af4d8f1ab51e0da6ff1627ff433ab"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-libxmi"
+
+python populate_packages_prepend () {
+ libdir = bb.data.expand('${libdir}', d)
+ libdir_dbg = bb.data.expand('${libdir}/.debug', d)
+ do_split_packages(d, libdir, '^lib(.*)\.so$', 'lib%s-dev', 'GNU Plotutils %s development package', extra_depends='${PN}-dev', allow_links=True)
+ do_split_packages(d, libdir, '^lib(.*)\.la$', 'lib%s-dev', 'GNU Plotutils %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, libdir, '^lib(.*)\.a$', 'lib%s-dev', 'GNU Plotutils %s development package', extra_depends='${PN}-dev')
+ do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'GNU Plotutils %s library', extra_depends='', allow_links=True)
+}
+
+FILES_${PN} = "${bindir}"