aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fakeroot
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2011-01-27 02:13:24 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-12 08:15:13 -0700
commit4d0d6c2640a3c32278db2caf196db761dfc03473 (patch)
tree3f9e26edf32af78a98baec0d4f07c55e3237eb7c /recipes/fakeroot
parent6265887b16489caf6f35fef1b15e7fbe8e645b26 (diff)
downloadopenembedded-4d0d6c2640a3c32278db2caf196db761dfc03473.tar.gz
fakeroot: add 1.14.5, mv 1.12.4 to obsolete
The other old recipes should be removed. - oplinux suggests 1.7.1 which is not available anymore - chinook-compat, maemo5-compat pin 1.9.6 Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/fakeroot')
-rw-r--r--recipes/fakeroot/fakeroot-1.14.5/fix-prefix.patch15
-rw-r--r--recipes/fakeroot/fakeroot-1.14.5/quiet-getopt-check.patch12
-rw-r--r--recipes/fakeroot/fakeroot-native_1.12.4.bb21
-rw-r--r--recipes/fakeroot/fakeroot.inc16
-rw-r--r--recipes/fakeroot/fakeroot_1.12.4.bb26
-rw-r--r--recipes/fakeroot/fakeroot_1.14.5.bb10
6 files changed, 53 insertions, 47 deletions
diff --git a/recipes/fakeroot/fakeroot-1.14.5/fix-prefix.patch b/recipes/fakeroot/fakeroot-1.14.5/fix-prefix.patch
new file mode 100644
index 0000000000..72e7528b0e
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-1.14.5/fix-prefix.patch
@@ -0,0 +1,15 @@
+This is not needed, kept just for reference.
+
+--- fakeroot-1.14.5.orig/scripts/fakeroot.in 2009-11-15 04:09:21.000000000 +0100
++++ fakeroot-1.14.5/scripts/fakeroot.in 2011-01-12 20:10:02.897300394 +0100
+@@ -30,8 +30,8 @@ fatal ()
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-FAKEROOT_PREFIX=@prefix@
+-FAKEROOT_BINDIR=@bindir@
++FAKEROOT_BINDIR=`dirname $0`
++FAKEROOT_PREFIX=`dirname ${FAKEROOT_BINDIR}`
+
+ USEABSLIBPATH=@LDPRELOADABS@
+ LIB=lib@fakeroot_transformed@@DLSUFFIX@
diff --git a/recipes/fakeroot/fakeroot-1.14.5/quiet-getopt-check.patch b/recipes/fakeroot/fakeroot-1.14.5/quiet-getopt-check.patch
new file mode 100644
index 0000000000..bcb9083998
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-1.14.5/quiet-getopt-check.patch
@@ -0,0 +1,12 @@
+busybox provided getopt prints the help-text on stderr.
+--- fakeroot-1.14.5.orig/scripts/fakeroot.in 2009-11-15 04:09:21.000000000 +0100
++++ fakeroot-1.14.5/scripts/fakeroot.in 2011-01-12 20:11:50.059891996 +0100
+@@ -43,7 +43,7 @@ export FAKED_MODE
+
+ libfound=no
+
+-GETOPTEST=`getopt --version`
++GETOPTEST=`getopt --version 2> /dev/null`
+ case $GETOPTEST in
+ getopt*) # GNU getopt
+ FAKE_TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`
diff --git a/recipes/fakeroot/fakeroot-native_1.12.4.bb b/recipes/fakeroot/fakeroot-native_1.12.4.bb
deleted file mode 100644
index e6add2bb26..0000000000
--- a/recipes/fakeroot/fakeroot-native_1.12.4.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-require fakeroot_${PV}.bb
-
-SRC_URI += "file://fix-prefix.patch"
-S = "${WORKDIR}/fakeroot-${PV}"
-
-inherit native
-
-EXTRA_OECONF = "--program-prefix="
-
-# Compatability for the rare systems not using or having SYSV
-python () {
- if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
- bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
-}
-
-NATIVE_INSTALL_WORKS = "1"
-
-RDEPENDS_${PN} = "util-linux-native"
-
-SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
-SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"
diff --git a/recipes/fakeroot/fakeroot.inc b/recipes/fakeroot/fakeroot.inc
new file mode 100644
index 0000000000..af71e24e2f
--- /dev/null
+++ b/recipes/fakeroot/fakeroot.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org"
+SECTION = "base"
+LICENSE = "GPL"
+INC_PR = "r0"
+inherit autotools
+BBCLASSEXTEND = "native"
+
+SRC_URI = "\
+ file://configure-libtool.patch \
+"
+# previous versions did the following for -native, but why? Not needed..
+#SRC_URI_append_virtclass-native = "file://fix-prefix.patch"
+
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS_${PN} = "util-linux"
diff --git a/recipes/fakeroot/fakeroot_1.12.4.bb b/recipes/fakeroot/fakeroot_1.12.4.bb
deleted file mode 100644
index c265749f64..0000000000
--- a/recipes/fakeroot/fakeroot_1.12.4.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "Gives a fake root environment"
-HOMEPAGE = "http://fakeroot.alioth.debian.org"
-SECTION = "base"
-LICENSE = "GPL"
-PR = "r2"
-
-SRC_URI = "\
- ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
- file://configure-libtool.patch \
-"
-
-inherit autotools
-
-do_install_append() {
- install -d ${D}${includedir}/fakeroot
- install -m 644 *.h ${D}${includedir}/fakeroot
- install -d ${D}${libdir}/libfakeroot/
- oe_libinstall -so libfakeroot ${D}${libdir}/libfakeroot/
-}
-
-# fakeroot needs getopt which is provided by the util-linux package
-RDEPENDS_${PN} = "util-linux"
-
-
-SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
-SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"
diff --git a/recipes/fakeroot/fakeroot_1.14.5.bb b/recipes/fakeroot/fakeroot_1.14.5.bb
new file mode 100644
index 0000000000..ff6844df6b
--- /dev/null
+++ b/recipes/fakeroot/fakeroot_1.14.5.bb
@@ -0,0 +1,10 @@
+require fakeroot.inc
+PR = "${INC_PR}.0"
+
+SRC_URI =+ "\
+ ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
+ file://quiet-getopt-check.patch \
+"
+
+SRC_URI[md5sum] = "659a1f3a36554abfc2a3eaad2fdc0604"
+SRC_URI[sha256] = "b035c834944bf9482027f48c388de8492e96609825265ac03f05408d0b3aae68"