aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ffalarms
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-13 21:36:53 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-13 21:38:29 +0200
commit9ac50f2494f029df76176117cb77a21491194855 (patch)
treeb1cd61b2413bd0b47a9ad9a81e729f9c4e5e584e /recipes/ffalarms
parent7e8f12e3c6e76a1b190d551d3ff5c796d5a59df2 (diff)
downloadopenembedded-9ac50f2494f029df76176117cb77a21491194855.tar.gz
ffalarms: fix build with newer vala
* ffalarms.vala:142.9-142.16: error: TimeZone is an ambiguous reference between GLib.TimeZone and ICal.TimeZone Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/ffalarms')
-rw-r--r--recipes/ffalarms/ffalarms/ical.timezone.patch40
-rw-r--r--recipes/ffalarms/ffalarms_git.bb5
2 files changed, 43 insertions, 2 deletions
diff --git a/recipes/ffalarms/ffalarms/ical.timezone.patch b/recipes/ffalarms/ffalarms/ical.timezone.patch
new file mode 100644
index 0000000000..e19ebc991a
--- /dev/null
+++ b/recipes/ffalarms/ffalarms/ical.timezone.patch
@@ -0,0 +1,40 @@
+diff -uNr git.orig//ffalarms.vala git/ffalarms.vala
+--- git.orig//ffalarms.vala 2010-09-26 16:15:04.000000000 +0200
++++ git/ffalarms.vala 2010-10-13 21:31:15.000000000 +0200
+@@ -139,7 +139,7 @@
+ }
+
+
+-unowned TimeZone local_tz()
++unowned ICal.TimeZone local_tz()
+ {
+ string s = Environment.get_variable("TZ");
+ try {
+@@ -149,15 +149,15 @@
+ } catch (FileError e) {
+ s = "UTC";
+ }
+- return TimeZone.get_builtin_timezone(s.strip());
++ return ICal.TimeZone.get_builtin_timezone(s.strip());
+ }
+
+
+ // XXX may return time_t
+ ICal.Time next_alarm_as_utc(Component c)
+ {
+- unowned TimeZone tz = local_tz();
+- unowned TimeZone utc = TimeZone.get_utc_timezone();
++ unowned ICal.TimeZone tz = local_tz();
++ unowned ICal.TimeZone utc = ICal.TimeZone.get_utc_timezone();
+ var t = time_t();
+ var utc_now = ICal.Time.from_timet_with_zone(t, false, utc);
+ ICal.Time tz_now = ICal.Time.from_timet_with_zone(t, false, tz);
+@@ -173,7 +173,7 @@
+ }
+ if (!next.is_utc() && next.zone == null)
+ ICal.Time.set_timezone(ref next, tz);
+- TimeZone.convert_time(ref next, tz, utc);
++ ICal.TimeZone.convert_time(ref next, tz, utc);
+ next.set_timezone(ref next, utc);
+ return (next.compare (utc_now) >= 0) ? next : ICal.Time.null_time();
+ }
diff --git a/recipes/ffalarms/ffalarms_git.bb b/recipes/ffalarms/ffalarms_git.bb
index 799e813063..d904859e9e 100644
--- a/recipes/ffalarms/ffalarms_git.bb
+++ b/recipes/ffalarms/ffalarms_git.bb
@@ -8,9 +8,10 @@ DEPENDS = "elementary libeflvala libical"
RDEPENDS_${PN} = "atd alsa-utils-amixer ttf-dejavu-sans libical"
RSUGGESTS_${PN} = "mplayer alsa-utils-aplay frameworkd"
PV = "0.4+gitr${SRCPV}"
-PR = "r6"
+PR = "r7"
-SRC_URI = "git://git.shr-project.org/repo/ffalarms.git;protocol=http;branch=master"
+SRC_URI = "git://git.shr-project.org/repo/ffalarms.git;protocol=http;branch=master \
+ file://ical.timezone.patch"
SRCREV = "4ff7daa50ca4f7093d4c331d0274d95f3171c4c6"
S = "${WORKDIR}/git"