aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/file
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-01 15:58:18 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-02 18:19:19 +0100
commite329d5e021ecc3484660f6b8beab44a837913897 (patch)
tree18d8784ce3e4892d60d16a9cb8ef55b9420347e7 /recipes/file
parenteaa2d77d79d81ceeac9b82f0c98ad86882821f80 (diff)
downloadopenembedded-e329d5e021ecc3484660f6b8beab44a837913897.tar.gz
file: merged Poky changes (BBEXTENDCLASS + new staging)
Note that 5.04 (newest) is now default instead of 4.21. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/file')
-rw-r--r--recipes/file/file-native_4.18.bb8
-rw-r--r--recipes/file/file-native_4.21.bb6
-rw-r--r--recipes/file/file_4.18.bb15
-rw-r--r--recipes/file/file_4.21.bb17
-rw-r--r--recipes/file/file_5.04.bb13
5 files changed, 12 insertions, 47 deletions
diff --git a/recipes/file/file-native_4.18.bb b/recipes/file/file-native_4.18.bb
deleted file mode 100644
index 63554b01fb..0000000000
--- a/recipes/file/file-native_4.18.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require file_${PV}.bb
-inherit native
-
-# avoid dependency loop
-DEPENDS = ""
-PR = "r1"
-
-SRC_URI += "file://native-fix.diff;patch=1"
diff --git a/recipes/file/file-native_4.21.bb b/recipes/file/file-native_4.21.bb
deleted file mode 100644
index 734891d18d..0000000000
--- a/recipes/file/file-native_4.21.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require file_${PV}.bb
-inherit native
-DEPENDS = "zlib-native"
-PR = "r0"
-
-SRC_URI += "file://native-fix.diff;patch=1"
diff --git a/recipes/file/file_4.18.bb b/recipes/file/file_4.18.bb
index a98c68009e..5433d3e9e6 100644
--- a/recipes/file/file_4.18.bb
+++ b/recipes/file/file_4.18.bb
@@ -1,22 +1,15 @@
-DESCRIPTION = "File attempts to classify files depending \
-on their contents and prints a description if a match is found."
-SECTION = "console/utils"
-LICENSE = "BSD-ADV"
-DEPENDS = "file-native"
+require file.inc
+
+PR = "${INCPR}.0"
SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
file://dump \
file://filesystems"
-S = "${WORKDIR}/file-${PV}"
-inherit autotools
+SRC_URI_append_virtclass-native = " file://native-fix.diff;patch=1"
do_configure_prepend() {
sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
cp ${WORKDIR}/dump ${S}/magic/Magdir/
cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/recipes/file/file_4.21.bb b/recipes/file/file_4.21.bb
index 758f7f36fa..dfe6e1063a 100644
--- a/recipes/file/file_4.21.bb
+++ b/recipes/file/file_4.21.bb
@@ -1,18 +1,13 @@
-DESCRIPTION = "File attempts to classify files depending \
-on their contents and prints a description if a match is found."
-SECTION = "console/utils"
-LICENSE = "BSD-ADV"
-DEPENDS = "file-native"
+require file.inc
+
+DEPENDS_virtclass-native += "zlib-native"
+
+PR = "${INCPR}.0"
SRC_URI = "ftp://ftp.fi.debian.org/pub/gentoo/distfiles/file-${PV}.tar.gz"
-S = "${WORKDIR}/file-${PV}"
-inherit autotools
+SRC_URI_append_virtclass-native = " file://native-fix.diff;patch=1"
do_configure_prepend() {
sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/recipes/file/file_5.04.bb b/recipes/file/file_5.04.bb
index 1fe1488dae..da14e941be 100644
--- a/recipes/file/file_5.04.bb
+++ b/recipes/file/file_5.04.bb
@@ -1,12 +1,3 @@
-DESCRIPTION = "File attempts to classify files depending \
-on their contents and prints a description if a match is found."
-SECTION = "console/utils"
-LICENSE = "BSD-ADV"
-DEPENDS = "file-native"
-DEPENDS_virtclass-native = ""
+require file.inc
-SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz"
-
-inherit autotools
-
-BBCLASSEXTEND = "native"
+PR = "${INCPR}.0"