aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2011-01-06 20:48:30 +0000
committerAndreas Oberritter <obi@opendreambox.org>2011-01-11 21:27:28 +0100
commitee85c41bb8f694ea7c58cebefa358adfb29f9adc (patch)
tree2187e5cc2f7d7bef3196945fd72d6dd1fe4fac2e /recipes/gcc
parent751ecb1daeaf08a3cb7bd5600731264a0753f4b3 (diff)
downloadopenembedded-ee85c41bb8f694ea7c58cebefa358adfb29f9adc.tar.gz
gcc: replace unconditional SRC_URI_append with SRC_URI +=
* Fixes missing leading whitespace character at some locations Signed-off-by: Andreas Oberritter <obi@opendreambox.org> CC: Khem Raj <raj.khem@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-3.4.4.inc2
-rw-r--r--recipes/gcc/gcc-3.4.6.inc2
-rw-r--r--recipes/gcc/gcc-4.0.2.inc2
-rw-r--r--recipes/gcc/gcc-canadian-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc_4.2.2.bb2
-rw-r--r--recipes/gcc/gcc_4.2.3.bb2
-rw-r--r--recipes/gcc/gcc_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc_4.3.2.bb2
-rw-r--r--recipes/gcc/gcc_4.3.3.bb2
-rw-r--r--recipes/gcc/gcc_4.3.4.bb2
-rw-r--r--recipes/gcc/gcc_4.4.1.bb2
-rw-r--r--recipes/gcc/gcc_4.4.2.bb2
-rw-r--r--recipes/gcc/gcc_4.4.4.bb2
-rw-r--r--recipes/gcc/gcc_4.5.bb2
-rw-r--r--recipes/gcc/gcc_svn.bb2
16 files changed, 16 insertions, 16 deletions
diff --git a/recipes/gcc/gcc-3.4.4.inc b/recipes/gcc/gcc-3.4.4.inc
index 99e680f40e..8a3ce026b7 100644
--- a/recipes/gcc/gcc-3.4.4.inc
+++ b/recipes/gcc/gcc-3.4.4.inc
@@ -26,7 +26,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://gcc-cross-fixincl.patch \
file://gcc-posix-open-fix.patch \
"
-SRC_URI_append = " file://zecke-no-host-includes.patch "
+SRC_URI += "file://zecke-no-host-includes.patch"
SRC_URI[archive.md5sum] = "b594ff4ea4fbef4ba9220887de713dfe"
SRC_URI[archive.sha256sum] = "3444179840638cb8664e8e53604900c4521d29d57785a5091202ee4937d8d0fd"
diff --git a/recipes/gcc/gcc-3.4.6.inc b/recipes/gcc/gcc-3.4.6.inc
index 5296f263c8..3991cdcf50 100644
--- a/recipes/gcc/gcc-3.4.6.inc
+++ b/recipes/gcc/gcc-3.4.6.inc
@@ -23,7 +23,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
SRC_URI += "file://gcc34-configure.in.patch"
SRC_URI += "file://gcc34-thumb-support.patch"
-SRC_URI_append = " file://zecke-no-host-includes.patch "
+SRC_URI += "file://zecke-no-host-includes.patch"
SRC_URI[archive.md5sum] = "4a21ac777d4b5617283ce488b808da7b"
SRC_URI[archive.sha256sum] = "7791a601878b765669022b8b3409fba33cc72f9e39340fec8af6d0e6f72dec39"
diff --git a/recipes/gcc/gcc-4.0.2.inc b/recipes/gcc/gcc-4.0.2.inc
index 63f9772730..9d3c6605ec 100644
--- a/recipes/gcc/gcc-4.0.2.inc
+++ b/recipes/gcc/gcc-4.0.2.inc
@@ -13,7 +13,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
file://zecke-xgcc-cpp.patch "
# uclibc patches below
-SRC_URI_append = " file://100-uclibc-conf.patch \
+SRC_URI += "file://100-uclibc-conf.patch \
file://200-uclibc-locale.patch \
file://301-missing-execinfo_h.patch \
file://302-c99-snprintf.patch \
diff --git a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
index 7a1402f993..08a4c950e1 100644
--- a/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-canadian-sdk_4.2.4.bb
@@ -14,7 +14,7 @@ DEPENDS = "gmp-canadian mpfr-canadian"
require gcc-configure-canadian-sdk.inc
require gcc-package-sdk.inc
-SRC_URI_append = "file://fortran-cross-compile-hack.patch \
+SRC_URI += "file://fortran-cross-compile-hack.patch \
file://pr22133-mingw-path-fixup.patch \
file://pr33281-mingw-host-fragment.patch \
file://pr35916-mingw-__USE_MINGW_ACCESS-everywhere.patch \
diff --git a/recipes/gcc/gcc_4.2.2.bb b/recipes/gcc/gcc_4.2.2.bb
index 30713f8a47..4822da9d0c 100644
--- a/recipes/gcc/gcc_4.2.2.bb
+++ b/recipes/gcc/gcc_4.2.2.bb
@@ -4,6 +4,6 @@ require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.2.3.bb b/recipes/gcc/gcc_4.2.3.bb
index 6fe30282d6..a174e11d08 100644
--- a/recipes/gcc/gcc_4.2.3.bb
+++ b/recipes/gcc/gcc_4.2.3.bb
@@ -4,7 +4,7 @@ require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.2.4.bb b/recipes/gcc/gcc_4.2.4.bb
index 6fe30282d6..a174e11d08 100644
--- a/recipes/gcc/gcc_4.2.4.bb
+++ b/recipes/gcc/gcc_4.2.4.bb
@@ -4,7 +4,7 @@ require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.3.1.bb b/recipes/gcc/gcc_4.3.1.bb
index 442c273ffc..38ae714029 100644
--- a/recipes/gcc/gcc_4.3.1.bb
+++ b/recipes/gcc/gcc_4.3.1.bb
@@ -4,7 +4,7 @@ require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.3.2.bb b/recipes/gcc/gcc_4.3.2.bb
index c73dfc1c84..998f58c91b 100644
--- a/recipes/gcc/gcc_4.3.2.bb
+++ b/recipes/gcc/gcc_4.3.2.bb
@@ -8,6 +8,6 @@ FILES_${PN} += "\
${gcclibdir}/${TARGET_SYS}/*/*.o \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.3.3.bb b/recipes/gcc/gcc_4.3.3.bb
index 274f474d37..263969ab3a 100644
--- a/recipes/gcc/gcc_4.3.3.bb
+++ b/recipes/gcc/gcc_4.3.3.bb
@@ -8,7 +8,7 @@ FILES_${PN} += "\
${gcclibdir}/${TARGET_SYS}/*/*.o \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.3.4.bb b/recipes/gcc/gcc_4.3.4.bb
index ec20085d90..57ced1637c 100644
--- a/recipes/gcc/gcc_4.3.4.bb
+++ b/recipes/gcc/gcc_4.3.4.bb
@@ -8,6 +8,6 @@ FILES_${PN} += "\
${gcclibdir}/${TARGET_SYS}/*/*.o \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.4.1.bb b/recipes/gcc/gcc_4.4.1.bb
index 52b09cf661..30ab40296a 100644
--- a/recipes/gcc/gcc_4.4.1.bb
+++ b/recipes/gcc/gcc_4.4.1.bb
@@ -8,7 +8,7 @@ FILES_${PN} += "\
${gcclibdir}/${TARGET_SYS}/*/*.o \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.4.2.bb b/recipes/gcc/gcc_4.4.2.bb
index d1d50adacf..55f05b5d14 100644
--- a/recipes/gcc/gcc_4.4.2.bb
+++ b/recipes/gcc/gcc_4.4.2.bb
@@ -8,7 +8,7 @@ FILES_${PN} += "\
${gcclibdir}/${TARGET_SYS}/*/*.o \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.4.4.bb b/recipes/gcc/gcc_4.4.4.bb
index 271e9d152d..6aeac2fb56 100644
--- a/recipes/gcc/gcc_4.4.4.bb
+++ b/recipes/gcc/gcc_4.4.4.bb
@@ -8,6 +8,6 @@ FILES_${PN} += "\
${gcclibdir}/${TARGET_SYS}/*/*.o \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_4.5.bb b/recipes/gcc/gcc_4.5.bb
index ad71ada0f9..bc59b14590 100644
--- a/recipes/gcc/gcc_4.5.bb
+++ b/recipes/gcc/gcc_4.5.bb
@@ -10,6 +10,6 @@ FILES_${PN} += "\
${libexecdir}/gcc/${TARGET_SYS}/${BINV}/lto-wrapper \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
diff --git a/recipes/gcc/gcc_svn.bb b/recipes/gcc/gcc_svn.bb
index 9b69a23d11..033217428d 100644
--- a/recipes/gcc/gcc_svn.bb
+++ b/recipes/gcc/gcc_svn.bb
@@ -8,6 +8,6 @@ FILES_${PN} += "\
${gcclibdir}/${TARGET_SYS}/*/*.o \
"
-SRC_URI_append = "file://fortran-cross-compile-hack.patch"
+SRC_URI += "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"