aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/glib-2.0
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-02 13:05:33 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-02 13:06:28 -0800
commit90350c170fb96a014edc0dff2dded9d8649091f3 (patch)
tree6d92d8c25f169012d632438524765eb6f2126ad6 /recipes/glib-2.0
parentd362c04c192d55af699b7f60ef2072c4d0ed6311 (diff)
downloadopenembedded-90350c170fb96a014edc0dff2dded9d8649091f3.tar.gz
glib-2.0_2.26.1.bb: Patch to make is work on systems without atomics
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/glib-2.0')
-rw-r--r--recipes/glib-2.0/glib-2.0-2.26.1/libglib2-fix-compilation-with-no-builtin-atomic.patch25
-rw-r--r--recipes/glib-2.0/glib-2.0_2.26.1.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes/glib-2.0/glib-2.0-2.26.1/libglib2-fix-compilation-with-no-builtin-atomic.patch b/recipes/glib-2.0/glib-2.0-2.26.1/libglib2-fix-compilation-with-no-builtin-atomic.patch
new file mode 100644
index 0000000000..39c0510781
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.26.1/libglib2-fix-compilation-with-no-builtin-atomic.patch
@@ -0,0 +1,25 @@
+From 58096320ea0888c4fbbff318839017a4d2e82703 Mon Sep 17 00:00:00 2001
+From: Lionel Landwerlin <llandwerlin@gmail.com>
+Date: Sat, 6 Nov 2010 14:56:15 +0100
+Subject: [PATCH] glib: fix compilation with no builtin atomic operations compilers
+
+Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
+---
+ glib/gatomic.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/glib/gatomic.c b/glib/gatomic.c
+index 845c866..01468ce 100644
+--- a/glib/gatomic.c
++++ b/glib/gatomic.c
+@@ -881,6 +881,7 @@ g_atomic_pointer_compare_and_exchange (volatile gpointer G_GNUC_MAY_ALIAS *atomi
+ #endif /* DEFINE_WITH_WIN32_INTERLOCKED */
+
+ #ifdef DEFINE_WITH_MUTEXES
++# include "gthread.h"
+ /* We have to use the slow, but safe locking method */
+ static GMutex *g_atomic_mutex;
+
+--
+1.7.2.3
+
diff --git a/recipes/glib-2.0/glib-2.0_2.26.1.bb b/recipes/glib-2.0/glib-2.0_2.26.1.bb
index 1fa9b6abdd..8788258e78 100644
--- a/recipes/glib-2.0/glib-2.0_2.26.1.bb
+++ b/recipes/glib-2.0/glib-2.0_2.26.1.bb
@@ -10,7 +10,7 @@ DEPENDS = "glib-2.0-native gtk-doc zlib"
DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
pkgconfig-native"
-PR = "r1"
+PR = "r2"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.26/glib-${PV}.tar.bz2;name=archive \
@@ -20,6 +20,7 @@ SRC_URI = "\
file://gatomic-proper-pointer-get-cast.patch \
file://60_wait-longer-for-threads-to-die.patch \
file://glib-mkenums-interpreter.patch \
+ file://libglib2-fix-compilation-with-no-builtin-atomic.patch \
"
SRC_URI[archive.md5sum] = "17535accceef55bcb17a74d73f9c2aef"