aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnash
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gnash
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gnash')
-rw-r--r--recipes/gnash/files/fix-trunc.diff13
-rw-r--r--recipes/gnash/files/libintl.patch13
-rw-r--r--recipes/gnash/files/libtool-2.2.patch35
-rw-r--r--recipes/gnash/gnash-minimal.inc62
-rw-r--r--recipes/gnash/gnash-minimal_0.8.2.bb3
-rw-r--r--recipes/gnash/gnash-minimal_0.8.3.bb12
-rw-r--r--recipes/gnash/gnash-minimal_cvs.bb20
-rw-r--r--recipes/gnash/gnash.inc45
-rw-r--r--recipes/gnash/gnash_0.8.0.bb3
-rw-r--r--recipes/gnash/gnash_0.8.1.bb3
-rw-r--r--recipes/gnash/gnash_0.8.2.bb3
-rw-r--r--recipes/gnash/gnash_0.8.3.bb11
-rw-r--r--recipes/gnash/gnash_0.8.4.bb24
-rw-r--r--recipes/gnash/gnash_0.8.5.bb38
14 files changed, 285 insertions, 0 deletions
diff --git a/recipes/gnash/files/fix-trunc.diff b/recipes/gnash/files/fix-trunc.diff
new file mode 100644
index 0000000000..a01ca311d0
--- /dev/null
+++ b/recipes/gnash/files/fix-trunc.diff
@@ -0,0 +1,13 @@
+--- /tmp/utility.h 2008-09-02 16:35:44.000000000 +0200
++++ gnash/libbase/utility.h 2008-09-02 16:36:10.000000000 +0200
+@@ -327,6 +327,10 @@
+ #endif
+ }
+
++#ifndef HAVE_TRUNC
++inline double trunc(double x) { return (x < 0 ? -(std::floor(-x)) : std::floor(x)); }
++#endif
++
+ #endif // UTILITY_H
+
+
diff --git a/recipes/gnash/files/libintl.patch b/recipes/gnash/files/libintl.patch
new file mode 100644
index 0000000000..22e1acb65b
--- /dev/null
+++ b/recipes/gnash/files/libintl.patch
@@ -0,0 +1,13 @@
+Index: gnash-0.8.3/gui/am-frag/fb.am
+===================================================================
+--- gnash-0.8.3.orig/gui/am-frag/fb.am 2008-08-19 00:37:45.000000000 +0200
++++ gnash-0.8.3/gui/am-frag/fb.am 2008-08-19 00:38:04.000000000 +0200
+@@ -30,7 +30,7 @@
+ fb_gnash_CPPFLAGS += $(AGG_CFLAGS)
+ fb_gnash_SOURCES +=
+ fb_gnash_LDADD = $(top_builddir)/backend/libgnashagg.la \
+- $(GNASH_LIBS) $(AGG_LIBS)
++ $(GNASH_LIBS) $(AGG_LIBS) $(INTLLIBS)
+ endif # BUILD_AGG_RENDERER
+ endif # BUILD_FB_GUI
+
diff --git a/recipes/gnash/files/libtool-2.2.patch b/recipes/gnash/files/libtool-2.2.patch
new file mode 100644
index 0000000000..f0ec274104
--- /dev/null
+++ b/recipes/gnash/files/libtool-2.2.patch
@@ -0,0 +1,35 @@
+diff -NrU5 gnash-0.8.3.orig/libbase/Makefile.am gnash-0.8.3/libbase/Makefile.am
+--- gnash-0.8.3.orig/libbase/Makefile.am 2008-06-26 22:56:12.000000000 +0200
++++ gnash-0.8.3/libbase/Makefile.am 2008-06-26 22:57:48.000000000 +0200
+@@ -19,13 +19,13 @@
+
+ # this is where Gnash plugins get installed
+ pluginsdir = $(prefix)/lib/gnash/plugins
+
+ if INSTALL_LTDL
+-include_HEADERS = $(top_srcdir)/libltdl/ltdl.h
+-LIBLTDLLIB = libltdl.la
+-LIBLTDLHEAD = $(top_srcdir)/libltdl/ltdl.h
++#include_HEADERS = $(top_srcdir)/libltdl/ltdl.h
++#LIBLTDLLIB = libltdl.la
++#LIBLTDLHEAD = $(top_srcdir)/libltdl/ltdl.h
+ endif
+
+ sysconf_DATA = gnashrc gnashpluginrc
+
+ edit = sed \
+@@ -174,12 +174,12 @@
+
+ libgnashbase_la_LDFLAGS = -release $(VERSION)
+
+ libltdlc_la_CPPFLAGS = $(LTDLINCL)
+ if CONVENIENCE_LTDL
+-noinst_LTLIBRARIES = libltdlc.la
+-libltdlc_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
++#noinst_LTLIBRARIES = libltdlc.la
++#libltdlc_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
+ endif
+ CLEANFILES = libltdl.la libltdlc.la gnashrc gnashpluginrc
+
+ libltdl_la_SOURCES = $(top_srcdir)/libltdl/ltdl.c
+ libltdl_la_LDFLAGS = -no-undefined -version-info 4:4:1
diff --git a/recipes/gnash/gnash-minimal.inc b/recipes/gnash/gnash-minimal.inc
new file mode 100644
index 0000000000..a8e5229f46
--- /dev/null
+++ b/recipes/gnash/gnash-minimal.inc
@@ -0,0 +1,62 @@
+DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
+HOMEPAGE = "http://www.gnu.org/software/gnash"
+LICENSE = "GPL-2"
+
+DEPENDS = "virtual/libiconv virtual/libintl libtool agg libxml2 zlib boost jpeg pango curl freetype \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'ffmpeg libmad', d)}"
+RRECOMMENDS_${PN} = "libltdl"
+
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2"
+S = ${WORKDIR}/gnash-${PV}
+
+inherit autotools pkgconfig
+
+# gnash-minimal is intended for running directly on a framebuffer device
+# for memory constrained devices, but does not accept all SWF files.
+# As such, it is useful as a GUI frontend for dedicated SWF files.
+
+# JPEG support and libz cannot be disabled due to a bug in 0.8.2.
+# maintainer-mode is enabled to disable the testsuite.
+
+EXTRA_OECONF="--enable-gui=gtk \
+ --enable-renderer=agg \
+ --enable-agg \
+ --enable-gui=fb \
+ --enable-z \
+ --enable-jpeg \
+ --disable-klash \
+ --disable-glext \
+ --disable-Xft \
+ --disable-expat \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-mad', d)} \
+ --disable-gstreamer \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-media=ffmpeg', d)} \
+ --enable-media=ffmpeg \
+ --disable-plugin \
+ --disable-cygnal \
+ --disable-testsuite \
+ --enable-maintainer-mode \
+ --enable-fps-debug \
+ --enable-allstatic \
+ --enable-static \
+ --with-top-level=${STAGING_DIR_HOST}/usr \
+ --disable-ltdl-install \
+ --without-included-ltdl \
+# --with-ltdl-include=${STAGING_INCDIR} \
+# --with-ltdl-lib=${STAGING_LIBDIR} \
+"
+
+# the test for error_t is wrong for uclibc, needs _GNU_SOURCE for correct
+# detection because uclibc does not have argz.h which enables error_t
+CFLAGS += " -D_GNU_SOURCE -I${S}/libltdl -I${STAGING_INCDIR}/libltdl $(pkgconfig --cflags gstreamer)"
+
+PACKAGES =+ "libgnashnet libgnashamf libgnashbase libgnashserver libgnashmedia"
+
+FILES_${PN} += "${datadir}/gnash/*png ${datadir}/gnash/*ico"
+FILES_${PN}-dbg += "${libdir}/gnash/.debug"
+FILES_${PN}-dev += "${libdir}/gnash/*a"
+FILES_libgnashamf = "${libdir}/gnash/libgnashamf-*.so"
+FILES_libgnashbase = "${libdir}/gnash/libgnashbase-*.so"
+FILES_libgnashmedia = "${libdir}/gnash/libgnashmedia-*.so"
+FILES_libgnashserver = "${libdir}/gnash/libgnashserver-*.so"
+FILES_libgnashnet = "${libdir}/gnash/libgnashnet.so.*"
diff --git a/recipes/gnash/gnash-minimal_0.8.2.bb b/recipes/gnash/gnash-minimal_0.8.2.bb
new file mode 100644
index 0000000000..81a97e3b7d
--- /dev/null
+++ b/recipes/gnash/gnash-minimal_0.8.2.bb
@@ -0,0 +1,3 @@
+require gnash-minimal.inc
+
+PR = "r4"
diff --git a/recipes/gnash/gnash-minimal_0.8.3.bb b/recipes/gnash/gnash-minimal_0.8.3.bb
new file mode 100644
index 0000000000..6f78d94c10
--- /dev/null
+++ b/recipes/gnash/gnash-minimal_0.8.3.bb
@@ -0,0 +1,12 @@
+require gnash-minimal.inc
+
+PR = "r9"
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+"
+
+SRC_URI += "file://libtool-2.2.patch;patch=1 file://libintl.patch;patch=1"
+
+
diff --git a/recipes/gnash/gnash-minimal_cvs.bb b/recipes/gnash/gnash-minimal_cvs.bb
new file mode 100644
index 0000000000..e1eff37b88
--- /dev/null
+++ b/recipes/gnash/gnash-minimal_cvs.bb
@@ -0,0 +1,20 @@
+require gnash-minimal.inc
+
+
+PR = "r4"
+
+PV = "0.8.3+cvs${SRCDATE}"
+
+SRC_URI = "cvs://anonymous:anonymous@cvs.sv.gnu.org/sources/gnash;module=gnash"
+SRC_URI += "file://libtool-2.2.patch;patch=1 \
+ file://libintl.patch;patch=1 \
+ file://fix-trunc.diff;patch=1"
+
+S = ${WORKDIR}/gnash
+
+
+do_configure_prepend() {
+ sed -i -e 's:dnl AC_CHECK_LIB(m, trunc:AC_CHECK_LIB(m, trunc:g' ${S}/configure.ac
+}
+
+
diff --git a/recipes/gnash/gnash.inc b/recipes/gnash/gnash.inc
new file mode 100644
index 0000000000..3602f6fa90
--- /dev/null
+++ b/recipes/gnash/gnash.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
+HOMEPAGE = "http://www.gnu.org/software/gnash"
+LICENSE = "GPL-2"
+DEPENDS = "giflib libtool gtk+ cairo libxml2 libsdl-mixer zlib boost jpeg pango curl freetype \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'ffmpeg libmad', d)}"
+
+PR = "r5"
+
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-gui=gtk \
+ --enable-renderer=cairo \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-media=ffmpeg', d)} \
+ --disable-klash \
+ --enable-z \
+ --enable-jpeg \
+ --disable-glext \
+ --enable-Xft \
+ --enable-expat \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-mad', d)} \
+ --enable-cairo \
+ --enable-plugin \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --disable-cygnal \
+ --with-top-level=${STAGING_DIR_HOST}/usr \
+ "
+
+PACKAGES =+ " gnash-browser-plugin libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
+
+FILES_gnash-browser-plugin= "${libdir}/mozilla/plugins/*"
+FILES_libgnashamf = "${libdir}/gnash/libgnashamf-${PV}.so"
+FILES_libgnashbackend = "${libdir}/gnash/libgnashbackend-${PV}.so"
+FILES_libgnashbase = "${libdir}/gnash/libgnashbase-${PV}.so"
+FILES_libgnashgeo = "${libdir}/gnash/libgnashgeo-${PV}.so"
+FILES_libgnashgui = "${libdir}/gnash/libgnashgui-${PV}.so"
+FILES_libgnashplayer = "${libdir}/gnash/libgnashplayer-${PV}.so"
+FILES_libgnashserver = "${libdir}/gnash/libgnashserver-${PV}.so"
+
+PARALLEL_MAKE = ""
diff --git a/recipes/gnash/gnash_0.8.0.bb b/recipes/gnash/gnash_0.8.0.bb
new file mode 100644
index 0000000000..e809525606
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.0.bb
@@ -0,0 +1,3 @@
+require gnash.inc
+
+PR = "r2"
diff --git a/recipes/gnash/gnash_0.8.1.bb b/recipes/gnash/gnash_0.8.1.bb
new file mode 100644
index 0000000000..e809525606
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.1.bb
@@ -0,0 +1,3 @@
+require gnash.inc
+
+PR = "r2"
diff --git a/recipes/gnash/gnash_0.8.2.bb b/recipes/gnash/gnash_0.8.2.bb
new file mode 100644
index 0000000000..e809525606
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.2.bb
@@ -0,0 +1,3 @@
+require gnash.inc
+
+PR = "r2"
diff --git a/recipes/gnash/gnash_0.8.3.bb b/recipes/gnash/gnash_0.8.3.bb
new file mode 100644
index 0000000000..1b36f30af0
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.3.bb
@@ -0,0 +1,11 @@
+require gnash.inc
+
+PR = "r5"
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+"
+
+SRC_URI += "file://libtool-2.2.patch;patch=1"
+
diff --git a/recipes/gnash/gnash_0.8.4.bb b/recipes/gnash/gnash_0.8.4.bb
new file mode 100644
index 0000000000..0a9c780cc4
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.4.bb
@@ -0,0 +1,24 @@
+require gnash.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+do_configure_prepend() {
+ sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:LIBPNG:PNG:g $i
+ done
+ export CFLAGS="${CFLAGS} -lpng"
+}
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --enable-png \
+ --with-png-incl=${STAGING_INCDIR} \
+ --with-png-lib=${STAGING_LIBDIR} \
+ "
+
diff --git a/recipes/gnash/gnash_0.8.5.bb b/recipes/gnash/gnash_0.8.5.bb
new file mode 100644
index 0000000000..fa9b3230e3
--- /dev/null
+++ b/recipes/gnash/gnash_0.8.5.bb
@@ -0,0 +1,38 @@
+require gnash.inc
+
+DEPENDS += "gst-plugins-base"
+
+acpaths = " -Imacros"
+
+DEFAULT_PREFERENCE = "-1"
+
+# Boost lacks defines for lots of archs
+TARGET_CC_ARCH_append = " -I${STAGING_INCDIR}/libxml2 -DHAVE_POLL_H ${@[' -D_BIG_ENDIAN', ' -D_LITTLE_ENDIAN'][bb.data.getVar('SITEINFO_ENDIANESS', d, 1) == 'le']}"
+
+
+do_configure_prepend() {
+ sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:LIBPNG:PNG:g $i
+ done
+ export CFLAGS="${CFLAGS} -lpng"
+}
+
+do_install_append() {
+ oe_runmake DESTDIR=${D} install-plugin
+}
+
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --enable-png \
+ --with-png-incl=${STAGING_INCDIR} \
+ --with-png-lib=${STAGING_LIBDIR} \
+ --enable-media=gst \
+ "
+