aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gnuradio
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2011-05-13 13:21:45 -0400
committerTom Rini <trini@kernel.crashing.org>2011-09-22 16:55:37 -0700
commit51aacab374a4508357901f3565d9766f1335d280 (patch)
tree82cfdb6f38fe0712e3ababdd1b304e3edba7310a /recipes/gnuradio
parent29142b90114a591edca4dccb51f3a0a933ea8e9e (diff)
downloadopenembedded-51aacab374a4508357901f3565d9766f1335d280.tar.gz
gnuradio : Update rev to latest master and add patch to really disable volk.
Signed-off-by: Philip Balister <philip@balister.org>
Diffstat (limited to 'recipes/gnuradio')
-rw-r--r--recipes/gnuradio/gnuradio-git/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch42
-rw-r--r--recipes/gnuradio/gnuradio_git.bb9
2 files changed, 48 insertions, 3 deletions
diff --git a/recipes/gnuradio/gnuradio-git/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch b/recipes/gnuradio/gnuradio-git/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch
new file mode 100644
index 0000000000..e2f674b752
--- /dev/null
+++ b/recipes/gnuradio/gnuradio-git/0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch
@@ -0,0 +1,42 @@
+From 857c38eb8201e2a34b524fcabea21b1accbdb288 Mon Sep 17 00:00:00 2001
+From: Philip Balister <philip@opensdr.com>
+Date: Fri, 13 May 2011 12:26:14 -0400
+Subject: [PATCH] volk : Remove all traces of volk from configure for OE builds.
+
+Signed-off-by: Philip Balister <philip@opensdr.com>
+---
+ Makefile.common | 4 ++--
+ configure.ac | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.common b/Makefile.common
+index 20b8a78..aeda1dd 100644
+--- a/Makefile.common
++++ b/Makefile.common
+@@ -92,8 +92,8 @@ GRUEL_INCLUDES = @gruel_INCLUDES@
+ GRUEL_LA = @gruel_LA@
+
+ # How to link in the VOLK library from inside the tree
+-VOLK_INCLUDES = @volk_INCLUDES@
+-VOLK_LA = @volk_LA@
++#VOLK_INCLUDES = @volk_INCLUDES@
++#VOLK_LA = @volk_LA@
+
+ # How to link in the USRP library from inside the tree
+ USRP_INCLUDES = @usrp_INCLUDES@
+diff --git a/configure.ac b/configure.ac
+index 73ebbd6..e5cf7a2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -349,7 +349,7 @@ AC_ARG_ENABLE(
+
+ build_dirs="config"
+ GRC_GRUEL dnl must come first
+-GRC_VOLK
++dnl GRC_VOLK
+ GRC_GCELL
+ GRC_GNURADIO_CORE
+ GRC_USRP
+--
+1.7.3.4
+
diff --git a/recipes/gnuradio/gnuradio_git.bb b/recipes/gnuradio/gnuradio_git.bb
index bc18d9e765..cf3bf5d408 100644
--- a/recipes/gnuradio/gnuradio_git.bb
+++ b/recipes/gnuradio/gnuradio_git.bb
@@ -1,15 +1,18 @@
require recipes/gnuradio/gnuradio.inc
PR = "${INC_PR}.1"
-PV = "3.3.0-${PR}+gitr${SRCREV}"
+PV = "3.4.0-${PR}+gitr${SRCREV}"
-SRCREV = "cdca1c917626f7c63f820da921a17187efc92cd5"
+SRCREV = "f53fef3d2bc39b2020b8bce3d88b43569dd16605"
# Make it easy to test against developer repos and branches
GIT_REPO = "gnuradio.git"
-GIT_BRANCH = "next"
+GIT_BRANCH = "master"
+
+FILESPATHPKG_prepend = "gnuradio-git:"
SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \
+ file://0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch \
"
S="${WORKDIR}/git"