aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gthumb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-01-28 14:20:07 +0000
committerGraeme Gregory <dp@xora.org.uk>2010-01-28 14:22:07 +0000
commitde2fec4c895d6fee8ad1111ea9ee8ebd36531123 (patch)
tree68a9b5a4f60efc26c5e42a79e252cd445096e0b1 /recipes/gthumb
parentcf026fcfe7192d086e3b7dba1c3e8174feff6ad5 (diff)
downloadopenembedded-de2fec4c895d6fee8ad1111ea9ee8ebd36531123.tar.gz
gthumb_2.10.11.bb : add a hack to make it look at sysroot not /
I found that the pkg-config sysroot support doesnt extend to variables so some extra munging was needed to point this at the correct IDL files.
Diffstat (limited to 'recipes/gthumb')
-rw-r--r--recipes/gthumb/gthumb/pkg-config-hack.patch7
-rw-r--r--recipes/gthumb/gthumb_2.10.11.bb9
2 files changed, 13 insertions, 3 deletions
diff --git a/recipes/gthumb/gthumb/pkg-config-hack.patch b/recipes/gthumb/gthumb/pkg-config-hack.patch
new file mode 100644
index 0000000000..e9981d1eb0
--- /dev/null
+++ b/recipes/gthumb/gthumb/pkg-config-hack.patch
@@ -0,0 +1,7 @@
+Index: gthumb-2.10.11/add-include-prefix
+===================================================================
+--- gthumb-2.10.11.orig/add-include-prefix
++++ gthumb-2.10.11/add-include-prefix
+@@ -1 +1 @@
+-sed -e 's/^/ /' -e 's/ \+$//' -e 's/ / -I /g' -e 's/^ \+//'
++sed -e 's|^| |' -e 's| \+$||' -e 's| | -I HACK_STAGING_DIR_HOST|g' -e 's|^ \+||'
diff --git a/recipes/gthumb/gthumb_2.10.11.bb b/recipes/gthumb/gthumb_2.10.11.bb
index 94f37a04d5..436d506a87 100644
--- a/recipes/gthumb/gthumb_2.10.11.bb
+++ b/recipes/gthumb/gthumb_2.10.11.bb
@@ -5,10 +5,13 @@ DEPENDS = "gtk+ libexif libgnome libgnomeui libgnomeprintui"
inherit gnome
-PR = "r1"
+SRC_URI += "file://pkg-config-hack.patch;patch=1"
+
+PR = "r2"
FILES_${PN} += "${libdir}/*.so ${datadir}/gnome* ${datadir}/application-registry/*"
FILES_${PN}-dbg += "${libdir}/gthumb/modules/.debug"
-
-
+do_configure_prepend() {
+ sed -i "s|HACK_STAGING_DIR_HOST|${STAGING_DIR_HOST}|" ${S}/add-include-prefix
+}