aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtkhtml
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gtkhtml
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gtkhtml')
-rw-r--r--recipes/gtkhtml/gtkhtml-2.0_2.6.3.bb18
-rw-r--r--recipes/gtkhtml/gtkhtml-3.0/fix-missing-colormap.patch36
-rw-r--r--recipes/gtkhtml/gtkhtml-3.0_3.0.10.bb19
-rw-r--r--recipes/gtkhtml/gtkhtml-3.1_3.1.16.bb12
-rw-r--r--recipes/gtkhtml/gtkhtml-3.6/cross-includedir.patch25
-rw-r--r--recipes/gtkhtml/gtkhtml-3.6_3.6.2.bb14
-rw-r--r--recipes/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch39
-rw-r--r--recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb29
-rw-r--r--recipes/gtkhtml/gtkhtml-3.8_3.18.0.bb12
-rw-r--r--recipes/gtkhtml/gtkhtml-3.8_3.8.2.bb12
-rw-r--r--recipes/gtkhtml/gtkhtml-lite-3.0_3.0.10.bb18
-rw-r--r--recipes/gtkhtml/gtkhtml.inc15
12 files changed, 249 insertions, 0 deletions
diff --git a/recipes/gtkhtml/gtkhtml-2.0_2.6.3.bb b/recipes/gtkhtml/gtkhtml-2.0_2.6.3.bb
new file mode 100644
index 0000000000..f44e8b57a6
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-2.0_2.6.3.bb
@@ -0,0 +1,18 @@
+require gtkhtml.inc
+
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui gal-2.0"
+PR = "r0"
+
+SRC_URI = "http://ftp.debian.org/debian/pool/main/libg/libgtkhtml2/libgtkhtml2_2.6.3.orig.tar.gz"
+
+FILES_${PN} += "${datadir}/gtkhtml-3.0 ${libdir}/gtkhtml/*.so"
+FILES_${PN}-dev += "${libdir}/gtkhtml"
+
+do_stage() {
+ mv src/libgtkhtml.pc src/libgtkhtml-2.0.pc || true
+ autotools_stage_all
+}
+
+do_compile() {
+ oe_runmake ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2
+}
diff --git a/recipes/gtkhtml/gtkhtml-3.0/fix-missing-colormap.patch b/recipes/gtkhtml/gtkhtml-3.0/fix-missing-colormap.patch
new file mode 100644
index 0000000000..6ec7409bd4
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.0/fix-missing-colormap.patch
@@ -0,0 +1,36 @@
+--- gtkhtml-3.0.10/src/htmlgdkpainter.c.orig 2004-07-23 17:07:05.000000000 +0100
++++ gtkhtml-3.0.10/src/htmlgdkpainter.c 2004-07-23 17:17:09.000000000 +0100
+@@ -277,22 +277,19 @@
+ begin (HTMLPainter *painter, int x1, int y1, int x2, int y2)
+ {
+ HTMLGdkPainter *gdk_painter;
+- GdkVisual *visual;
+
+ /* printf ("painter begin %d,%d %d,%d\n", x1, y1, x2, y2); */
+
+ gdk_painter = HTML_GDK_PAINTER (painter);
+ g_return_if_fail (gdk_painter->window != NULL);
+- visual = gdk_drawable_get_visual (gdk_painter->window);
+- g_return_if_fail (visual != NULL);
+
+ if (gdk_painter->double_buffer){
+ const int width = x2 - x1 + 1;
+ const int height = y2 - y1 + 1;
+
+ g_assert (gdk_painter->pixmap == NULL);
+-
+- gdk_painter->pixmap = gdk_pixmap_new (gdk_painter->pixmap, width, height, visual->depth);
++
++ gdk_painter->pixmap = gdk_pixmap_new (gdk_painter->window, width, height, -1);
+ gdk_painter->x1 = x1;
+ gdk_painter->y1 = y1;
+ gdk_painter->x2 = x2;
+@@ -313,6 +310,8 @@
+ gdk_painter->x2 = 0;
+ gdk_painter->y2 = 0;
+ }
++
++ g_assert(gdk_drawable_get_colormap(gdk_painter->pixmap) != NULL);
+ }
+
+ static void
diff --git a/recipes/gtkhtml/gtkhtml-3.0_3.0.10.bb b/recipes/gtkhtml/gtkhtml-3.0_3.0.10.bb
new file mode 100644
index 0000000000..66993cec74
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.0_3.0.10.bb
@@ -0,0 +1,19 @@
+require gtkhtml.inc
+
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui gal-2.0"
+PR = "r2"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.0/gtkhtml-${PV}.tar.bz2 \
+ file://fix-missing-colormap.patch;patch=1"
+FILES_${PN} += "${datadir}/gtkhtml-3.0 ${libdir}/gtkhtml/*.so"
+FILES_${PN}-dev += "${libdir}/gtkhtml"
+
+do_stage() {
+ mv src/libgtkhtml.pc src/libgtkhtml-3.0.pc || true
+ gnome_stage_includes
+ oe_libinstall -C src -so libgtkhtml-3.0 ${STAGING_LIBDIR}
+}
+
+do_compile() {
+ oe_runmake ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2
+}
diff --git a/recipes/gtkhtml/gtkhtml-3.1_3.1.16.bb b/recipes/gtkhtml/gtkhtml-3.1_3.1.16.bb
new file mode 100644
index 0000000000..1e389dabe0
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.1_3.1.16.bb
@@ -0,0 +1,12 @@
+require gtkhtml.inc
+
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.1/gtkhtml-${PV}.tar.bz2"
+FILES_${PN} += "${datadir}/gtkhtml-3.1"
+
+do_stage() {
+ mv src/libgtkhtml.pc src/libgtkhtml-3.1.pc || true
+ gnome_stage_includes
+ oe_libinstall -C src -so libgtkhtml-3.1 ${STAGING_LIBDIR}
+}
diff --git a/recipes/gtkhtml/gtkhtml-3.6/cross-includedir.patch b/recipes/gtkhtml/gtkhtml-3.6/cross-includedir.patch
new file mode 100644
index 0000000000..f69b0f3421
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.6/cross-includedir.patch
@@ -0,0 +1,25 @@
+diff --git a/components/html-editor/Makefile.am b/components/html-editor/Makefile.am
+index 7fda5ae..925e409 100644
+--- a/components/html-editor/Makefile.am
++++ b/components/html-editor/Makefile.am
+@@ -5,7 +5,7 @@ gtkhtml_data = $(datadir)/gtkhtml-@GTKHTML_API_VERSION@
+ gladedir = $(gtkhtml_data)
+ glade_DATA = gtkhtml-editor-properties.glade
+
+-INCLUDES = -I$(top_srcdir)/src -I$(srcdir) -I$(includedir) $(GTKHTML_CFLAGS) $(SOUP_CFLAGS) \
++INCLUDES = -I$(top_srcdir)/src -I$(srcdir) $(GTKHTML_CFLAGS) $(SOUP_CFLAGS) \
+ -DG_LOG_DOMAIN=\"gtkhtml\" \
+ -DSRCDIR=\"$(srcdir)\" \
+ -DPREFIX=\"$(prefix)\"
+diff --git a/src/Makefile.am b/src/Makefile.am
+index f76178f..2d70183 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -3,7 +3,6 @@ NULL=
+ INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(srcdir) \
+- -I$(includedir) \
+ $(GTKHTML_CFLAGS) \
+ $(SOUP_CFLAGS) \
+ -DG_LOG_DOMAIN=\"gtkhtml\" \
diff --git a/recipes/gtkhtml/gtkhtml-3.6_3.6.2.bb b/recipes/gtkhtml/gtkhtml-3.6_3.6.2.bb
new file mode 100644
index 0000000000..cb2b8b2acc
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.6_3.6.2.bb
@@ -0,0 +1,14 @@
+require gtkhtml.inc
+
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.6/gtkhtml-${PV}.tar.bz2 \
+ file://cross-includedir.patch;patch=1"
+PR = "r1"
+FILES_${PN} += "${datadir}/gtkhtml-3.6"
+
+do_stage() {
+ mv src/libgtkhtml.pc src/libgtkhtml-3.6.pc || true
+ gnome_stage_includes
+ oe_libinstall -C src -so libgtkhtml-3.6 ${STAGING_LIBDIR}
+}
diff --git a/recipes/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch b/recipes/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch
new file mode 100644
index 0000000000..60e46488cf
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.8/60_glib-2.15-g-gnuc-function.patch
@@ -0,0 +1,39 @@
+diff -Nur gtkhtml3.8-3.12.3/src/htmlengine-edit-clueflowstyle.c gtkhtml3.8-3.12.3.new/src/htmlengine-edit-clueflowstyle.c
+--- gtkhtml3.8-3.12.3/src/htmlengine-edit-clueflowstyle.c 2007-01-29 10:50:59.000000000 +0100
++++ gtkhtml3.8-3.12.3.new/src/htmlengine-edit-clueflowstyle.c 2008-02-15 10:07:22.000000000 +0100
+@@ -175,7 +175,7 @@
+ while (p != NULL) {
+ if (HTML_OBJECT_TYPE (obj->parent) != HTML_TYPE_CLUEFLOW) {
+ g_warning ("(%s:%s) Eeeek! Unknown parent type `%s'.",
+- __FILE__, G_GNUC_FUNCTION,
++ __FILE__, G_STRFUNC,
+ html_type_name (HTML_OBJECT_TYPE (obj->parent)));
+ break;
+ }
+@@ -209,7 +209,7 @@
+ /* This should not happen. */
+ g_warning ("(%s:%s) There were not enough paragraphs for "
+ "setting the paragraph style.",
+- __FILE__, G_GNUC_FUNCTION);
++ __FILE__, G_STRFUNC);
+ break;
+ }
+ } while (obj != NULL && HTML_CLUEFLOW (obj->parent) == clueflow);
+@@ -217,7 +217,7 @@
+
+ if (prop_list == NULL) {
+ /* This should not happen. */
+- g_warning ("%s:%s Eeek! Nothing done?", __FILE__, G_GNUC_FUNCTION);
++ g_warning ("%s:%s Eeek! Nothing done?", __FILE__, G_STRFUNC);
+ return;
+ }
+
+@@ -280,7 +280,7 @@
+ while (p != NULL) {
+ if (HTML_OBJECT_TYPE (p->parent) != HTML_TYPE_CLUEFLOW) {
+ g_warning ("(%s:%s) Eeeek! Unknown parent type `%s'.",
+- __FILE__, G_GNUC_FUNCTION,
++ __FILE__, G_STRFUNC,
+ html_type_name (HTML_OBJECT_TYPE (p->parent)));
+ break;
+ }
diff --git a/recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb b/recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb
new file mode 100644
index 0000000000..e8727bd0dc
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.8_3.12.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "HTML rendering/editing library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.12/gtkhtml-${PV}.tar.bz2 \
+ file://60_glib-2.15-g-gnuc-function.patch;patch=1"
+
+S = "${WORKDIR}/gtkhtml-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+ORBIT_IDL = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
+ find ${S} -name Makefile | xargs sed -i 's|ORBIT_IDL =.*|ORBIT_IDL = ${ORBIT_IDL}|'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+
diff --git a/recipes/gtkhtml/gtkhtml-3.8_3.18.0.bb b/recipes/gtkhtml/gtkhtml-3.8_3.18.0.bb
new file mode 100644
index 0000000000..e678bc3134
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.8_3.18.0.bb
@@ -0,0 +1,12 @@
+require gtkhtml.inc
+
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.18/gtkhtml-${PV}.tar.bz2"
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+
+do_stage() {
+ mv src/libgtkhtml.pc src/libgtkhtml-3.8.pc || true
+ gnome_stage_includes
+ oe_libinstall -C src -so libgtkhtml-3.8 ${STAGING_LIBDIR}
+}
diff --git a/recipes/gtkhtml/gtkhtml-3.8_3.8.2.bb b/recipes/gtkhtml/gtkhtml-3.8_3.8.2.bb
new file mode 100644
index 0000000000..cc177de08f
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-3.8_3.8.2.bb
@@ -0,0 +1,12 @@
+require gtkhtml.inc
+
+DEPENDS = "gtk+ gail libbonoboui libgnomeprintui libgnomeui"
+
+SRC_URI = "${GNOME_MIRROR}/gtkhtml/3.8/gtkhtml-${PV}.tar.bz2"
+FILES_${PN} += "${datadir}/gtkhtml-3.8"
+
+do_stage() {
+ mv src/libgtkhtml.pc src/libgtkhtml-3.8.pc || true
+ gnome_stage_includes
+ oe_libinstall -C src -so libgtkhtml-3.8 ${STAGING_LIBDIR}
+}
diff --git a/recipes/gtkhtml/gtkhtml-lite-3.0_3.0.10.bb b/recipes/gtkhtml/gtkhtml-lite-3.0_3.0.10.bb
new file mode 100644
index 0000000000..44a96d6d64
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml-lite-3.0_3.0.10.bb
@@ -0,0 +1,18 @@
+require gtkhtml.inc
+
+DEPENDS = "gtk+ gail libgnomeprint orbit2-native"
+PR = "r1"
+
+SRC_URI = "http://stag.mind.be/gtkhtml-lite-3.0.10.tar.bz2"
+FILES_${PN} += "${datadir}/gtkhtml-3.0 ${libdir}/gtkhtml/*.so"
+FILES_${PN}-dev += "${libdir}/gtkhtml"
+
+do_stage() {
+ mv src/libgtkhtml.pc src/libgtkhtml-3.0.pc || true
+ gnome_stage_includes
+ oe_libinstall -C src -so libgtkhtml-3.0 ${STAGING_LIBDIR}
+}
+
+do_compile() {
+ oe_runmake ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2
+}
diff --git a/recipes/gtkhtml/gtkhtml.inc b/recipes/gtkhtml/gtkhtml.inc
new file mode 100644
index 0000000000..091e17d15b
--- /dev/null
+++ b/recipes/gtkhtml/gtkhtml.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "HTML rendering/editing library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+inherit gnome
+
+S = "${WORKDIR}/gtkhtml-${PV}"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I${prefix}/include':'-I.':g
+}