aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icedtea
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch.de>2011-12-09 17:00:27 +0000
committerSteffen Sledz <sledz@dresearch-fe.de>2011-12-20 08:40:25 +0100
commitc3b9e78eefec8b451755d68c0cf6cccd771014c4 (patch)
treeda4c82ddad2d1a67a1c6b1094eb65589c5cee819 /recipes/icedtea
parentd22f4281d63410477b523ad24e646b39dc24079f (diff)
downloadopenembedded-c3b9e78eefec8b451755d68c0cf6cccd771014c4.tar.gz
icedtea6-native: fix problem on build hosts with linux kernel 3.x
see http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7072341 Signed-off-by: Steffen Sledz <sledz@dresearch.de>
Diffstat (limited to 'recipes/icedtea')
-rw-r--r--recipes/icedtea/icedtea6-native.inc9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes/icedtea/icedtea6-native.inc b/recipes/icedtea/icedtea6-native.inc
index 06da7c0d36..91d6075a88 100644
--- a/recipes/icedtea/icedtea6-native.inc
+++ b/recipes/icedtea/icedtea6-native.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools"
HOMEPAGE = "http://icedtea.classpath.org"
LICENSE = "GPL with Classpath Exception"
-INC_PR = "r4"
+INC_PR = "r5"
DEPENDS = "virtual/javac-native classpath-tools-native \
virtual/java-native classpath-native \
@@ -108,6 +108,13 @@ do_configure_append() {
-e"s|g++\$(GCC_SUFFIX)|${CXX}|" \
$F
done
+
+ for F in openjdk/hotspot/make/linux/Makefile openjdk-ecj/hotspot/make/linux/Makefile ;
+ do
+ sed -i \
+ -e"s|SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 2.7%|SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3%|" \
+ $F
+ done
}
EXTRA_OEMAKE = ' \