aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ifupdown/ifupdown-0.6.10
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2010-03-31 15:43:29 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-31 15:47:33 +0200
commit920132b42db5454b553b8f360a0be325849692a7 (patch)
treebb128a69d11f6be556edb3888a06b5c52a392357 /recipes/ifupdown/ifupdown-0.6.10
parentd36c91f6167c180674b49635199fb7e9bbf3fbbf (diff)
downloadopenembedded-920132b42db5454b553b8f360a0be325849692a7.tar.gz
ifupdown: update to 0.6.10 and do not ship /etc/network/interfaces
Init script was renamed to ifup like it is in ifupdown-ubuntu Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/ifupdown/ifupdown-0.6.10')
-rw-r--r--recipes/ifupdown/ifupdown-0.6.10/busybox.patch20
-rw-r--r--recipes/ifupdown/ifupdown-0.6.10/head-tail.patch14
-rw-r--r--recipes/ifupdown/ifupdown-0.6.10/init13
-rw-r--r--recipes/ifupdown/ifupdown-0.6.10/zeroconf.patch21
4 files changed, 68 insertions, 0 deletions
diff --git a/recipes/ifupdown/ifupdown-0.6.10/busybox.patch b/recipes/ifupdown/ifupdown-0.6.10/busybox.patch
new file mode 100644
index 0000000000..5619ab7c0a
--- /dev/null
+++ b/recipes/ifupdown/ifupdown-0.6.10/busybox.patch
@@ -0,0 +1,20 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ifupdown-0.6.4/inet.defn~busybox
++++ ifupdown-0.6.4/inet.defn
+@@ -116,8 +116,8 @@
+ options
+ provider name -- Use /name/ as the provider (from /etc/ppp/peers).
+ up
+- /sbin/start-stop-daemon --start -x /usr/bin/wvdial \
+- -p /var/run/wvdial.%iface% -b -m -- [[ %provider% ]]
++ /sbin/start-stop-daemon -S -x /usr/bin/wvdial \
++ -p /var/run/wvdial.%iface% -- [[ %provider% ]]
+ down
+- /sbin/start-stop-daemon --stop -x /usr/bin/wvdial \
+- -p /var/run/wvdial.%iface% -s 2
++ /sbin/start-stop-daemon -X -x /usr/bin/wvdial \
++ -p /var/run/wvdial.%iface%
diff --git a/recipes/ifupdown/ifupdown-0.6.10/head-tail.patch b/recipes/ifupdown/ifupdown-0.6.10/head-tail.patch
new file mode 100644
index 0000000000..a86a25d2fb
--- /dev/null
+++ b/recipes/ifupdown/ifupdown-0.6.10/head-tail.patch
@@ -0,0 +1,14 @@
+--- ifupdown-0.6.4/Makefile~ 2000-11-18 07:12:01.000000000 +0000
++++ ifupdown-0.6.4/Makefile 2004-04-24 11:06:58.000000000 +0100
+@@ -46,9 +46,9 @@
+ LINE=$$(grep -n '^##ADDRESSFAM##$$' $< | sed 's/:.*//g'); \
+ WC=`wc -l < $<`; \
+ ( \
+- head -$$(($$LINE - 1)) $<; \
++ head -n $$(($$LINE - 1)) $<; \
+ cat $(MAN); \
+- tail -$$(($$WC - $$LINE)) $<; \
++ tail -n $$(($$WC - $$LINE)) $<; \
+ ) > $@
+
+ ifdown.8: ifup.8
diff --git a/recipes/ifupdown/ifupdown-0.6.10/init b/recipes/ifupdown/ifupdown-0.6.10/init
new file mode 100644
index 0000000000..d258d51ff4
--- /dev/null
+++ b/recipes/ifupdown/ifupdown-0.6.10/init
@@ -0,0 +1,13 @@
+#!/bin/sh -e
+
+case "$1" in
+ start|restart)
+ if [ -e /etc/network/ifstate ]; then
+ echo -n "Cleaning: /etc/network/ifstate"
+ echo -n >/etc/network/ifstate
+ echo "."
+ fi
+ ;;
+ stop|reload|force-reload)
+ ;;
+esac
diff --git a/recipes/ifupdown/ifupdown-0.6.10/zeroconf.patch b/recipes/ifupdown/ifupdown-0.6.10/zeroconf.patch
new file mode 100644
index 0000000000..33745db6ff
--- /dev/null
+++ b/recipes/ifupdown/ifupdown-0.6.10/zeroconf.patch
@@ -0,0 +1,21 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ifupdown-0.6.4/inet.defn~zeroconf
++++ ifupdown-0.6.4/inet.defn
+@@ -120,3 +120,13 @@
+ down
+ /sbin/start-stop-daemon -X -x /usr/bin/wvdial \
+ -p /var/run/wvdial.%iface%
++
++method zeroconf
++ description
++ This method uses zeroconf to configure an interface. See the man page
++ for zcip for details.
++ up
++ /sbin/start-stop-daemon -S -x /usr/sbin/zcip -p /var/run/zcip.%iface% \
++ -- -s -i %iface%
++ down
++ /sbin/start-stop-daemon -X -x /usr/sbin/zcip -p /var/run/zcip.%iface%