aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/qt4e-base-image.bb
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-11-02 17:51:59 +0100
committerEric Bénard <eric@eukrea.com>2010-11-03 23:20:16 +0100
commit4cf0f233541f2bef81ad6f2faf69cfe3c715d74f (patch)
tree35147fd3fed4c669d2a6753518aaefc8de464124 /recipes/images/qt4e-base-image.bb
parenta8c1ef6eaba34018a00b5bfe5537bfad78836fab (diff)
downloadopenembedded-4cf0f233541f2bef81ad6f2faf69cfe3c715d74f.tar.gz
qt4e: add 2 images
- qt4e-base-image : contains qt4 embedded libraries and can be used as a base rootfs when developping using the sdk - qt4e-demo-image : contains qt-base-image + qt-demo + a script to launch qt-demo at boot, this image can be used to quickly setup a demonstration of qt capabilities on a machine using qtdemo - qt-demo-init : recipe creating the package which provides the init script to lauch qtdemo. Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/images/qt4e-base-image.bb')
-rw-r--r--recipes/images/qt4e-base-image.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/images/qt4e-base-image.bb b/recipes/images/qt4e-base-image.bb
new file mode 100644
index 0000000000..4aa24dac51
--- /dev/null
+++ b/recipes/images/qt4e-base-image.bb
@@ -0,0 +1,51 @@
+require micro-base-image.bb
+
+TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+RDEPENDS_append += " \
+ qt4-embedded \
+ "
+
+QTE_INSTALL = " \
+ libqt-embedded3support4 \
+ libqt-embeddedclucene4 \
+ libqt-embeddedcore4 \
+ libqt-embeddeddbus4 \
+ libqt-embeddedgui4 \
+ libqt-embeddedhelp4 \
+ libqt-embeddedmultimedia4 \
+ libqt-embeddednetwork4 \
+ libqt-embeddedscript4 \
+ libqt-embeddedscripttools4 \
+ libqt-embeddedsql4 \
+ libqt-embeddedsvg4 \
+ libqt-embeddedtest4 \
+ libqt-embeddedwebkit4 \
+ libqt-embeddedxml4 \
+ libqt-embeddedxmlpatterns4 \
+ qt4-embedded-fonts-ttf-dejavu \
+ qt4-embedded-fonts-ttf-vera \
+ qt4-embedded-plugin-iconengine-svgicon \
+ qt4-embedded-plugin-imageformat-gif \
+ qt4-embedded-plugin-imageformat-ico \
+ qt4-embedded-plugin-imageformat-jpeg \
+ qt4-embedded-plugin-imageformat-mng \
+ qt4-embedded-plugin-imageformat-svg \
+ qt4-embedded-plugin-imageformat-tiff \
+ qt4-embedded-plugin-mousedriver-tslib \
+ qt4-embedded-plugin-phonon-backend-gstreamer \
+ qt4-embedded-plugin-script-dbus \
+ qt4-embedded-plugin-sqldriver-sqlite2 \
+ qt4-embedded-plugin-sqldriver-sqlite \
+"
+
+IMAGE_INSTALL += "\
+ initscripts \
+ kernel-modules \
+ gdbserver \
+ strace \
+ module-init-tools \
+ ${QTE_INSTALL} \
+ ${TOUCH} \
+ qwt-e \
+"