aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jamvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2010-07-13 15:46:41 +0200
committerRobert Schuster <robertschuster@fsfe.org>2010-07-14 07:59:41 +0200
commit1bd457c58207fe853ab05c6dc118f32b99996b62 (patch)
tree34991c1e63c47ecc0ce3d30ab18aa2a5ec516d31 /recipes/jamvm
parent5dfb4130a58f9b2a8b551bbfb98ee15fc7c11c86 (diff)
downloadopenembedded-1bd457c58207fe853ab05c6dc118f32b99996b62.tar.gz
jamvm-initial 1.4.5: Face random crashes with a silent retry.
jamvm-initial 1.5.0: Dito.
Diffstat (limited to 'recipes/jamvm')
-rw-r--r--recipes/jamvm/files/jamvm_1.4.5-initial.patch15
-rw-r--r--recipes/jamvm/files/jamvm_1.5.0-initial.patch15
-rw-r--r--recipes/jamvm/jamvm-initial_1.4.5.bb2
-rw-r--r--recipes/jamvm/jamvm-initial_1.5.0.bb2
4 files changed, 26 insertions, 8 deletions
diff --git a/recipes/jamvm/files/jamvm_1.4.5-initial.patch b/recipes/jamvm/files/jamvm_1.4.5-initial.patch
index 3c68818955..f841271221 100644
--- a/recipes/jamvm/files/jamvm_1.4.5-initial.patch
+++ b/recipes/jamvm/files/jamvm_1.4.5-initial.patch
@@ -14,12 +14,21 @@ Index: jamvm-1.4.5/java-initial
===================================================================
--- /dev/null
+++ jamvm-1.4.5/java-initial
-@@ -0,0 +1,5 @@
+@@ -0,0 +1,14 @@
+#!/bin/sh
+#
-+# Wrapper script inspired by the one provided by cacao.
++# Wrapper which (almost) silently restarts the VM in case of segfaults.
+
-+exec jamvm-initial ${1+"$@"}
++redo_from_start=1;
++while [ $redo_from_start -eq 1 ]; do
++ echo "Running JamVM: ${@}"
++ redo_from_start=0;
++ jamvm ${1+"$@"}
++ if [ $? -eq 139 ]; then
++ echo "JamVM crashed - silently trying again"
++ redo_from_start=1;
++ fi
++done
Index: jamvm-1.4.5/lib/Makefile.am
===================================================================
--- jamvm-1.4.5.orig/lib/Makefile.am
diff --git a/recipes/jamvm/files/jamvm_1.5.0-initial.patch b/recipes/jamvm/files/jamvm_1.5.0-initial.patch
index 9b972da014..3d5a4ae93b 100644
--- a/recipes/jamvm/files/jamvm_1.5.0-initial.patch
+++ b/recipes/jamvm/files/jamvm_1.5.0-initial.patch
@@ -15,12 +15,21 @@ Index: jamvm-1.5.0/java-initial
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ jamvm-1.5.0/java-initial 2007-12-20 00:03:27.000000000 +0100
-@@ -0,0 +1,5 @@
+@@ -0,0 +1,14 @@
+#!/bin/sh
+#
-+# Wrapper script inspired by the one provided by cacao.
++# Wrapper which (almost) silently restarts the VM in case of segfaults.
+
-+exec jamvm-initial ${1+"$@"}
++redo_from_start=1;
++while [ $redo_from_start -eq 1 ]; do
++ echo "Running JamVM: ${@}"
++ redo_from_start=0;
++ jamvm ${1+"$@"}
++ if [ $? -eq 139 ]; then
++ echo "JamVM crashed - silently trying again"
++ redo_from_start=1;
++ fi
++done
Index: jamvm-1.5.0/lib/Makefile.am
===================================================================
--- jamvm-1.5.0.orig/lib/Makefile.am 2007-12-20 00:05:24.000000000 +0100
diff --git a/recipes/jamvm/jamvm-initial_1.4.5.bb b/recipes/jamvm/jamvm-initial_1.4.5.bb
index e3ace6dbdb..301e806169 100644
--- a/recipes/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes/jamvm/jamvm-initial_1.4.5.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
DEPENDS = "zlib-native classpath-initial jikes-initial libffi-native"
-PR = "r1"
+PR = "r2"
PROVIDES = "virtual/java-initial"
diff --git a/recipes/jamvm/jamvm-initial_1.5.0.bb b/recipes/jamvm/jamvm-initial_1.5.0.bb
index 3986861a1a..2a1fef6af0 100644
--- a/recipes/jamvm/jamvm-initial_1.5.0.bb
+++ b/recipes/jamvm/jamvm-initial_1.5.0.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
DEPENDS = "zlib-native classpath-initial jikes-initial libffi-native"
-PR = "r1"
+PR = "r2"
PROVIDES = "virtual/java-initial"