aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jamvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2010-06-18 14:52:23 +0200
committerRobert Schuster <robertschuster@fsfe.org>2010-06-24 11:46:04 +0200
commit64e7aaced537cc22311bba72542cb1c128cd4536 (patch)
tree7357863eba7dd84cc7ea59b9762e368a7cb50c4a /recipes/jamvm
parent4b7eaa7b901a0f08acdd4b6ca189ddd4cc2f071d (diff)
downloadopenembedded-64e7aaced537cc22311bba72542cb1c128cd4536.tar.gz
jamvm.inc: Make libjvm.so a private lib.
Diffstat (limited to 'recipes/jamvm')
-rw-r--r--recipes/jamvm/jamvm.inc2
-rw-r--r--recipes/jamvm/jamvm_1.4.5.bb2
-rw-r--r--recipes/jamvm/jamvm_1.5.0.bb2
-rw-r--r--recipes/jamvm/jamvm_1.5.2.bb2
-rw-r--r--recipes/jamvm/jamvm_1.5.3.bb2
5 files changed, 6 insertions, 4 deletions
diff --git a/recipes/jamvm/jamvm.inc b/recipes/jamvm/jamvm.inc
index 327caf9a68..1181d16cbf 100644
--- a/recipes/jamvm/jamvm.inc
+++ b/recipes/jamvm/jamvm.inc
@@ -12,6 +12,8 @@ RPROVIDES_jamvm = "java2-runtime"
# This uses 32 bit arm, so force the instruction set to arm, not thumb
ARM_INSTRUCTION_SET = "arm"
+PRIVATE_LIBS = "libjvm.so"
+
inherit java autotools update-alternatives
EXTRA_OECONF = "--with-classpath-install-dir=${prefix} --libdir=${libdir}/jamvm"
diff --git a/recipes/jamvm/jamvm_1.4.5.bb b/recipes/jamvm/jamvm_1.4.5.bb
index fc2c92c2c4..2f61fdc5a3 100644
--- a/recipes/jamvm/jamvm_1.4.5.bb
+++ b/recipes/jamvm/jamvm_1.4.5.bb
@@ -1,6 +1,6 @@
require jamvm.inc
-PR = "r4"
+PR = "r5"
SRC_URI += "file://jamvm-1.3.1-size-defaults.patch"
diff --git a/recipes/jamvm/jamvm_1.5.0.bb b/recipes/jamvm/jamvm_1.5.0.bb
index 32f78c7065..dbb27bd66a 100644
--- a/recipes/jamvm/jamvm_1.5.0.bb
+++ b/recipes/jamvm/jamvm_1.5.0.bb
@@ -2,7 +2,7 @@ require jamvm.inc
SRC_URI += "file://debian-jni.patch;striplevel=0"
-PR = "r5"
+PR = "r6"
do_configure_prepend() {
# Replaces the placeholder OE_LIBDIR_JNI with the JNI library directory
diff --git a/recipes/jamvm/jamvm_1.5.2.bb b/recipes/jamvm/jamvm_1.5.2.bb
index 7cfeca78d3..2fd5f959c8 100644
--- a/recipes/jamvm/jamvm_1.5.2.bb
+++ b/recipes/jamvm/jamvm_1.5.2.bb
@@ -2,7 +2,7 @@ require jamvm.inc
SRC_URI += "file://debian-jni.patch;striplevel=0"
-PR = "r1"
+PR = "r2"
do_configure_prepend() {
# Replaces the placeholder OE_LIBDIR_JNI with the JNI library directory
diff --git a/recipes/jamvm/jamvm_1.5.3.bb b/recipes/jamvm/jamvm_1.5.3.bb
index 22ca036346..a496d42505 100644
--- a/recipes/jamvm/jamvm_1.5.3.bb
+++ b/recipes/jamvm/jamvm_1.5.3.bb
@@ -2,7 +2,7 @@ require jamvm.inc
SRC_URI += "file://debian-jni.patch;striplevel=0"
-PR = "r1"
+PR = "r2"
do_configure_prepend() {
# Replaces the placeholder OE_LIBDIR_JNI with the JNI library directory