aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/librcf
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-15 20:06:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-21 20:28:50 -0700
commitcaa6067f7faf33200681c75843ce2e059cb1c0b4 (patch)
tree334e6f6ab9b6dea945d192cb73afda3b30dd218f /recipes/librcf
parente84f4995e257e0505fb73432cbd2a9f53cdf074b (diff)
downloadopenembedded-caa6067f7faf33200681c75843ce2e059cb1c0b4.tar.gz
Various fixes for cp argument portability
Diffstat (limited to 'recipes/librcf')
-rw-r--r--recipes/librcf/librcf_0.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/librcf/librcf_0.4.bb b/recipes/librcf/librcf_0.4.bb
index ce174bf07a..13b2353d95 100644
--- a/recipes/librcf/librcf_0.4.bb
+++ b/recipes/librcf/librcf_0.4.bb
@@ -31,8 +31,8 @@ do_install() {
do_stage() {
cd ${S}
install -d -m 775 ${STAGING_LIBDIR}
- cp -dp src/RCF/libRCF[sm]t.a ${STAGING_LIBDIR}
- cp -dp src/RCF/libRCF[sm]t.so* ${STAGING_LIBDIR}
+ cp -PpR src/RCF/libRCF[sm]t.a ${STAGING_LIBDIR}
+ cp -PpR src/RCF/libRCF[sm]t.so* ${STAGING_LIBDIR}
install -d -m 775 ${STAGING_INCDIR}
tar -C include --exclude='*.diff' -cvf - . | tar -C ${STAGING_INCDIR} -xvf -
}