aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtool
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-15 16:37:52 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-15 16:37:52 -0700
commit3740dea7ec2f0e9469248bb8c117551a8261d2d8 (patch)
treed56abeeff0af8a20ded1b77ca228f3596b0af16d /recipes/libtool
parentb10441991fe94b832ade5ffd3f38fa197a97a076 (diff)
downloadopenembedded-3740dea7ec2f0e9469248bb8c117551a8261d2d8.tar.gz
libtool-2.4: Append lt_sysroot to libdir
Remove cross.patch which is not needed now. Fix PR setting. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libtool')
-rw-r--r--recipes/libtool/libtool-2.4/cross.patch34
-rw-r--r--recipes/libtool/libtool-2.4/resolve-sysroot.patch23
-rw-r--r--recipes/libtool/libtool-2.4/use-sysroot-in-libpath.patch19
-rw-r--r--recipes/libtool/libtool-cross_2.4.bb2
-rw-r--r--recipes/libtool/libtool-native_2.4.bb2
-rw-r--r--recipes/libtool/libtool-nativesdk_2.4.bb2
-rw-r--r--recipes/libtool/libtool-sdk_2.4.bb2
-rw-r--r--recipes/libtool/libtool.inc3
-rw-r--r--recipes/libtool/libtool_2.4.bb2
9 files changed, 48 insertions, 41 deletions
diff --git a/recipes/libtool/libtool-2.4/cross.patch b/recipes/libtool/libtool-2.4/cross.patch
deleted file mode 100644
index fb25e38140..0000000000
--- a/recipes/libtool/libtool-2.4/cross.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: libtool-2.4/libltdl/config/ltmain.m4sh
-===================================================================
---- libtool-2.4.orig/libltdl/config/ltmain.m4sh
-+++ libtool-2.4/libltdl/config/ltmain.m4sh
-@@ -6121,8 +6121,6 @@ func_mode_link ()
- add="$libdir/$linklib"
- fi
- else
-- # We cannot seem to hardcode it, guess we'll fake it.
-- add_dir="-L$libdir"
- # Try looking first in the location we're being installed to.
- if test -n "$inst_prefix_dir"; then
- case $libdir in
-@@ -6277,8 +6275,18 @@ func_mode_link ()
- fi
- ;;
- *)
-- path="-L$absdir/$objdir"
-- ;;
-+ # OE sets installed=no in staging. We need to look in $objdir and $absdir,
-+ # preferring $objdir. RP 31/04/2008
-+ if test -f "$absdir/$objdir/$depdepl" ; then
-+ depdepl="$absdir/$objdir/$depdepl"
-+ path="-L$absdir/$objdir"
-+ elif test -f "$absdir/$depdepl" ; then
-+ depdepl="$absdir/$depdepl"
-+ path="-L$absdir"
-+ else
-+ path="-L$absdir/$objdir"
-+ fi
-+ ;;
- esac
- else
- eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
diff --git a/recipes/libtool/libtool-2.4/resolve-sysroot.patch b/recipes/libtool/libtool-2.4/resolve-sysroot.patch
index 57689a5887..62ad72bed3 100644
--- a/recipes/libtool/libtool-2.4/resolve-sysroot.patch
+++ b/recipes/libtool/libtool-2.4/resolve-sysroot.patch
@@ -6,7 +6,7 @@ Index: libtool-2.4/libltdl/config/ltmain.m4sh
===================================================================
--- libtool-2.4.orig/libltdl/config/ltmain.m4sh
+++ libtool-2.4/libltdl/config/ltmain.m4sh
-@@ -8480,7 +8480,8 @@ EOF
+@@ -8479,7 +8479,8 @@ EOF
*.la)
func_basename "$deplib"
name="$func_basename_result"
@@ -16,3 +16,24 @@ Index: libtool-2.4/libltdl/config/ltmain.m4sh
test -z "$libdir" && \
func_fatal_error "\`$deplib' is not a valid libtool archive"
func_append newdependency_libs " ${lt_sysroot:+=}$libdir/$name"
+@@ -8505,7 +8506,9 @@ EOF
+ *.la)
+ func_basename "$lib"
+ name="$func_basename_result"
+- eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $lib`
++ func_resolve_sysroot "$lib"
++ eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $func_resolve_sysroot_result`
++
+ test -z "$libdir" && \
+ func_fatal_error "\`$lib' is not a valid libtool archive"
+ func_append newdlfiles " ${lt_sysroot:+=}$libdir/$name"
+@@ -8524,7 +8527,8 @@ EOF
+ # the library:
+ func_basename "$lib"
+ name="$func_basename_result"
+- eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $lib`
++ func_resolve_sysroot "$lib"
++ eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $func_resolve_sysroot_result`
+ test -z "$libdir" && \
+ func_fatal_error "\`$lib' is not a valid libtool archive"
+ func_append newdlprefiles " ${lt_sysroot:+=}$libdir/$name"
diff --git a/recipes/libtool/libtool-2.4/use-sysroot-in-libpath.patch b/recipes/libtool/libtool-2.4/use-sysroot-in-libpath.patch
new file mode 100644
index 0000000000..017ab0889c
--- /dev/null
+++ b/recipes/libtool/libtool-2.4/use-sysroot-in-libpath.patch
@@ -0,0 +1,19 @@
+When using sysroot we should append it to libdir which is helpful in cross builds
+as the system is staged in the sysroot. For normal build i.e. when lt_sysroot is not
+set it will still behave same and add -L/usr/lib to relink command
+
+-Khem
+
+Index: libtool-2.4/libltdl/config/ltmain.m4sh
+===================================================================
+--- libtool-2.4.orig/libltdl/config/ltmain.m4sh
++++ libtool-2.4/libltdl/config/ltmain.m4sh
+@@ -6122,7 +6122,7 @@ func_mode_link ()
+ fi
+ else
+ # We cannot seem to hardcode it, guess we'll fake it.
+- add_dir="-L$libdir"
++ add_dir="-L$lt_sysroot$libdir"
+ # Try looking first in the location we're being installed to.
+ if test -n "$inst_prefix_dir"; then
+ case $libdir in
diff --git a/recipes/libtool/libtool-cross_2.4.bb b/recipes/libtool/libtool-cross_2.4.bb
index cc477baf1c..709e18e70b 100644
--- a/recipes/libtool/libtool-cross_2.4.bb
+++ b/recipes/libtool/libtool-cross_2.4.bb
@@ -1,9 +1,9 @@
require libtool.inc
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
SRC_URI_append = " file://prefix.patch \
- file://cross.patch \
"
SRC_URI[md5sum] = "b32b04148ecdd7344abc6fe8bd1bb021"
SRC_URI[sha256sum] = "13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e"
diff --git a/recipes/libtool/libtool-native_2.4.bb b/recipes/libtool/libtool-native_2.4.bb
index e40680ca38..0fd2ec8854 100644
--- a/recipes/libtool/libtool-native_2.4.bb
+++ b/recipes/libtool/libtool-native_2.4.bb
@@ -1,11 +1,11 @@
require libtool.inc
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
DEPENDS = ""
SRC_URI_append = " file://prefix.patch \
- file://cross.patch \
"
SRC_URI[md5sum] = "b32b04148ecdd7344abc6fe8bd1bb021"
SRC_URI[sha256sum] = "13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e"
diff --git a/recipes/libtool/libtool-nativesdk_2.4.bb b/recipes/libtool/libtool-nativesdk_2.4.bb
index 9aaf68a120..961e48a9c6 100644
--- a/recipes/libtool/libtool-nativesdk_2.4.bb
+++ b/recipes/libtool/libtool-nativesdk_2.4.bb
@@ -1,8 +1,8 @@
require libtool.inc
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
SRC_URI_append = " file://prefix.patch \
- file://cross.patch \
"
SRC_URI[md5sum] = "b32b04148ecdd7344abc6fe8bd1bb021"
SRC_URI[sha256sum] = "13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e"
diff --git a/recipes/libtool/libtool-sdk_2.4.bb b/recipes/libtool/libtool-sdk_2.4.bb
index cf8ba3aaf8..674eb73e99 100644
--- a/recipes/libtool/libtool-sdk_2.4.bb
+++ b/recipes/libtool/libtool-sdk_2.4.bb
@@ -1,8 +1,8 @@
require libtool.inc
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
SRC_URI_append = " file://prefix.patch \
- file://cross.patch \
"
SRC_URI[md5sum] = "b32b04148ecdd7344abc6fe8bd1bb021"
SRC_URI[sha256sum] = "13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e"
diff --git a/recipes/libtool/libtool.inc b/recipes/libtool/libtool.inc
index 6c194ddeca..97fdb30da5 100644
--- a/recipes/libtool/libtool.inc
+++ b/recipes/libtool/libtool.inc
@@ -16,8 +16,9 @@ FILESPATHPKG=. "libtool-${PV}:"
SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
file://trailingslash.patch \
- file://prefix-manpage-fix.patch \
+ file://prefix-manpage-fix.patch \
file://resolve-sysroot.patch \
+ file://use-sysroot-in-libpath.patch \
"
do_configure_prepend () {
if ${@['true', 'false'][bb.data.inherits_class('native', d) or bb.data.inherits_class('sdk', d) or (bb.data.getVar('PN', d, 1) == 'libtool-cross')]}
diff --git a/recipes/libtool/libtool_2.4.bb b/recipes/libtool/libtool_2.4.bb
index c7c56fda47..b122f91993 100644
--- a/recipes/libtool/libtool_2.4.bb
+++ b/recipes/libtool/libtool_2.4.bb
@@ -3,7 +3,7 @@ require libtool.inc
DEFAULT_PREFERENCE = "-1"
DEPENDS = "libtool-native"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI[md5sum] = "b32b04148ecdd7344abc6fe8bd1bb021"
SRC_URI[sha256sum] = "13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e"