aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-uml/linux-uml_2.4.26.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux-uml/linux-uml_2.4.26.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux-uml/linux-uml_2.4.26.bb')
-rw-r--r--recipes/linux-uml/linux-uml_2.4.26.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/linux-uml/linux-uml_2.4.26.bb b/recipes/linux-uml/linux-uml_2.4.26.bb
new file mode 100644
index 0000000000..11b2a2261c
--- /dev/null
+++ b/recipes/linux-uml/linux-uml_2.4.26.bb
@@ -0,0 +1,44 @@
+SECTION = "kernel"
+DESCRIPTION = "User Mode Linux Kernel"
+LICENSE = "GPL"
+UMLR = "2"
+PR = "1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
+ ${SOURCEFORGE_MIRROR}/user-mode-linux/uml-patch-${PV}-${UMLR}.bz2;patch=1 \
+ file://defconfig \
+ file://aio_abi.h"
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+COMPATIBLE_HOST = 'i.86.*-linux'
+COMPATIBLE_MACHINE = "x86-uml"
+
+export OS = "Linux"
+ARCH = "um"
+SUBARCH = "${TARGET_ARCH}"
+KERNEL_IMAGETYPE = "linux"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig .config
+ oe_runmake oldconfig
+ install -d arch/um/include/linux/
+ #install -m 0644 ${WORKDIR}/aio_abi.h arch/um/include/linux/
+}
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake dep
+ oe_runmake HAVE_AIO_ABI= HAVE_AIO_LIBC= STAGING_LIBDIR=${STAGING_LIBDIR} ${KERNEL_IMAGETYPE}
+ oe_runmake modules
+}
+
+do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake DEPMOD=echo INSTALL_MOD_PATH="${D}" modules_install
+ install -d ${D}/boot
+ install -m 0755 linux ${D}/boot/linux-${PV}
+ install -m 0644 System.map ${D}/boot/System.map-${PV}
+ install -m 0644 .config ${D}/boot/config-${PV}
+}