aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-15 18:25:23 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-17 08:22:41 -0700
commit474d7b392a0e68011cddf53bf255345f72c83f7f (patch)
tree2e63ffe853cdeb1bb9b7ccfb6d69e9960fbe3eb4 /recipes/linux
parent3109a7ee392b2d09cb9542ea7307ff09526b325b (diff)
downloadopenembedded-474d7b392a0e68011cddf53bf255345f72c83f7f.tar.gz
linux: Add CONFIG_MODULES to qemu{ppc,sh4,mips64}
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-2.6.33/qemuppc/defconfig7
-rw-r--r--recipes/linux/linux-2.6.33/qemush4/defconfig7
-rw-r--r--recipes/linux/linux-2.6.34/qemuppc/defconfig7
-rw-r--r--recipes/linux/linux-2.6.34/qemush4/defconfig7
-rw-r--r--recipes/linux/linux-2.6.35/qemumips64/defconfig7
-rw-r--r--recipes/linux/linux-2.6.35/qemuppc/defconfig7
-rw-r--r--recipes/linux/linux-2.6.37/qemuppc/defconfig6
-rw-r--r--recipes/linux/linux_2.6.33.bb2
-rw-r--r--recipes/linux/linux_2.6.34.bb2
-rw-r--r--recipes/linux/linux_2.6.35.bb2
-rw-r--r--recipes/linux/linux_2.6.37.bb2
11 files changed, 47 insertions, 9 deletions
diff --git a/recipes/linux/linux-2.6.33/qemuppc/defconfig b/recipes/linux/linux-2.6.33/qemuppc/defconfig
index 68e2ceeaef..a8ea480397 100644
--- a/recipes/linux/linux-2.6.33/qemuppc/defconfig
+++ b/recipes/linux/linux-2.6.33/qemuppc/defconfig
@@ -161,7 +161,12 @@ CONFIG_HAVE_DMA_API_DEBUG=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
-# CONFIG_MODULES is not set
+CONFIG_MODULES=y
+# CONFIG_MODULE_FORCE_LOAD is not set
+CONFIG_MODULE_UNLOAD=y
+# CONFIG_MODULE_FORCE_UNLOAD is not set
+CONFIG_MODVERSIONS=y
+# CONFIG_MODULE_SRCVERSION_ALL is not set
CONFIG_BLOCK=y
CONFIG_LBDAF=y
# CONFIG_BLK_DEV_BSG is not set
diff --git a/recipes/linux/linux-2.6.33/qemush4/defconfig b/recipes/linux/linux-2.6.33/qemush4/defconfig
index 2cc3e9bf2c..3934b893c8 100644
--- a/recipes/linux/linux-2.6.33/qemush4/defconfig
+++ b/recipes/linux/linux-2.6.33/qemush4/defconfig
@@ -134,7 +134,12 @@ CONFIG_HAVE_GENERIC_DMA_COHERENT=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
-# CONFIG_MODULES is not set
+CONFIG_MODULES=y
+# CONFIG_MODULE_FORCE_LOAD is not set
+CONFIG_MODULE_UNLOAD=y
+# CONFIG_MODULE_FORCE_UNLOAD is not set
+CONFIG_MODVERSIONS=y
+# CONFIG_MODULE_SRCVERSION_ALL is not set
CONFIG_BLOCK=y
# CONFIG_LBDAF is not set
# CONFIG_BLK_DEV_BSG is not set
diff --git a/recipes/linux/linux-2.6.34/qemuppc/defconfig b/recipes/linux/linux-2.6.34/qemuppc/defconfig
index 68e2ceeaef..a8ea480397 100644
--- a/recipes/linux/linux-2.6.34/qemuppc/defconfig
+++ b/recipes/linux/linux-2.6.34/qemuppc/defconfig
@@ -161,7 +161,12 @@ CONFIG_HAVE_DMA_API_DEBUG=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
-# CONFIG_MODULES is not set
+CONFIG_MODULES=y
+# CONFIG_MODULE_FORCE_LOAD is not set
+CONFIG_MODULE_UNLOAD=y
+# CONFIG_MODULE_FORCE_UNLOAD is not set
+CONFIG_MODVERSIONS=y
+# CONFIG_MODULE_SRCVERSION_ALL is not set
CONFIG_BLOCK=y
CONFIG_LBDAF=y
# CONFIG_BLK_DEV_BSG is not set
diff --git a/recipes/linux/linux-2.6.34/qemush4/defconfig b/recipes/linux/linux-2.6.34/qemush4/defconfig
index 2cc3e9bf2c..3934b893c8 100644
--- a/recipes/linux/linux-2.6.34/qemush4/defconfig
+++ b/recipes/linux/linux-2.6.34/qemush4/defconfig
@@ -134,7 +134,12 @@ CONFIG_HAVE_GENERIC_DMA_COHERENT=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
-# CONFIG_MODULES is not set
+CONFIG_MODULES=y
+# CONFIG_MODULE_FORCE_LOAD is not set
+CONFIG_MODULE_UNLOAD=y
+# CONFIG_MODULE_FORCE_UNLOAD is not set
+CONFIG_MODVERSIONS=y
+# CONFIG_MODULE_SRCVERSION_ALL is not set
CONFIG_BLOCK=y
# CONFIG_LBDAF is not set
# CONFIG_BLK_DEV_BSG is not set
diff --git a/recipes/linux/linux-2.6.35/qemumips64/defconfig b/recipes/linux/linux-2.6.35/qemumips64/defconfig
index a6342d0f6f..1fa57541ea 100644
--- a/recipes/linux/linux-2.6.35/qemumips64/defconfig
+++ b/recipes/linux/linux-2.6.35/qemumips64/defconfig
@@ -288,7 +288,12 @@ CONFIG_HAVE_GENERIC_DMA_COHERENT=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
-# CONFIG_MODULES is not set
+CONFIG_MODULES=y
+# CONFIG_MODULE_FORCE_LOAD is not set
+CONFIG_MODULE_UNLOAD=y
+# CONFIG_MODULE_FORCE_UNLOAD is not set
+CONFIG_MODVERSIONS=y
+# CONFIG_MODULE_SRCVERSION_ALL is not set
CONFIG_BLOCK=y
# CONFIG_BLK_DEV_BSG is not set
# CONFIG_BLK_DEV_INTEGRITY is not set
diff --git a/recipes/linux/linux-2.6.35/qemuppc/defconfig b/recipes/linux/linux-2.6.35/qemuppc/defconfig
index 4aa2892637..a879a830f4 100644
--- a/recipes/linux/linux-2.6.35/qemuppc/defconfig
+++ b/recipes/linux/linux-2.6.35/qemuppc/defconfig
@@ -162,7 +162,12 @@ CONFIG_HAVE_DMA_API_DEBUG=y
CONFIG_SLABINFO=y
CONFIG_RT_MUTEXES=y
CONFIG_BASE_SMALL=0
-# CONFIG_MODULES is not set
+CONFIG_MODULES=y
+# CONFIG_MODULE_FORCE_LOAD is not set
+CONFIG_MODULE_UNLOAD=y
+# CONFIG_MODULE_FORCE_UNLOAD is not set
+CONFIG_MODVERSIONS=y
+# CONFIG_MODULE_SRCVERSION_ALL is not set
CONFIG_BLOCK=y
CONFIG_LBDAF=y
# CONFIG_BLK_DEV_BSG is not set
diff --git a/recipes/linux/linux-2.6.37/qemuppc/defconfig b/recipes/linux/linux-2.6.37/qemuppc/defconfig
index d502c716a3..0ecf3cabb9 100644
--- a/recipes/linux/linux-2.6.37/qemuppc/defconfig
+++ b/recipes/linux/linux-2.6.37/qemuppc/defconfig
@@ -89,3 +89,9 @@ CONFIG_NFS_FS=y
CONFIG_IP_PNP=y
CONFIG_AUTOFS4_FS=y
CONFIG_ROOT_NFS=y
+CONFIG_MODULES=y
+# CONFIG_MODULE_FORCE_LOAD is not set
+CONFIG_MODULE_UNLOAD=y
+# CONFIG_MODULE_FORCE_UNLOAD is not set
+CONFIG_MODVERSIONS=y
+# CONFIG_MODULE_SRCVERSION_ALL is not set
diff --git a/recipes/linux/linux_2.6.33.bb b/recipes/linux/linux_2.6.33.bb
index 65d86b3247..3cff6c30e8 100644
--- a/recipes/linux/linux_2.6.33.bb
+++ b/recipes/linux/linux_2.6.33.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR="r1"
+PR="r2"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/linux/linux_2.6.34.bb b/recipes/linux/linux_2.6.34.bb
index daaeb88d78..bd7259d68e 100644
--- a/recipes/linux/linux_2.6.34.bb
+++ b/recipes/linux/linux_2.6.34.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r6"
+PR = "r7"
module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
diff --git a/recipes/linux/linux_2.6.35.bb b/recipes/linux/linux_2.6.35.bb
index 2653e989ef..98edfaa35d 100644
--- a/recipes/linux/linux_2.6.35.bb
+++ b/recipes/linux/linux_2.6.35.bb
@@ -1,7 +1,7 @@
require linux.inc
STABLEV = "8"
-PR = "r3"
+PR = "r4"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/linux/linux_2.6.37.bb b/recipes/linux/linux_2.6.37.bb
index 26edb2bba3..0114c2dbcd 100644
--- a/recipes/linux/linux_2.6.37.bb
+++ b/recipes/linux/linux_2.6.37.bb
@@ -1,5 +1,7 @@
require linux.inc
+PR = "r1"
+
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_sheevaplug = "1"