aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/logrotate/logrotate_3.7.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/logrotate/logrotate_3.7.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/logrotate/logrotate_3.7.1.bb')
-rw-r--r--recipes/logrotate/logrotate_3.7.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/logrotate/logrotate_3.7.1.bb b/recipes/logrotate/logrotate_3.7.1.bb
new file mode 100644
index 0000000000..0a1647e81d
--- /dev/null
+++ b/recipes/logrotate/logrotate_3.7.1.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Rotates, compresses, removes and mails system log files"
+HOMEPAGE = "http://packages.debian.org/unstable/admin/logrotate"
+RCONFLICTS = "logrotate-script"
+DEPENDS = "popt"
+RDEPENDS = "cron"
+SECTION = "admin"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://ftp.debian.org/debian/pool/main/l/logrotate/logrotate_${PV}.orig.tar.gz \
+ file://logrotate-3.7.1.patch;patch=1 \
+ file://logrotate.conf"
+
+CFLAGS_prepend += "-I${STAGING_INCDIR} "
+LDFLAGS_prepend += "-L${STAGING_LIBDIR} "
+EXTRA_OEMAKE = "-p"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install () {
+ # Install the binary and conf file
+ install -D -s -m 0755 ${S}/logrotate ${D}${base_sbindir}/logrotate
+ install -D -m 0644 ${WORKDIR}/logrotate.conf ${D}${sysconfdir}/logrotate.conf
+ install -m 0755 -d ${D}${sysconfdir}/logrotate.d
+}
+
+pkg_postinst () {
+ # Add the logrotate line to /etc/crontab
+ grep -q "${base_sbindir}/logrotate" ${sysconfdir}/crontab || echo "*/5 * * * * ${base_sbindir}/logrotate ${sysconfdir}/logrotate.conf" >> ${sysconfdir}/crontab
+}
+
+pkg_postrm() {
+ # Remove the logrotate line from /etc/crontab
+ grep -v ${base_sbindir}/logrotate ${sysconfdir}/crontab > ${sysconfdir}/crontab.no-${PF}
+ mv ${sysconfdir}/crontab.no-${PF} ${sysconfdir}/crontab
+}
+
+CONFFILES_${PN} += "${sysconfdir}/logrotate.conf"