aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ltrace
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-11 10:35:08 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-11 10:36:44 -0700
commit751ecb1daeaf08a3cb7bd5600731264a0753f4b3 (patch)
tree8540635c2445b2be08e1450fdf3b28197f4d79ea /recipes/ltrace
parent343b75ebf0e5f325b0d99e86b532bfe04f2141b6 (diff)
downloadopenembedded-751ecb1daeaf08a3cb7bd5600731264a0753f4b3.tar.gz
ltrace: Rework sysdeps dependencies
The dependencies here were slightly lazy and in certain cases it was possible to be building objects that required generated headers before they were done. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/ltrace')
-rw-r--r--recipes/ltrace/files/ltrace-fix-sysdep_h-dependency.patch33
-rw-r--r--recipes/ltrace/ltrace_0.5.3.bb3
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes/ltrace/files/ltrace-fix-sysdep_h-dependency.patch b/recipes/ltrace/files/ltrace-fix-sysdep_h-dependency.patch
new file mode 100644
index 0000000000..b9e5f7f3e5
--- /dev/null
+++ b/recipes/ltrace/files/ltrace-fix-sysdep_h-dependency.patch
@@ -0,0 +1,33 @@
+Index: ltrace-0.5.3/sysdeps/linux-gnu/Makefile
+===================================================================
+--- ltrace-0.5.3.orig/sysdeps/linux-gnu/Makefile
++++ ltrace-0.5.3/sysdeps/linux-gnu/Makefile
+@@ -12,7 +12,10 @@ CPPFLAGS += -I$(TOPDIR)/sysdeps/linux-gn
+
+ OBJ = events.o trace.o proc.o breakpoint.o
+
+-all: sysdep.h signalent.h syscallent.h arch_syscallent.h signalent1.h syscallent1.h ../sysdep.o
++HDRS = sysdep.h signalent.h syscallent.h arch_syscallent.h \
++ signalent1.h syscallent1.h
++
++all: ../sysdep.o
+
+ sysdep.h: $(ARCH)/arch.h
+ cat $(ARCH)/arch.h > sysdep.h
+@@ -49,12 +52,14 @@ arch_syscallent.h:
+ os.o: $(OBJ)
+ $(CC) -nostdlib -r -o os.o $(OBJ)
+
++$(OBJ): $(HDRS)
++
+ $(ARCH)/arch.o: dummy
+ $(MAKE) -C $(ARCH)
+
+ clean:
+ $(MAKE) -C $(ARCH) clean
+- rm -f $(OBJ) sysdep.h signalent.h signalent1.h syscallent.h arch_syscallent.h
+- rm -f syscallent1.h os.o sysdep.o ../sysdep.o
++ rm -f $(HDRS)
++ rm -f $(OBJ) os.o sysdep.o ../sysdep.o
+
+ dummy:
diff --git a/recipes/ltrace/ltrace_0.5.3.bb b/recipes/ltrace/ltrace_0.5.3.bb
index 6c13c0896f..53f489245f 100644
--- a/recipes/ltrace/ltrace_0.5.3.bb
+++ b/recipes/ltrace/ltrace_0.5.3.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
DEPENDS = "libelf binutils"
LICENSE = "GPLv2"
-PR = "r2"
+PR = "r3"
# ltrace is not ported to sh3/sh4 targets at this time
COMPATIBLE_TARGET_SYS = (?!sh[34])
@@ -17,6 +17,7 @@ SRC_URI = "\
file://ltrace-mips-remove-CP.patch \
file://ltrace-mips.patch \
file://ltrace-ppc.patch \
+ file://ltrace-fix-sysdep_h-dependency.patch \
"
inherit autotools