aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lua
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-10-25 03:01:13 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-25 15:44:26 -0700
commit48838f0fca6b00767115dd13bce2537f035fd3ba (patch)
treef88bbf4006d2ffd99e785b0973e1b94d41ce902b /recipes/lua
parent6e285e9994ab8f3942ac904e5a7aa268cbd0e187 (diff)
downloadopenembedded-48838f0fca6b00767115dd13bce2537f035fd3ba.tar.gz
lua5.1: install lua5.1.pc properly
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/lua')
-rw-r--r--recipes/lua/lua5.1_5.1.4.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/lua/lua5.1_5.1.4.bb b/recipes/lua/lua5.1_5.1.4.bb
index e3d56fd959..814f83e47e 100644
--- a/recipes/lua/lua5.1_5.1.4.bb
+++ b/recipes/lua/lua5.1_5.1.4.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
HOMEPAGE = "http://www.lua.org/"
DEPENDS += "readline"
-PR = "r8"
+PR = "r9"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
file://bitwise_operators.patch \
file://lua5.1.pc \
@@ -25,7 +25,6 @@ do_configure_prepend() {
}
do_compile () {
- cp ${WORKDIR}/lua5.1.pc ${S}/
oe_runmake linux
}
@@ -37,6 +36,8 @@ do_install () {
'INSTALL_MAN=${D}${mandir}/man1' \
'INSTALL_SHARE=${D}${datadir}/lua' \
install
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/lua5.1.pc ${D}${libdir}/pkgconfig/lua5.1.pc
}
NATIVE_INSTALL_WORKS = 1
BBCLASSEXTEND = "native"