aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lua
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2010-10-15 23:09:20 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-20 18:30:24 -0700
commitfff62b3b96794ecd2a912eff451949321c382798 (patch)
tree12579169eaef20c3e26f2ea6e23fef418a17246c /recipes/lua
parent1e171fd3d7579fd08aa6db26b98eee5938929ba6 (diff)
downloadopenembedded-fff62b3b96794ecd2a912eff451949321c382798.tar.gz
lua5.1: link to libpthread when using uclibc
When the Lua modules are linked with pthreads, loading them crashes Lua. It's some bug in pthread_create() in uclibc. Anyway, linking Lua against pthread fixes this issue. Signed-off-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/lua')
-rw-r--r--recipes/lua/lua5.1/uclibc-pthread.patch13
-rw-r--r--recipes/lua/lua5.1_5.1.4.bb9
2 files changed, 20 insertions, 2 deletions
diff --git a/recipes/lua/lua5.1/uclibc-pthread.patch b/recipes/lua/lua5.1/uclibc-pthread.patch
new file mode 100644
index 0000000000..0555e81b19
--- /dev/null
+++ b/recipes/lua/lua5.1/uclibc-pthread.patch
@@ -0,0 +1,13 @@
+Index: lua-5.1.4/src/Makefile
+===================================================================
+--- lua-5.1.4.orig/src/Makefile 2010-10-16 09:51:52.000000000 +0200
++++ lua-5.1.4/src/Makefile 2010-10-16 09:52:15.000000000 +0200
+@@ -12,7 +12,7 @@
+ AR= ar rcu
+ RANLIB= ranlib
+ RM= rm -f
+-LIBS= -lm $(MYLIBS)
++LIBS= -lm -lpthread $(MYLIBS)
+
+ MYCFLAGS=
+ MYLDFLAGS=
diff --git a/recipes/lua/lua5.1_5.1.4.bb b/recipes/lua/lua5.1_5.1.4.bb
index 75b48f4064..ba2f8b9e50 100644
--- a/recipes/lua/lua5.1_5.1.4.bb
+++ b/recipes/lua/lua5.1_5.1.4.bb
@@ -4,14 +4,19 @@ LICENSE = "MIT"
HOMEPAGE = "http://www.lua.org/"
DEPENDS += "readline"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
file://bitwise_operators.patch \
- file://lua5.1.pc"
+ file://lua5.1.pc \
+ "
S = "${WORKDIR}/lua-${PV}"
inherit pkgconfig binconfig
+UCLIBC_PATCHES += "file://uclibc-pthread.patch"
+SRC_URI_append_linux-uclibc = "${UCLIBC_PATCHES}"
+SRC_URI_append_linux-uclibceabi = "${UCLIBC_PATCHES}"
+
TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLDFLAGS='${LDFLAGS}'"