aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mesa
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-10 21:42:29 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-10 21:42:29 -0800
commitf2253e23c7fbbf2bfa1a0d1b47342800755e71c6 (patch)
treea0185dedd3d5d1dcff0d908b5dfe04ddf80363cf /recipes/mesa
parente0728e428367d5534d6a56e452487529c5ec4918 (diff)
downloadopenembedded-f2253e23c7fbbf2bfa1a0d1b47342800755e71c6.tar.gz
mesa-7.9.1: Fix build on uclibc
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/mesa')
-rw-r--r--recipes/mesa/mesa-7.9.1/uclibc.patch21
-rw-r--r--recipes/mesa/mesa-dri_7.9.1.bb2
-rw-r--r--recipes/mesa/mesa_7.9.1.bb2
3 files changed, 19 insertions, 6 deletions
diff --git a/recipes/mesa/mesa-7.9.1/uclibc.patch b/recipes/mesa/mesa-7.9.1/uclibc.patch
index 11cfe2dd43..0508112df9 100644
--- a/recipes/mesa/mesa-7.9.1/uclibc.patch
+++ b/recipes/mesa/mesa-7.9.1/uclibc.patch
@@ -1,8 +1,8 @@
-Index: Mesa-7.9/src/mesa/main/imports.c
+Index: Mesa-7.9.1/src/mesa/main/imports.c
===================================================================
---- Mesa-7.9.orig/src/mesa/main/imports.c
-+++ Mesa-7.9/src/mesa/main/imports.c
-@@ -756,7 +756,7 @@ _mesa_strdup( const char *s )
+--- Mesa-7.9.1.orig/src/mesa/main/imports.c 2010-12-15 13:50:00.000000000 -0800
++++ Mesa-7.9.1/src/mesa/main/imports.c 2011-01-10 12:23:48.848656001 -0800
+@@ -757,7 +757,7 @@
float
_mesa_strtof( const char *s, char **end )
{
@@ -11,3 +11,16 @@ Index: Mesa-7.9/src/mesa/main/imports.c
static locale_t loc = NULL;
if (!loc) {
loc = newlocale(LC_CTYPE_MASK, "C", NULL);
+Index: Mesa-7.9.1/src/glsl/strtod.c
+===================================================================
+--- Mesa-7.9.1.orig/src/glsl/strtod.c 2011-01-10 20:08:01.568656001 -0800
++++ Mesa-7.9.1/src/glsl/strtod.c 2011-01-10 20:08:39.898656001 -0800
+@@ -44,7 +44,7 @@
+ double
+ glsl_strtod(const char *s, char **end)
+ {
+-#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__)
++#if defined(_GNU_SOURCE) && !defined(__CYGWIN__) && !defined(__FreeBSD__) && !defined(__UCLIBC__)
+ static locale_t loc = NULL;
+ if (!loc) {
+ loc = newlocale(LC_CTYPE_MASK, "C", NULL);
diff --git a/recipes/mesa/mesa-dri_7.9.1.bb b/recipes/mesa/mesa-dri_7.9.1.bb
index 26b56e426c..bd62c98ce4 100644
--- a/recipes/mesa/mesa-dri_7.9.1.bb
+++ b/recipes/mesa/mesa-dri_7.9.1.bb
@@ -1,4 +1,4 @@
require mesa-common.inc
require mesa-${PV}.inc
require mesa-dri.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
diff --git a/recipes/mesa/mesa_7.9.1.bb b/recipes/mesa/mesa_7.9.1.bb
index 4cb8db7f73..f5c9a174fa 100644
--- a/recipes/mesa/mesa_7.9.1.bb
+++ b/recipes/mesa/mesa_7.9.1.bb
@@ -1,6 +1,6 @@
# This is a dummy package so OE can use the poky mesa files
require mesa-dri_${PV}.bb
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
EXTRA_OECONF += "--disable-egl"