aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mktemp
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-11-21 16:30:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-11-21 16:33:30 -0700
commit44289f3b9f14db9fcc860c7625e3503deec34821 (patch)
tree717296f24b4945e99874a362311d7fcaca70db15 /recipes/mktemp
parent46c8038ae2bd265026e72c0e41f5b1e62dba7e2b (diff)
downloadopenembedded-44289f3b9f14db9fcc860c7625e3503deec34821.tar.gz
mktemp: fix for bindir vs base_bindir
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/mktemp')
-rw-r--r--recipes/mktemp/mktemp_1.6.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes/mktemp/mktemp_1.6.bb b/recipes/mktemp/mktemp_1.6.bb
index d0312d5f8b..ca54075688 100644
--- a/recipes/mktemp/mktemp_1.6.bb
+++ b/recipes/mktemp/mktemp_1.6.bb
@@ -2,20 +2,22 @@ DESCRIPTION = "Allow safe temporary file creation from shell scripts."
HOMEPAGE = "http://www.mktemp.org/"
SECTION = "console/utils"
LICENSE = "GPLv2 BSD"
+PR = "r2"
inherit autotools update-alternatives
EXTRA_OECONF = "--with-libc"
SRC_URI = "\
- ftp://ftp.mktemp.org/pub/mktemp/${P}.tar.gz \
- file://add_destdir.patch \
- file://disable-strip.patch \
+ ftp://ftp.mktemp.org/pub/mktemp/${BP}.tar.gz \
+ file://add_destdir.patch \
+ file://disable-strip.patch \
"
-do_install_append () {
- mkdir ${D}${base_bindir}
- mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp.${PN}
+bindir = "${base_bindir}"
+
+do_install_append_pn-mktemp () {
+ mv ${D}${base_bindir}/mktemp ${D}${base_bindir}/mktemp.${PN}
}
ALTERNATIVE_NAME = "mktemp"