aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mrtg
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-26 18:17:17 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-27 22:50:20 +0300
commit90869a3727a820b60064c30f05832c7ad3436a27 (patch)
tree875eba6a7b21f6c7743382f60f414b9ab35fedca /recipes/mrtg
parent51c8adb7ab9af674a402966befd6d5a55177167d (diff)
downloadopenembedded-90869a3727a820b60064c30f05832c7ad3436a27.tar.gz
mrtg: new recipe
The Multi Router Traffic Grapher (MRTG) is a tool to monitor the traffic load on network links. MRTG generates HTML pages containing PNG images which provide a LIVE visual representation of this traffic. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/mrtg')
-rw-r--r--recipes/mrtg/mrtg.inc40
-rw-r--r--recipes/mrtg/mrtg_2.16.3.bb3
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes/mrtg/mrtg.inc b/recipes/mrtg/mrtg.inc
new file mode 100644
index 0000000000..afe4398665
--- /dev/null
+++ b/recipes/mrtg/mrtg.inc
@@ -0,0 +1,40 @@
+DESCRIPTION = "The Multi Router Traffic Grapher"
+SECTION = "net"
+DEPENDS = "gd perl-native"
+RDEPENDS = " \
+ gd \
+ net-snmp-server \
+ perl \
+ perl-module-carp-heavy \
+ perl-module-findbin \
+ perl-module-getopt-long \
+ perl-module-io \
+ perl-module-io-socket \
+ perl-module-locale \
+ perl-module-math-bigfloat \
+ perl-module-math-bigint \
+ perl-module-overload \
+ perl-module-pod-text \
+ perl-module-universal \
+ "
+LICENSE = "GPL"
+
+PR = "r0"
+
+SRC_URI = "http://oss.oetiker.ch/mrtg/pub/mrtg-${PV}.tar.gz;name=mrtg-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ export long_long_format_specifier="%lld"
+}
+
+do_install_append() {
+ for file in ${bindir}/mrtg ${bindir}/indexmaker ${bindir}/cfgmaker ${bindir}/mrtg-traffic-sum; do
+ sed -ri "s,${STAGING_BINDIR_NATIVE},${bindir}," ${D}/$file
+ done
+ install -d ${D}/etc/mrtg
+ install -d ${D}/var/db/mrtg
+}
+
+FILES_${PN} += "${libdir}/mrtg2 ${datadir}/mrtg2 ${sysconfdir}/mrtg ${localstatedir}/db/mrtg" \ No newline at end of file
diff --git a/recipes/mrtg/mrtg_2.16.3.bb b/recipes/mrtg/mrtg_2.16.3.bb
new file mode 100644
index 0000000000..632e341b04
--- /dev/null
+++ b/recipes/mrtg/mrtg_2.16.3.bb
@@ -0,0 +1,3 @@
+require mrtg.inc
+SRC_URI[mrtg-2.16.3.md5sum] = "dfdda80c1d575081458cede58f979d81"
+SRC_URI[mrtg-2.16.3.sha256sum] = "d5d04b8ab104200d370676813e924470d73cfe12b84380f4e17bc6a44cd498ed" \ No newline at end of file