aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nautilus
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-02 12:46:11 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-02 12:48:38 +0200
commitfb82cf69a9114da395d8f4b452fc53423d077422 (patch)
tree2fab7fc7b4b3e48fd5ef5fcc743632c892f96252 /recipes/nautilus
parent6856ab2772f19a4c6e0fbe63b7f176dac27c5b20 (diff)
downloadopenembedded-fb82cf69a9114da395d8f4b452fc53423d077422.tar.gz
nautilus: update to 2.28
Diffstat (limited to 'recipes/nautilus')
-rw-r--r--recipes/nautilus/nautilus_2.28.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/nautilus/nautilus_2.28.0.bb b/recipes/nautilus/nautilus_2.28.0.bb
new file mode 100644
index 0000000000..e3a551c76f
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.28.0.bb
@@ -0,0 +1,37 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+SRC_URI += "file://idl-sysroot.patch;patch=1 \
+ file://no-try-run-strftime.diff;patch=1 \
+"
+
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+LICENSE="GPL"
+
+DEPENDS += "libunique gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
+RDEPENDS = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
+
+EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+do_configure_prepend() {
+ sed -i -e /docs/d Makefile.am
+}
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+ find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+do_stage() {
+ autotools_stage_all
+}