aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/sword
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/sword
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/sword')
-rw-r--r--recipes/nonworking/sword/gnomesword_2.1.2.bb11
-rw-r--r--recipes/nonworking/sword/sword-1.5.9/gcc-visibility.patch26
-rw-r--r--recipes/nonworking/sword/sword_1.5.10.bb19
-rw-r--r--recipes/nonworking/sword/sword_1.5.9.bb20
4 files changed, 76 insertions, 0 deletions
diff --git a/recipes/nonworking/sword/gnomesword_2.1.2.bb b/recipes/nonworking/sword/gnomesword_2.1.2.bb
new file mode 100644
index 0000000000..a4ec60d040
--- /dev/null
+++ b/recipes/nonworking/sword/gnomesword_2.1.2.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "GUI frontend for sword"
+HOMEPAGE = "http://gnomesword.sf.net"
+LICENSE = "GPLv3"
+DEPENDS = "gail libgnomeui gtkhtml-3.6 gail sword"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+
diff --git a/recipes/nonworking/sword/sword-1.5.9/gcc-visibility.patch b/recipes/nonworking/sword/sword-1.5.9/gcc-visibility.patch
new file mode 100644
index 0000000000..f23a66767f
--- /dev/null
+++ b/recipes/nonworking/sword/sword-1.5.9/gcc-visibility.patch
@@ -0,0 +1,26 @@
+diff --git a/include/rawtext.h b/include/rawtext.h
+index 32986fe..1304bf7 100644
+--- a/include/rawtext.h
++++ b/include/rawtext.h
+@@ -43,7 +43,7 @@ public:
+ virtual ~RawText();
+ virtual SWBuf &getRawEntryBuf();
+ virtual void increment(int steps = 1);
+- virtual void decrement(int steps = 1) { increment(-steps); }
++ virtual __attribute__((visibility("default"))) void decrement(int steps = 1) { increment(-steps); }
+ virtual signed char createSearchFramework(
+ void (*percent) (char, void *) = &nullPercent,
+ void *percentUserData = 0);
+diff --git a/include/versekey.h b/include/versekey.h
+index 0ca5e47..53084d9 100644
+--- a/include/versekey.h
++++ b/include/versekey.h
+@@ -253,7 +253,7 @@ public:
+ */
+ virtual const char *getText() const;
+ virtual const char *getShortText() const;
+- virtual void setText(const char *ikey) { SWKey::setText(ikey); parse (); }
++ virtual __attribute__((visibility("default"))) void setText(const char *ikey) { SWKey::setText(ikey); parse (); }
+ virtual void copyFrom(const SWKey &ikey);
+
+ /** Equates this VerseKey to another VerseKey
diff --git a/recipes/nonworking/sword/sword_1.5.10.bb b/recipes/nonworking/sword/sword_1.5.10.bb
new file mode 100644
index 0000000000..151bba366d
--- /dev/null
+++ b/recipes/nonworking/sword/sword_1.5.10.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "The SWORD Project is an open source, cross-platform \
+(Linux, Windows, Solaris, MacOSX etc.) API and library for \
+Bible software with a constantly growing list of front-ends \
+(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
+SECTION = "libs"
+HOMEPAGE = "http://www.e-sword.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+EXTRA_OECONF = "--without-clucene --without-curl"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/nonworking/sword/sword_1.5.9.bb b/recipes/nonworking/sword/sword_1.5.9.bb
new file mode 100644
index 0000000000..303d7f9fcc
--- /dev/null
+++ b/recipes/nonworking/sword/sword_1.5.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "The SWORD Project is an open source, cross-platform \
+(Linux, Windows, Solaris, MacOSX etc.) API and library for \
+Bible software with a constantly growing list of front-ends \
+(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
+SECTION = "libs"
+HOMEPAGE = "http://www.e-sword.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz \
+ file://gcc-visibility.patch;patch=1"
+
+inherit autotools pkgconfig lib_package
+
+EXTRA_OECONF = "--without-clucene --without-curl"
+
+do_stage() {
+ autotools_stage_all
+}