aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/notification-daemon
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/notification-daemon
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/notification-daemon')
-rw-r--r--recipes/notification-daemon/files/dbus-glib-tool-prefix.patch13
-rw-r--r--recipes/notification-daemon/files/notification-daemon-fix-text-color.diff44
-rw-r--r--recipes/notification-daemon/notification-daemon_0.3.6.bb20
-rw-r--r--recipes/notification-daemon/notification-daemon_0.3.7.bb20
4 files changed, 97 insertions, 0 deletions
diff --git a/recipes/notification-daemon/files/dbus-glib-tool-prefix.patch b/recipes/notification-daemon/files/dbus-glib-tool-prefix.patch
new file mode 100644
index 0000000000..bfe06f7737
--- /dev/null
+++ b/recipes/notification-daemon/files/dbus-glib-tool-prefix.patch
@@ -0,0 +1,13 @@
+Index: notification-daemon-0.3.6/src/Makefile.am
+===================================================================
+--- notification-daemon-0.3.6.orig/src/Makefile.am 2007-01-15 16:25:37.000000000 +0100
++++ notification-daemon-0.3.6/src/Makefile.am 2007-01-15 16:26:01.000000000 +0100
+@@ -13,7 +13,7 @@
+ BUILT_SOURCES = notificationdaemon-dbus-glue.h
+
+ notificationdaemon-dbus-glue.h: notificationdaemon.xml
+- dbus-binding-tool --mode=glib-server \
++ dbus-binding-tool --mode=glib-server --prefix= \
+ $(srcdir)/notificationdaemon.xml > notificationdaemon-dbus-glue.h
+
+ INCLUDES = \
diff --git a/recipes/notification-daemon/files/notification-daemon-fix-text-color.diff b/recipes/notification-daemon/files/notification-daemon-fix-text-color.diff
new file mode 100644
index 0000000000..aacb507151
--- /dev/null
+++ b/recipes/notification-daemon/files/notification-daemon-fix-text-color.diff
@@ -0,0 +1,44 @@
+--- notification-daemon-0.3.7.orig/src/themes/standard/theme.c 2007-01-26 04:20:15.000000000 +0000
++++ notification-daemon-0.3.7/src/themes/standard/theme.c 2008-04-18 12:14:33.000000000 +0100
+@@ -653,6 +653,23 @@
+ return FALSE;
+ }
+
++
++static void
++style_set_cb (GtkWidget *label, GtkStyle *previous_style, WindowData *windata)
++{
++ static gboolean in_style_set_cb;
++
++ if (in_style_set_cb)
++ return;
++
++ in_style_set_cb = TRUE;
++
++ gtk_widget_modify_fg (label, GTK_STATE_NORMAL,
++ &label->style->text[GTK_STATE_NORMAL]);
++
++ in_style_set_cb = FALSE;
++}
++
+ GtkWindow *
+ create_notification(UrlClickedCb url_clicked)
+ {
+@@ -753,6 +770,8 @@
+ gtk_widget_set_size_request(spacer, SPACER_LEFT, -1);
+
+ windata->summary_label = gtk_label_new(NULL);
++ g_signal_connect(windata->summary_label, "style-set",
++ G_CALLBACK(style_set_cb), windata);
+ gtk_widget_show(windata->summary_label);
+ gtk_box_pack_start(GTK_BOX(hbox), windata->summary_label, TRUE, TRUE, 0);
+ gtk_misc_set_alignment(GTK_MISC(windata->summary_label), 0, 0);
+@@ -800,6 +819,8 @@
+ gtk_box_pack_start(GTK_BOX(windata->content_hbox), vbox, TRUE, TRUE, 0);
+
+ windata->body_label = sexy_url_label_new();
++ g_signal_connect(windata->body_label, "style-set",
++ G_CALLBACK(style_set_cb), windata);
+ gtk_box_pack_start(GTK_BOX(vbox), windata->body_label, TRUE, TRUE, 0);
+ gtk_misc_set_alignment(GTK_MISC(windata->body_label), 0, 0);
+ gtk_label_set_line_wrap(GTK_LABEL(windata->body_label), TRUE);
diff --git a/recipes/notification-daemon/notification-daemon_0.3.6.bb b/recipes/notification-daemon/notification-daemon_0.3.6.bb
new file mode 100644
index 0000000000..5a76d10b31
--- /dev/null
+++ b/recipes/notification-daemon/notification-daemon_0.3.6.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A dbus service that listens to desktop notification requests and displays them"
+HOMEPAGE = "http://www.galago-project.org/"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gettext dbus gtk+ libsexy gconf libwnck"
+PR = "r1"
+
+SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+ file://dbus-glib-tool-prefix.patch;patch=1"
+
+EXTRA_OECONF = "--disable-binreloc"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "\
+ ${libexecdir}/notification-daemon \
+ ${datadir}/dbus-1/services \
+ ${libdir}/notification-daemon-1.0/engines/libstandard.so \
+ ${sysconfdir}/gconf/schemas/notification-daemon.schemas \
+"
diff --git a/recipes/notification-daemon/notification-daemon_0.3.7.bb b/recipes/notification-daemon/notification-daemon_0.3.7.bb
new file mode 100644
index 0000000000..4f38ea9ff9
--- /dev/null
+++ b/recipes/notification-daemon/notification-daemon_0.3.7.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A dbus service that listens to desktop notification requests and displays them"
+HOMEPAGE = "http://www.galago-project.org/"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gettext dbus gtk+ libsexy gconf libwnck"
+PR = "r1"
+
+SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+ file://notification-daemon-fix-text-color.diff;patch=1"
+
+EXTRA_OECONF = "--disable-binreloc"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "\
+ ${libexecdir}/notification-daemon \
+ ${datadir}/dbus-1/services/ \
+ ${libdir}/notification-daemon-1.0/engines/libstandard.so \
+ ${sysconfdir}/gconf/schemas/notification-daemon.schemas \
+"