aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-24 10:16:41 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-24 20:10:47 +0100
commit45809c052d7d6030675b9da0a95db705fafbc740 (patch)
tree9eb482495a2484463186a4eac90690bdf27b9717 /recipes/opkg
parent046c7c5f1cdec5c92f6a365d8846ba33986277b6 (diff)
downloadopenembedded-45809c052d7d6030675b9da0a95db705fafbc740.tar.gz
opkg: add tmp_dir option to opkg.conf for SHR
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/opkg')
-rw-r--r--recipes/opkg/opkg-collateral.bb11
-rw-r--r--recipes/opkg/opkg-collateral/tmp_dir4
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/opkg/opkg-collateral.bb b/recipes/opkg/opkg-collateral.bb
index 401e76e8be..a7ec321c6f 100644
--- a/recipes/opkg/opkg-collateral.bb
+++ b/recipes/opkg/opkg-collateral.bb
@@ -1,11 +1,12 @@
DESCRIPTION = "opkg configuration files"
SECTION = "base"
LICENSE = "MIT"
-PR = "r1"
+PR = "r2"
SRC_URI = "file://opkg.conf.comments \
file://lists \
file://dest \
+ file://tmp_dir \
file://src "
do_compile () {
@@ -15,9 +16,17 @@ do_compile () {
cat ${WORKDIR}/lists >>${WORKDIR}/opkg.conf
}
+do_compile_append_shr () {
+ cat ${WORKDIR}/tmp_dir >>${WORKDIR}/opkg.conf
+}
+
do_install () {
install -d ${D}${sysconfdir}/opkg
install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
}
+do_install_append_shr () {
+ install -d ${D}/var/lib/opkg/tmp
+}
+
CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"
diff --git a/recipes/opkg/opkg-collateral/tmp_dir b/recipes/opkg/opkg-collateral/tmp_dir
new file mode 100644
index 0000000000..7ba6abf6cf
--- /dev/null
+++ b/recipes/opkg/opkg-collateral/tmp_dir
@@ -0,0 +1,4 @@
+# We have whole /tmp in volatile tmpfs which is better than wear leveling NAND or uSD
+# But also bad for big upgrades where tmpfs eats whole memory,
+# device starts swapping (possibly using more NAND/uSD than temporary unpack) and then segfaults because of lack of space
+option tmp_dir /var/lib/opkg/tmp