aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/palmpre
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-02-25 22:43:59 +0100
committerSimon Busch <morphis@gravedo.de>2011-02-27 13:58:04 +0100
commit3eda2bfe44698b3abb64e5f81ecfad5bad1bc990 (patch)
tree42cd39c0b9625c4c03232e33bd8997342a75094b /recipes/palmpre
parent15de5d3ab224abf7e97ad0d249cb5053b34fc873 (diff)
downloadopenembedded-3eda2bfe44698b3abb64e5f81ecfad5bad1bc990.tar.gz
tsmd: install also a little helper script to control the touchscreen daemon
Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/palmpre')
-rwxr-xr-xrecipes/palmpre/tsmd/tsmd_control12
-rw-r--r--recipes/palmpre/tsmd_git.bb5
2 files changed, 16 insertions, 1 deletions
diff --git a/recipes/palmpre/tsmd/tsmd_control b/recipes/palmpre/tsmd/tsmd_control
new file mode 100755
index 0000000000..a7668d4d1a
--- /dev/null
+++ b/recipes/palmpre/tsmd/tsmd_control
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+case "$1" in
+ enable)
+ kill -USR2 `pidof tsmd`
+ ;;
+ disable)
+ kill -USR1 `pidof tsmd`
+ ;;
+ *)
+ ;;
+esac
diff --git a/recipes/palmpre/tsmd_git.bb b/recipes/palmpre/tsmd_git.bb
index a7c6054037..0cef19edc1 100644
--- a/recipes/palmpre/tsmd_git.bb
+++ b/recipes/palmpre/tsmd_git.bb
@@ -6,13 +6,14 @@ LICENSE = "GPL"
DEPENDS = "tslib"
-PR = "r2"
+PR = "r3"
PV = "1.0.0+gitr${SRCPV}"
SRCREV = "9262a2e4f8f6e6c7bcacf1eeae0ad348cbfcce06"
SRC_URI = " \
${FREESMARTPHONE_GIT}/utilities.git;protocol=git;branch=master \
file://tsmd \
+ file://tsmd_control \
"
S = "${WORKDIR}/git/palmpre/tsmd"
@@ -27,4 +28,6 @@ INITSCRIPT_PARAMS = "defaults 10"
do_install_append() {
install -d 0644 ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
+ install -d 0644 ${D}${base_bindir}/
+ install -m 0755 ${WORKDIR}/tsmd_control ${D}${base_bindir}/tsmd_control
}