aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/puzzles/stppc2x_svn.bb
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-11-03 18:31:43 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 17:36:48 +0100
commit70b504ea5a3f1a4903a412dbf06e914ac0807bc1 (patch)
treee3fd86f5a06e15aecc59a743a76b173e2215f337 /recipes/puzzles/stppc2x_svn.bb
parent714f41f603dc86d7a944ab4dd71feeb79d76c220 (diff)
downloadopenembedded-70b504ea5a3f1a4903a412dbf06e914ac0807bc1.tar.gz
stppc2x: Added recipe for stppc2x, a port of puzzles to SDL.
* Added dirs-fix.patch, which changes the default directories for the game data to a systemwide /usr/share/games/stppc2x setting and changes the default font to DejaVuSans-Condensed. * Added enable-fullscreen.patch, which, um, makes the game fullscreen. * Added generic-keys.patch, which changes the game keys to more generic ones (for devices with QWERTY keyboards) and changes the default control system from mouse-emulation to keyboard controlled. * Added a modified Makefile, compatible to how OE handles CFLAGS and LDFLAGS by moving additional defines to INCS and LIBS, respectively. * Added no-music.patch, which disables music. Remember to add libsdl-mixer to DEPENDS if you decide not to apply this. * Added no-upper-mem.patch, which disables the OPTION_USE_UPPER_MEMORY hack, which makes stppc2x segfault on the Ben Nanonote and is useless outside of the GP2X. * Added stppc2x-extras.tar.gz, which contains modified versions of the stppc2x splash screen and help messages (respective to the generic-keys patch above). * Added stppc2x.desktop and accompanying stppc2x.png files. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/puzzles/stppc2x_svn.bb')
-rw-r--r--recipes/puzzles/stppc2x_svn.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/puzzles/stppc2x_svn.bb b/recipes/puzzles/stppc2x_svn.bb
new file mode 100644
index 0000000000..380a75398d
--- /dev/null
+++ b/recipes/puzzles/stppc2x_svn.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "stppc2x is an SDL port of Simon Tatham's Portable Puzzle Collection"
+LICENSE = "GPLv2"
+
+DEPENDS = "virtual/libsdl libsdl-image libsdl-ttf"
+RDEPENDS = "ttf-dejavu-sans-condensed"
+
+SRCREV = "185"
+PV = "1.0+svnr${SRCPV}"
+PR = "r0"
+
+FILES_${PN} = "/usr/bin /usr/share"
+
+SRC_URI = "svn://stppc2x.googlecode.com/svn/;module=trunk;proto=http \
+ file://stppc2x-extras.tar.gz \
+ file://no-upper-mem.patch \
+ file://generic-keys.patch \
+ file://no-music.patch \
+ file://enable-fullscreen.patch \
+ file://dir-fix.patch \
+ file://stppc2x.desktop \
+ file://stppc2x.png \
+ file://Makefile"
+
+S = "${WORKDIR}/trunk"
+
+do_configure() {
+ mv ${WORKDIR}/Makefile ${S}
+ mv ${WORKDIR}/extras/help/* ${S}/help
+ mv ${WORKDIR}/extras/images/* ${S}/images
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+
+ install -m 0644 ${WORKDIR}/stppc2x.png ${D}${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/stppc2x.desktop ${D}${datadir}/applications
+}