aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-coherence_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-coherence_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-coherence_svn.bb')
-rw-r--r--recipes/python/python-coherence_svn.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/python/python-coherence_svn.bb b/recipes/python/python-coherence_svn.bb
new file mode 100644
index 0000000000..031067672e
--- /dev/null
+++ b/recipes/python/python-coherence_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Coherence is a DLNA/UPnP mediaserver + backends"
+SECTION = "devel/python"
+LICENSE = "MIT"
+HOMEPAGE = "http://coherence.beebits.net/wiki"
+
+PR = "r1"
+
+PV = "0.6.0+svnr${SRCREV}"
+
+inherit setuptools
+
+DISTUTILS_INSTALL_ARGS = "--root=${D} \
+ --prefix=${prefix} \
+ --install-data=${datadir}"
+
+SRC_URI = "svn://coherence.beebits.net/svn/trunk;module=Coherence;proto=https"
+S = "${WORKDIR}/Coherence"
+
+FILES_${PN} += "${datadir}"
+RDEPENDS_${PN} += "python-twisted-pair python-divmodepsilon python-nevow python-gst python-dbus \
+ python-configobj python-twisted python-twisted-core python-twisted-protocols python-misc \
+ python-zopeinterface zope python-modules python-pygobject python-gdata python-inotify \
+ python-divmodaxiom"
+
+